Merge branch 'master' of ssh://git.onelab.eu/git/sliver-openvswitch
[sliver-openvswitch.git] / sliver-openvswitch.spec
1 %define name sliver-openvswitch
2 # to check for any change:
3 # grep AC_INIT configure.ac 
4 %define version 1.9.90
5 %define taglevel 3
6
7 %define debug_package %{nil}
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Vendor: OneLab
12 Packager: OneLab <support@planet-lab.eu>
13 Distribution: PlanetLab %{plrelease}
14 URL: %{SCMURL}
15 # Dependencies
16 # mar 2013 - because of the move to f18 I have to turn off auto requires
17 # this is because rpm would otherwise find deps to /bin/python and /bin/perl
18 # In other modules I was able to solve this by referring to /usr/bin/python 
19 # instead of just python in the builds scripts, but here it looks too complex
20 AutoReq: no
21
22 Summary: Openvswitch modified for running from a PlanetLab sliver
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Applications
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 Source0: sliver-openvswitch-%{version}.tar.gz
30
31 %description
32 Openvswitch tuned for running within a PlanetLab sliver
33
34 %prep 
35 %setup -q
36
37 %build
38 ./boot.sh
39 # let's be as close as the regular linux/fedora layout
40 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-logdir=/var/log
41 make
42
43 %install
44 make install DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /usr/bin/*
51 /usr/sbin/*
52 /usr/share/openvswitch
53 /usr/share/man
54
55 %post
56
57 %postun
58
59 %changelog
60 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.9.90-3
61 - pulled mainstream - amazingly this is still known as 1.9.90 despite the size of changes
62
63 * Fri Dec 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.9.90-2
64 - merged with upstream
65 - handling of promisc &up/down flags for tap devices
66 - small improvements to the Makefile
67
68 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-6
69 - fixes in the exp-tool makefile (bash redirections, scp with key..)
70
71 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-5
72 - numerous additional make targets for finer control (use make help)
73 - including gprobe for reporting traffic to an ndnmap instance
74 - related, more functions in sliver-ovs as well, like exposing
75 - detailed info (mac, dpids..) relevant to the OF controller
76 - retrieving rx_bytes/tx_bytes (fixed) accessible through ovs-appctl
77
78 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-4
79 - fix file descriptor leaks
80
81 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-3
82 - can specify OpenFlow controller ip/port for each ovs instance
83 - through $(CONTROLLER_<id>), or $(CONTROLLER) by default
84
85 * Thu Sep 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-2
86 - add/skip packet information on tap send/recv
87
88 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-1
89 - merged mainstream 1.8.90
90 - planetlab extensions to the openvswitch: single helper command tool 'sliver-ovs' in /usr/sbin
91 - planetlab exp-tool : single config file (conf.mk)
92 - planetlab exp-tool : can retrieve and save current topology