Merge branch 'mainstream'
[sliver-openvswitch.git] / sliver-openvswitch.spec
1 %define name sliver-openvswitch
2 # to check for any change:
3 # grep AC_INIT configure.ac 
4 %define version 1.6.90
5 %define taglevel 1
6
7 %define debug_package %{nil}
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Vendor: OneLab
12 Packager: OneLab <support@planet-lab.eu>
13 Distribution: PlanetLab %{plrelease}
14 URL: %{SCMURL}
15 #Requires: 
16
17 Summary: Openvswitch modified for running from a PlanetLab sliver
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Applications
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 Source0: sliver-openvswitch-%{version}.tar.gz
25
26 %description
27 Openvswitch tuned for running within a PlanetLab sliver
28
29 %prep 
30 %setup -q
31
32 %build
33 ./boot.sh
34 # let's be as close as the regular linux/fedora layout
35 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
36 make
37
38 %install
39 make install DESTDIR=$RPM_BUILD_ROOT
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 /usr
46
47 %post
48
49 %postun
50
51 %changelog