try to trim package of debugging stuff
[sliver-openvswitch.git] / sliver-openvswitch.spec
1 %define name sliver-openvswitch
2 %define version 0.1
3 %define taglevel 1
4
5 %global __debug_package 0
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Vendor: OneLab
10 Packager: OneLab <support@planet-lab.eu>
11 Distribution: PlanetLab %{plrelease}
12 URL: %{SCMURL}
13 #Requires: 
14
15 Summary: Openvswitch modified for running from a PlanetLab sliver
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 License: GPL
20 Group: System Environment/Applications
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22 Source0: sliver-openvswitch-%{version}.tar.gz
23
24 %description
25 Openvswitch tuned for running within a PlanetLab sliver
26
27 %prep 
28 %setup -q
29
30 %build
31 ./boot.sh
32 ./configure --prefix=/usr
33 make
34
35 %install
36 make install DESTDIR=$RPM_BUILD_ROOT
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 /usr
43
44 %post
45
46 %postun
47
48 %changelog