Merge commit '180c6d0b440961cbc873c4d045eb8b2daa1364e9'
[sliver-openvswitch.git] / sliver-openvswitch.spec
1 %define name sliver-openvswitch
2 # to check for any change:
3 # grep AC_INIT configure.ac 
4 %define version 1.10.90
5 %define taglevel 2
6
7 %define debug_package %{nil}
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Vendor: OneLab
12 Packager: OneLab <support@planet-lab.eu>
13 Distribution: PlanetLab %{plrelease}
14 URL: %{SCMURL}
15 # Dependencies
16 # mar 2013 - because of the move to f18 I have to turn off auto requires
17 # this is because rpm would otherwise find deps to /bin/python and /bin/perl
18 # In other modules I was able to solve this by referring to /usr/bin/python 
19 # instead of just python in the builds scripts, but here it looks too complex
20 AutoReq: no
21
22 Summary: Openvswitch modified for running from a PlanetLab sliver
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Applications
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 Source0: sliver-openvswitch-%{version}.tar.gz
30
31 %description
32 Openvswitch tuned for running within a PlanetLab sliver
33
34 %prep 
35 %setup -q
36
37 %build
38 ./boot.sh
39 # let's be as close as the regular linux/fedora layout
40 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-logdir=/var/log
41 make
42
43 %install
44 make install DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /usr/bin/*
51 /usr/sbin/*
52 /usr/share/openvswitch
53 /usr/share/man
54
55 %post
56
57 %postun
58
59 %changelog
60 * Wed May 01 2013 Giuseppe Lettieri <g.lettieri@iet.unipi.it> - sliver-openvswitch-1.10.90-2
61 - - fixed several bugs in the external-nodes support in exp-tool/Makefile
62 - - let sliver-ovs return an error if tap device configuration failed
63
64 * Mon Apr 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.10.90-1
65 - merged with upstream (develoment version 1.10.90)
66 - integrated ALLEGRA contributions for the termination of virtual cables in external nodes.
67
68 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.9.90-3
69 - pulled mainstream - amazingly this is still known as 1.9.90 despite the size of changes
70
71 * Fri Dec 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.9.90-2
72 - merged with upstream
73 - handling of promisc &up/down flags for tap devices
74 - small improvements to the Makefile
75
76 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-6
77 - fixes in the exp-tool makefile (bash redirections, scp with key..)
78
79 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-5
80 - numerous additional make targets for finer control (use make help)
81 - including gprobe for reporting traffic to an ndnmap instance
82 - related, more functions in sliver-ovs as well, like exposing
83 - detailed info (mac, dpids..) relevant to the OF controller
84 - retrieving rx_bytes/tx_bytes (fixed) accessible through ovs-appctl
85
86 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-4
87 - fix file descriptor leaks
88
89 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-3
90 - can specify OpenFlow controller ip/port for each ovs instance
91 - through $(CONTROLLER_<id>), or $(CONTROLLER) by default
92
93 * Thu Sep 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-2
94 - add/skip packet information on tap send/recv
95
96 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-1
97 - merged mainstream 1.8.90
98 - planetlab extensions to the openvswitch: single helper command tool 'sliver-ovs' in /usr/sbin
99 - planetlab exp-tool : single config file (conf.mk)
100 - planetlab exp-tool : can retrieve and save current topology