configure: Silence check for broken strtok_r().
[sliver-openvswitch.git] / xenserver / vswitch-xen.spec
1 # Spec file for vswitch and related programs.
2
3 # Copyright (C) 2009, 2010 Nicira Networks, Inc.
4 #
5 # Copying and distribution of this file, with or without modification,
6 # are permitted in any medium without royalty provided the copyright
7 # notice and this notice are preserved.  This file is offered as-is,
8 # without warranty of any kind.
9
10 # When building, the rpmbuild command line should define
11 # vswitch_version, xen_version, and build_number using -D arguments.
12 # for example:
13 #
14 #    rpmbuild -D "vswitch_version 0.8.9~1+build123" -D "xen_version 2.6.18-128.1.1.el5.xs5.1.0.483.1000xen" -D "build_number --with-build-number=123" -bb /usr/src/redhat/SPECS/vswitch-xen.spec
15 #
16 %define version %{vswitch_version}-%{xen_version}
17
18 Name: vswitch
19 Summary: Virtual switch
20 Group: System Environment/Daemons
21 URL: http://www.openvswitch.org/
22 Version: %{vswitch_version}
23
24 # The entire source code is ASL 2.0 except datapath/ which is GPLv2
25 License: ASL 2.0 and GPLv2
26 Release: 1
27 Source: openvswitch-%{vswitch_version}.tar.gz
28 Buildroot: /tmp/vswitch-xen-rpm
29 Requires: kernel-xen = %(echo '%{xen_version}' | sed 's/xen$//')
30 # The following Conflicts prevents the "vswitch" package generated by
31 # this spec file from installing at the same time as the "openvswitch"
32 # package shipped with XenServer 5.5.900.  In fact, the packages
33 # contain some files with identical names anyhow, so they will not
34 # coexist, but adding an explicit Conflicts makes this conflict more
35 # obvious.
36 Conflicts: openvswitch
37
38 %description
39 The vswitch provides standard network bridging functions augmented with
40 support for the OpenFlow protocol for remote per-flow control of
41 traffic.
42
43 %prep
44 %setup -q -n openvswitch-%{vswitch_version}
45
46 %build
47 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=%{_localstatedir} --with-l26=/lib/modules/%{xen_version}/build --enable-ssl %{build_number}
48 make %{_smp_mflags}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 make install DESTDIR=$RPM_BUILD_ROOT
53 install -d -m 755 $RPM_BUILD_ROOT/etc
54 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
55 install -m 755 xenserver/etc_init.d_vswitch \
56          $RPM_BUILD_ROOT/etc/init.d/vswitch
57 install -m 755 xenserver/etc_init.d_vswitch-xapi-update \
58          $RPM_BUILD_ROOT/etc/init.d/vswitch-xapi-update
59 install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
60 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d
61 install -m 755 xenserver/etc_logrotate.d_vswitch \
62          $RPM_BUILD_ROOT/etc/logrotate.d/vswitch
63 install -d -m 755 $RPM_BUILD_ROOT/etc/profile.d
64 install -m 755 xenserver/etc_profile.d_vswitch.sh \
65          $RPM_BUILD_ROOT/etc/profile.d/vswitch.sh
66 install -d -m 755 $RPM_BUILD_ROOT/etc/xapi.d/plugins
67 install -m 755 xenserver/etc_xapi.d_plugins_vswitch-cfg-update \
68          $RPM_BUILD_ROOT/etc/xapi.d/plugins/vswitch-cfg-update
69 install -d -m 755 $RPM_BUILD_ROOT/usr/share/vswitch/scripts
70 install -m 755 xenserver/opt_xensource_libexec_interface-reconfigure \
71              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/interface-reconfigure
72 install -m 755 xenserver/opt_xensource_libexec_InterfaceReconfigure.py \
73              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/InterfaceReconfigure.py
74 install -m 755 xenserver/opt_xensource_libexec_InterfaceReconfigureBridge.py \
75              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/InterfaceReconfigureBridge.py
76 install -m 755 xenserver/opt_xensource_libexec_InterfaceReconfigureVswitch.py \
77              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/InterfaceReconfigureVswitch.py
78 install -m 755 xenserver/etc_xensource_scripts_vif \
79              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/vif
80 install -m 755 xenserver/usr_share_vswitch_scripts_dump-vif-details \
81                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/dump-vif-details
82 install -m 755 xenserver/usr_share_vswitch_scripts_refresh-xs-network-uuids \
83                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/refresh-xs-network-uuids
84 install -m 755 xenserver/usr_sbin_xen-bugtool \
85              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/xen-bugtool
86 install -m 755 xenserver/usr_sbin_brctl \
87              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/brctl
88 install -m 755 xenserver/usr_share_vswitch_scripts_sysconfig.template \
89          $RPM_BUILD_ROOT/usr/share/vswitch/scripts/sysconfig.template
90 install -m 644 \
91         xenserver/usr_lib_xsconsole_plugins-base_XSFeatureVSwitch.py \
92                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/XSFeatureVSwitch.py
93
94 install -d -m 755 $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch
95 find datapath/linux-2.6 -name *.ko -exec install -m 755  \{\} $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch \;
96
97 # Get rid of stuff we don't want to make RPM happy.
98 rm \
99     $RPM_BUILD_ROOT/usr/bin/ovs-controller \
100     $RPM_BUILD_ROOT/usr/bin/ovs-discover \
101     $RPM_BUILD_ROOT/usr/bin/ovs-kill \
102     $RPM_BUILD_ROOT/usr/bin/ovs-openflowd \
103     $RPM_BUILD_ROOT/usr/bin/ovs-pki \
104     $RPM_BUILD_ROOT/usr/bin/ovs-wdt \
105     $RPM_BUILD_ROOT/usr/sbin/ovs-monitor \
106     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-controller.8 \
107     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-discover.8 \
108     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-kill.8 \
109     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-openflowd.8 \
110     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-pki.8
111 rm -f $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch/veth_mod.ko
112 rm -r \
113     $RPM_BUILD_ROOT/usr/share/openvswitch/commands
114
115 install -d -m 755 $RPM_BUILD_ROOT/var/lib/openvswitch
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 if [ ! -f /etc/xensource-inventory ]; then
122     printf "XenSource inventory not present in /etc/xensource-inventory"
123     exit 1
124 fi
125
126 if [ "$1" = "1" ]; then
127     if md5sum -c --status <<EOF
128 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
129 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
130 51970ad613a3996d5997e18e44db47da  /opt/xensource/libexec/interface-reconfigure
131 5654c8c36699fcc8744ca9cd5b855414  /usr/sbin/xen-bugtool
132 EOF
133     then
134         printf "\nVerified host scripts from XenServer 5.5.0.\n\n"
135     elif md5sum -c --status <<EOF
136 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
137 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
138 ce451d3c985fd1db6497a363f0d9dedb  /opt/xensource/libexec/interface-reconfigure
139 2b53f500431fcba5276c896e9e4281b9  /usr/sbin/xen-bugtool
140 EOF
141     then
142         printf "\nVerified host scripts from XenServer 5.5.900.\n\n"
143     else
144 cat <<EOF
145
146 The original XenServer scripts replaced by this package are not those
147 of any supported version of XenServer.  This could lead to unexpected
148 behavior of your server.  Unless you are sure you know what you are
149 doing, it is highly recommended that you remove this package
150 immediately after the install completes, which will restore the
151 XenServer scripts that you were previously using.
152
153 EOF
154     fi
155 fi
156
157 if test ! -e /var/xapi/network.dbcache; then
158     if test "$1" = 1; then
159         printf "Creating xapi database cache...  "
160     else
161         printf "warning: Open vSwitch is being re-installed or upgraded,\n"
162         printf "         but the xapi database cache is missing.\n"
163         printf "Re-creating xapi database cache...  "
164     fi
165
166     if /usr/share/vswitch/scripts/interface-reconfigure rewrite; then
167         printf "done.\n"
168     else
169         printf "FAILED\n"
170         printf "Open vSwitch can only be installed on a XenServer that\n"
171         printf "has connectivity to xapi on the pool master.  Please\n"
172         printf "fix connectivity to the pool master, then try again.\n"
173         exit 1
174     fi
175 fi
176
177 # Ensure that modprobe will find our modules.
178 depmod %{xen_version}
179
180 if grep -F net.ipv4.conf.all.arp_filter /etc/sysctl.conf >/dev/null 2>&1; then :; else
181     cat >>/etc/sysctl.conf <<EOF
182 # This works around an issue in xhad, which binds to a particular
183 # Ethernet device, which in turn causes ICMP port unreachable messages
184 # if packets are received are on the wrong interface, which in turn
185 # can happen if we send out ARP replies on every interface (as Linux
186 # does by default) instead of just on the interface that has the IP
187 # address being ARPed for, which this sysctl setting in turn works
188 # around.
189 #
190 # Bug #1378.
191 net.ipv4.conf.all.arp_filter = 1
192 EOF
193 fi
194
195 # Ensure ovs-vswitchd.conf exists
196 touch /etc/ovs-vswitchd.conf
197
198 # Create default or update existing /etc/sysconfig/vswitch.
199 SYSCONFIG=/etc/sysconfig/vswitch
200 TEMPLATE=/usr/share/vswitch/scripts/sysconfig.template
201 if [ ! -e $SYSCONFIG ]; then
202     cp $TEMPLATE $SYSCONFIG
203 else
204     for var in $(awk -F'[ :]' '/^# [_A-Z0-9]+:/{print $2}' $TEMPLATE)
205     do
206         if ! grep $var $SYSCONFIG >/dev/null 2>&1; then
207             echo >> $SYSCONFIG
208             sed -n "/$var:/,/$var=/p" $TEMPLATE >> $SYSCONFIG
209         fi
210     done
211 fi
212
213 # Replace XenServer files by our versions.
214 mkdir -p /usr/lib/vswitch/xs-original \
215     || printf "Could not create script backup directory.\n"
216 for f in \
217     /opt/xensource/libexec/interface-reconfigure \
218     /opt/xensource/libexec/InterfaceReconfigure.py \
219     /opt/xensource/libexec/InterfaceReconfigureBridge.py \
220     /opt/xensource/libexec/InterfaceReconfigureVswitch.py \
221     /etc/xensource/scripts/vif \
222     /usr/sbin/xen-bugtool \
223     /usr/sbin/brctl
224 do
225     s=$(basename "$f")
226     t=$(readlink "$f")
227     if [ -f "$f" ] && [ "$t" != "/usr/share/vswitch/scripts/$s" ]; then
228         mv "$f" /usr/lib/vswitch/xs-original/ \
229             || printf "Could not save original XenServer $s script\n"
230         ln -s "/usr/share/vswitch/scripts/$s" "$f" \
231             || printf "Could not link to vSwitch $s script\n"
232     fi
233 done
234
235 # Install xsconsole plugin
236 plugin=$(readlink /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py)
237 if [ "$plugin" != "/usr/share/vswitch/scripts/XSFeatureVSwitch.py" ]; then
238     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
239     ln -s /usr/share/vswitch/scripts/XSFeatureVSwitch.py /usr/lib/xsconsole/plugins-base/ || printf "Could not link to vSswitch xsconsole plugin.\n"
240 fi
241
242 # Ensure all required services are set to run
243 for s in vswitch vswitch-xapi-update; do
244     if chkconfig --list $s >/dev/null 2>&1; then
245         chkconfig --del $s || printf "Could not remove $s init script."
246     fi
247     chkconfig --add $s || printf "Could not add $s init script."
248     chkconfig $s on || printf "Could not enable $s init script."
249 done
250
251 # Configure system to use vswitch
252 echo vswitch > /etc/xensource/network.conf
253
254 if [ "$1" = "1" ]; then    # $1 = 2 for upgrade
255     printf "\nYou MUST reboot the server NOW to complete the change to the\n"
256     printf "the vSwitch.  Attempts to modify networking on the server\n"
257     printf "or any hosted VM will fail until after the reboot and could\n"
258     printf "leave the server in an state requiring manual recovery.\n\n"
259 else
260     printf "\nTo use the new vSwitch, you should reboot the server\n"
261     printf "now.  Failure to do so may result in incorrect operation.\n\n"
262 fi
263
264 %preun
265 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
266     for s in vswitch vswitch-xapi-update; do
267         chkconfig --del $s || printf "Could not remove $s init script."
268     done
269 fi
270
271
272 %postun
273 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
274
275     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py \
276         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyc \
277         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyo \
278         || printf "Could not remove vSwitch xsconsole plugin.\n"
279
280     # Restore original XenServer scripts
281     for f in \
282         /opt/xensource/libexec/interface-reconfigure \
283         /etc/xensource/scripts/vif \
284         /usr/sbin/xen-bugtool \
285         /usr/sbin/brctl
286     do
287         s=$(basename "$f")
288         if [ ! -f "/usr/lib/vswitch/xs-original/$s" ]; then
289             printf "Original XenServer $s script not present in /usr/lib/vswitch/xs-original\n"
290             printf "Could not restore original XenServer script.\n"
291         else
292             (rm -f "$f" \
293                 && mv "/usr/lib/vswitch/xs-original/$s" "$f") \
294                 || printf "Could not restore original XenServer $s script.\n"
295         fi
296     done
297
298     # Remove all configuration files
299     rm -f /etc/ovs-vswitchd.conf
300     rm -f /etc/sysconfig/vswitch
301     rm -f /etc/ovs-vswitchd.cacert
302     rm -f /var/xapi/network.dbcache
303
304     # Configure system to use bridge
305     echo bridge > /etc/xensource/network.conf
306
307     printf "\nYou MUST reboot the server now to complete the change to\n"
308     printf "standard Xen networking.  Attempts to modify networking on the\n"
309     printf "server or any hosted VM will fail until after the reboot and\n"
310     printf "could leave the server in a state requiring manual recovery.\n\n"
311 fi
312
313
314 %files
315 %defattr(-,root,root)
316 /etc/init.d/vswitch
317 /etc/init.d/vswitch-xapi-update
318 /etc/xapi.d/plugins/vswitch-cfg-update
319 /etc/logrotate.d/vswitch
320 /etc/profile.d/vswitch.sh
321 /lib/modules/%{xen_version}/kernel/net/vswitch/openvswitch_mod.ko
322 /lib/modules/%{xen_version}/kernel/net/vswitch/brcompat_mod.ko
323 /usr/share/vswitch/scripts/dump-vif-details
324 /usr/share/vswitch/scripts/refresh-xs-network-uuids
325 /usr/share/vswitch/scripts/interface-reconfigure
326 /usr/share/vswitch/scripts/InterfaceReconfigure.py
327 /usr/share/vswitch/scripts/InterfaceReconfigure.pyc
328 /usr/share/vswitch/scripts/InterfaceReconfigure.pyo
329 /usr/share/vswitch/scripts/InterfaceReconfigureBridge.py
330 /usr/share/vswitch/scripts/InterfaceReconfigureBridge.pyc
331 /usr/share/vswitch/scripts/InterfaceReconfigureBridge.pyo
332 /usr/share/vswitch/scripts/InterfaceReconfigureVswitch.py
333 /usr/share/vswitch/scripts/InterfaceReconfigureVswitch.pyc
334 /usr/share/vswitch/scripts/InterfaceReconfigureVswitch.pyo
335 /usr/share/vswitch/scripts/vif
336 /usr/share/vswitch/scripts/xen-bugtool
337 /usr/share/vswitch/scripts/XSFeatureVSwitch.py
338 /usr/share/vswitch/scripts/brctl
339 /usr/share/vswitch/scripts/sysconfig.template
340 # Following two files are generated automatically by rpm.  We don't
341 # really need them and they won't be used on the XenServer, but there
342 # isn't an obvious place to get rid of them since they are generated
343 # after the install script runs.  Since they are small, we just
344 # include them.
345 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyc
346 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyo
347 /usr/sbin/ovs-brcompatd
348 /usr/sbin/ovs-vswitchd
349 /usr/bin/ovs-appctl
350 /usr/bin/ovs-cfg-mod
351 /usr/bin/ovs-dpctl
352 /usr/bin/ovs-ofctl
353 /usr/bin/ovs-vsctl
354 /usr/share/man/man5/ovs-vswitchd.conf.5.gz
355 /usr/share/man/man8/ovs-appctl.8.gz
356 /usr/share/man/man8/ovs-brcompatd.8.gz
357 /usr/share/man/man8/ovs-cfg-mod.8.gz
358 /usr/share/man/man8/ovs-dpctl.8.gz
359 /usr/share/man/man8/ovs-ofctl.8.gz
360 /usr/share/man/man8/ovs-vsctl.8.gz
361 /usr/share/man/man8/ovs-vswitchd.8.gz
362 /var/lib/openvswitch