tests: Fix memory leaks in test programs.
[sliver-openvswitch.git] / xenserver / vswitch-xen.spec
1 # Spec file for vswitch and related programs.
2
3 # Copyright (C) 2009, 2010 Nicira Networks, Inc.
4 #
5 # Copying and distribution of this file, with or without modification,
6 # are permitted in any medium without royalty provided the copyright
7 # notice and this notice are preserved.  This file is offered as-is,
8 # without warranty of any kind.
9
10 # When building, the rpmbuild command line should define
11 # vswitch_version, xen_version, and build_number using -D arguments.
12 # for example:
13 #
14 #    rpmbuild -D "vswitch_version 0.8.9~1+build123" -D "xen_version 2.6.18-128.1.1.el5.xs5.1.0.483.1000xen" -D "build_number --with-build-number=123" -bb /usr/src/redhat/SPECS/vswitch-xen.spec
15 #
16 %define version %{vswitch_version}-%{xen_version}
17
18 Name: vswitch
19 Summary: Virtual switch
20 Group: System Environment/Daemons
21 URL: http://www.openvswitch.org/
22 Version: %{vswitch_version}
23
24 # The entire source code is ASL 2.0 except datapath/ which is GPLv2
25 License: ASL 2.0 and GPLv2
26 Release: 1
27 Source: openvswitch-%{vswitch_version}.tar.gz
28 Buildroot: /tmp/vswitch-xen-rpm
29 Requires: kernel-xen = %(echo '%{xen_version}' | sed 's/xen$//')
30 # The following Conflicts prevents the "vswitch" package generated by
31 # this spec file from installing at the same time as the "openvswitch"
32 # package shipped with XenServer 5.5.900.  In fact, the packages
33 # contain some files with identical names anyhow, so they will not
34 # coexist, but adding an explicit Conflicts makes this conflict more
35 # obvious.
36 Conflicts: openvswitch
37
38 %description
39 The vswitch provides standard network bridging functions augmented with
40 support for the OpenFlow protocol for remote per-flow control of
41 traffic.
42
43 %prep
44 %setup -q -n openvswitch-%{vswitch_version}
45
46 %build
47 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=%{_localstatedir} --with-l26=/lib/modules/%{xen_version}/build --enable-ssl %{build_number}
48 make %{_smp_mflags}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 make install DESTDIR=$RPM_BUILD_ROOT
53 install -d -m 755 $RPM_BUILD_ROOT/etc
54 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
55 install -m 755 xenserver/etc_init.d_vswitch \
56          $RPM_BUILD_ROOT/etc/init.d/vswitch
57 install -m 755 xenserver/etc_init.d_vswitch-xapi-update \
58          $RPM_BUILD_ROOT/etc/init.d/vswitch-xapi-update
59 install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
60 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d
61 install -m 755 xenserver/etc_logrotate.d_vswitch \
62          $RPM_BUILD_ROOT/etc/logrotate.d/vswitch
63 install -d -m 755 $RPM_BUILD_ROOT/etc/profile.d
64 install -m 755 xenserver/etc_profile.d_vswitch.sh \
65          $RPM_BUILD_ROOT/etc/profile.d/vswitch.sh
66 install -d -m 755 $RPM_BUILD_ROOT/etc/xapi.d/plugins
67 install -m 755 xenserver/etc_xapi.d_plugins_vswitch-cfg-update \
68          $RPM_BUILD_ROOT/etc/xapi.d/plugins/vswitch-cfg-update
69 install -d -m 755 $RPM_BUILD_ROOT/usr/share/vswitch/scripts
70 install -m 644 vswitchd/vswitch.ovsschema \
71          $RPM_BUILD_ROOT/usr/share/vswitch/vswitch.ovsschema
72 install -m 755 xenserver/opt_xensource_libexec_interface-reconfigure \
73              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/interface-reconfigure
74 install -m 755 xenserver/etc_xensource_scripts_vif \
75              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/vif
76 install -m 755 xenserver/usr_share_vswitch_scripts_dump-vif-details \
77                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/dump-vif-details
78 install -m 755 xenserver/usr_share_vswitch_scripts_refresh-xs-network-uuids \
79                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/refresh-xs-network-uuids
80 install -m 755 xenserver/usr_sbin_xen-bugtool \
81              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/xen-bugtool
82 install -m 755 xenserver/usr_sbin_brctl \
83              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/brctl
84 install -m 755 xenserver/usr_share_vswitch_scripts_sysconfig.template \
85          $RPM_BUILD_ROOT/usr/share/vswitch/scripts/sysconfig.template
86 install -m 644 \
87         xenserver/usr_lib_xsconsole_plugins-base_XSFeatureVSwitch.py \
88                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/XSFeatureVSwitch.py
89
90 install -d -m 755 $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch
91 find datapath/linux-2.6 -name *.ko -exec install -m 755  \{\} $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch \;
92
93 # Get rid of stuff we don't want to make RPM happy.
94 rm \
95     $RPM_BUILD_ROOT/usr/bin/ovs-controller \
96     $RPM_BUILD_ROOT/usr/bin/ovs-discover \
97     $RPM_BUILD_ROOT/usr/bin/ovs-kill \
98     $RPM_BUILD_ROOT/usr/bin/ovs-openflowd \
99     $RPM_BUILD_ROOT/usr/bin/ovs-pki \
100     $RPM_BUILD_ROOT/usr/bin/ovs-wdt \
101     $RPM_BUILD_ROOT/usr/sbin/ovs-monitor \
102     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-controller.8 \
103     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-discover.8 \
104     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-kill.8 \
105     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-openflowd.8 \
106     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-pki.8
107 rm -f $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch/veth_mod.ko
108
109 install -d -m 755 $RPM_BUILD_ROOT/var/lib/openvswitch
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 if [ ! -f /etc/xensource-inventory ]; then
116     printf "XenSource inventory not present in /etc/xensource-inventory"
117     exit 1
118 fi
119
120 if [ "$1" = "1" ]; then
121     if md5sum -c --status <<EOF
122 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
123 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
124 51970ad613a3996d5997e18e44db47da  /opt/xensource/libexec/interface-reconfigure
125 5654c8c36699fcc8744ca9cd5b855414  /usr/sbin/xen-bugtool
126 EOF
127     then
128         printf "\nVerified host scripts from XenServer 5.5.0.\n\n"
129     elif md5sum -c --status <<EOF
130 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
131 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
132 51970ad613a3996d5997e18e44db47da  /opt/xensource/libexec/interface-reconfigure
133 f6519085c2fc5f7bc4eccc294ed62000  /usr/sbin/xen-bugtool
134 EOF
135     then
136         printf "\nVerified host scripts from XenServer 5.5.0-24648p (Update 1)\n"
137         printf "or 5.5.0-25727p (Update 2).\n\n"
138     elif md5sum -c --status <<EOF
139 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
140 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
141 ce451d3c985fd1db6497a363f0d9dedb  /opt/xensource/libexec/interface-reconfigure
142 2b53f500431fcba5276c896e9e4281b9  /usr/sbin/xen-bugtool
143 EOF
144     then
145         printf "\nVerified host scripts from XenServer 5.5.900.\n\n"
146     else
147 cat <<EOF
148
149 The original XenServer scripts replaced by this package are not those
150 of any supported version of XenServer.  This could lead to unexpected
151 behavior of your server.  Unless you are sure you know what you are
152 doing, it is highly recommended that you remove this package
153 immediately after the install completes, which will restore the
154 XenServer scripts that you were previously using.
155
156 EOF
157     fi
158 fi
159
160 if test ! -e /var/lib/openvswitch/dbcache; then
161     if test "$1" = 1; then
162         printf "Creating xapi database cache...  "
163     else
164         printf "warning: Open vSwitch is being re-installed or upgraded,\n"
165         printf "         but the xapi database cache is missing.\n"
166         printf "Re-creating xapi database cache...  "
167     fi
168
169     if /usr/share/vswitch/scripts/interface-reconfigure rewrite; then
170         printf "done.\n"
171     else
172         printf "FAILED\n"
173         printf "Open vSwitch can only be installed on a XenServer that\n"
174         printf "has connectivity to xapi on the pool master.  Please\n"
175         printf "fix connectivity to the pool master, then try again.\n"
176         exit 1
177     fi
178 fi
179
180 # Ensure that modprobe will find our modules.
181 depmod %{xen_version}
182
183 if grep -F net.ipv4.conf.all.arp_filter /etc/sysctl.conf >/dev/null 2>&1; then :; else
184     cat >>/etc/sysctl.conf <<EOF
185 # This works around an issue in xhad, which binds to a particular
186 # Ethernet device, which in turn causes ICMP port unreachable messages
187 # if packets are received are on the wrong interface, which in turn
188 # can happen if we send out ARP replies on every interface (as Linux
189 # does by default) instead of just on the interface that has the IP
190 # address being ARPed for, which this sysctl setting in turn works
191 # around.
192 #
193 # Bug #1378.
194 net.ipv4.conf.all.arp_filter = 1
195 EOF
196 fi
197
198 if test ! -e /etc/ovs-vswitchd.conf.db; then
199     # Create ovs-vswitchd config database
200     ovsdb-tool -vANY:console:emer create /etc/ovs-vswitchd.conf.db \
201             /usr/share/vswitch/vswitch.ovsschema \
202
203     # Create initial table in config database
204     ovsdb-tool -vANY:console:emer transact /etc/ovs-vswitchd.conf.db \
205             '[{"op": "insert", "table": "Open_vSwitch", "row": {}}]' \
206             > /dev/null
207 fi
208
209 # Create default or update existing /etc/sysconfig/vswitch.
210 SYSCONFIG=/etc/sysconfig/vswitch
211 TEMPLATE=/usr/share/vswitch/scripts/sysconfig.template
212 if [ ! -e $SYSCONFIG ]; then
213     cp $TEMPLATE $SYSCONFIG
214 else
215     for var in $(awk -F'[ :]' '/^# [_A-Z0-9]+:/{print $2}' $TEMPLATE)
216     do
217         if ! grep $var $SYSCONFIG >/dev/null 2>&1; then
218             echo >> $SYSCONFIG
219             sed -n "/$var:/,/$var=/p" $TEMPLATE >> $SYSCONFIG
220         fi
221     done
222 fi
223
224 # Replace XenServer files by our versions.
225 mkdir -p /usr/lib/vswitch/xs-original \
226     || printf "Could not create script backup directory.\n"
227 for f in \
228     /opt/xensource/libexec/interface-reconfigure \
229     /etc/xensource/scripts/vif \
230     /usr/sbin/xen-bugtool \
231     /usr/sbin/brctl
232 do
233     s=$(basename "$f")
234     t=$(readlink "$f")
235     if [ "$t" != "/usr/share/vswitch/scripts/$s" ]; then
236         mv "$f" /usr/lib/vswitch/xs-original/ \
237             || printf "Could not save original XenServer $s script\n"
238         ln -s "/usr/share/vswitch/scripts/$s" "$f" \
239             || printf "Could not link to vSwitch $s script\n"
240     fi
241 done
242
243 # Install xsconsole plugin
244 plugin=$(readlink /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py)
245 if [ "$plugin" != "/usr/share/vswitch/scripts/XSFeatureVSwitch.py" ]; then
246     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
247     ln -s /usr/share/vswitch/scripts/XSFeatureVSwitch.py /usr/lib/xsconsole/plugins-base/ || printf "Could not link to vSswitch xsconsole plugin.\n"
248 fi
249
250 # Ensure all required services are set to run
251 for s in vswitch vswitch-xapi-update; do
252     if chkconfig --list $s >/dev/null 2>&1; then
253         chkconfig --del $s || printf "Could not remove $s init script."
254     fi
255     chkconfig --add $s || printf "Could not add $s init script."
256     chkconfig $s on || printf "Could not enable $s init script."
257 done
258
259 if [ "$1" = "1" ]; then    # $1 = 2 for upgrade
260     printf "\nYou MUST reboot the server NOW to complete the change to the\n"
261     printf "the vSwitch.  Attempts to modify networking on the server\n"
262     printf "or any hosted VM will fail until after the reboot and could\n"
263     printf "leave the server in an state requiring manual recovery.\n\n"
264 else
265     printf "\nTo use the new vSwitch, you should reboot the server\n"
266     printf "now.  Failure to do so may result in incorrect operation.\n\n"
267 fi
268
269 %preun
270 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
271     for s in vswitch vswitch-xapi-update; do
272         chkconfig --del $s || printf "Could not remove $s init script."
273     done
274 fi
275
276
277 %postun
278 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
279
280     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py \
281         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyc \
282         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyo \
283         || printf "Could not remove vSwitch xsconsole plugin.\n"
284
285     # Restore original XenServer scripts
286     for f in \
287         /opt/xensource/libexec/interface-reconfigure \
288         /etc/xensource/scripts/vif \
289         /usr/sbin/xen-bugtool \
290         /usr/sbin/brctl
291     do
292         s=$(basename "$f")
293         if [ ! -f "/usr/lib/vswitch/xs-original/$s" ]; then
294             printf "Original XenServer $s script not present in /usr/lib/vswitch/xs-original\n"
295             printf "Could not restore original XenServer script.\n"
296         else
297             (rm -f "$f" \
298                 && mv "/usr/lib/vswitch/xs-original/$s" "$f") \
299                 || printf "Could not restore original XenServer $s script.\n"
300         fi
301     done
302
303     # Remove all configuration files
304     rm -f /etc/ovs-vswitchd.conf.db
305     rm -f /etc/sysconfig/vswitch
306     rm -f /etc/ovs-vswitchd.cacert
307     rm -f /var/lib/openvswitch/dbcache
308
309     printf "\nYou MUST reboot the server now to complete the change to\n"
310     printf "standard Xen networking.  Attempts to modify networking on the\n"
311     printf "server or any hosted VM will fail until after the reboot and\n"
312     printf "could leave the server in a state requiring manual recovery.\n\n"
313 fi
314
315
316 %files
317 %defattr(-,root,root)
318 /etc/init.d/vswitch
319 /etc/init.d/vswitch-xapi-update
320 /etc/xapi.d/plugins/vswitch-cfg-update
321 /etc/logrotate.d/vswitch
322 /etc/profile.d/vswitch.sh
323 /lib/modules/%{xen_version}/kernel/net/vswitch/openvswitch_mod.ko
324 /lib/modules/%{xen_version}/kernel/net/vswitch/brcompat_mod.ko
325 %if %(echo '%{xen_version}'|awk -F"." '{if ($3>=18) print 1; else print 0;}')
326 /lib/modules/%{xen_version}/kernel/net/vswitch/ip_gre_mod.ko
327 %endif
328 /usr/share/vswitch/scripts/dump-vif-details
329 /usr/share/vswitch/scripts/refresh-xs-network-uuids
330 /usr/share/vswitch/scripts/interface-reconfigure
331 /usr/share/vswitch/scripts/vif
332 /usr/share/vswitch/scripts/xen-bugtool
333 /usr/share/vswitch/scripts/XSFeatureVSwitch.py
334 /usr/share/vswitch/scripts/brctl
335 /usr/share/vswitch/scripts/sysconfig.template
336 # Following two files are generated automatically by rpm.  We don't
337 # really need them and they won't be used on the XenServer, but there
338 # isn't an obvious place to get rid of them since they are generated
339 # after the install script runs.  Since they are small, we just
340 # include them.
341 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyc
342 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyo
343 /usr/share/vswitch/vswitch.ovsschema
344 /usr/sbin/ovs-brcompatd
345 /usr/sbin/ovs-vswitchd
346 /usr/sbin/ovsdb-server
347 /usr/bin/ovs-appctl
348 /usr/bin/ovs-dpctl
349 /usr/bin/ovs-ofctl
350 /usr/bin/ovs-vsctl
351 /usr/bin/ovsdb-client
352 /usr/bin/ovsdb-tool
353 /usr/share/man/man1/ovsdb-client.1.gz
354 /usr/share/man/man1/ovsdb-server.1.gz
355 /usr/share/man/man1/ovsdb-tool.1.gz
356 /usr/share/man/man8/ovs-appctl.8.gz
357 /usr/share/man/man8/ovs-brcompatd.8.gz
358 /usr/share/man/man8/ovs-dpctl.8.gz
359 /usr/share/man/man8/ovs-ofctl.8.gz
360 /usr/share/man/man8/ovs-vsctl.8.gz
361 /usr/share/man/man8/ovs-vswitchd.8.gz
362 /var/lib/openvswitch