New script for setting promisc tag on slice devices
[vsys-scripts.git] / root-context / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6
7 %define name vsys-scripts
8 %define version 0.95
9 %define taglevel 44
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab %{plrelease}
16 URL: %{SCMURL}
17
18 Summary: Vsys scripts scripts
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 Requires: vsys
26
27 Source0: vsys-scripts-%{version}.tar.gz
28
29 %description
30 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
31 to which users require privileged access.
32
33 %prep
34 %setup
35
36 %build
37 rm -rf $RPM_BUILD_ROOT
38 make -C root-context
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/vsys
42 cp root-context/exec/* $RPM_BUILD_ROOT/vsys
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 /vsys/*
49
50 %post
51
52 %postun
53
54 %changelog
55 * Tue Sep 04 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-44
56 - new slice-oriented package vsys-wrapper (python wrapper)
57 - new layout of the module, spit between root-context and slice-context
58
59 * Fri Jul 27 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-43
60
61 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
62 - fix TUN devices creation (was always creating TAPs)
63
64 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
65
66 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
67
68 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
69 - prevent vserver from unsharing namespaces
70
71 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
72 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
73
74 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
75 - A new script that lets slices serve DNS by binding to UDP port 53.
76
77 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
78 - Disable namespaces for pl_netflow
79
80 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
81 - Added a script for users to create custom distributions within their slices. Use as follows:
82 - mkdir /rootfs;cd /rootfs
83 - wget <your distribution tarball>
84 - tar xvfz <tarball>
85 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
86 - cat /vsys/switcheroo.out &
87 - echo 1 > /vsys/switcheroo.in
88
89 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
90 - Added a new script from Jude.
91
92 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
93 - Build fd_netlink, a new script that lets slices stream packet headers
94
95 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
96 - New script for slices to stream the headers of all packets going out of a node.
97
98 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
99 - vif_up has support for GRE tunnels
100 - sliceip is known to cause kernel crashes with 2.6.32 at least
101
102 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
103 - New script: claimport.
104
105 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
106 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
107 - new vroute
108
109 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
110 - Bug fix for 2.6.27+ kernels
111
112 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
113 - first draft of new scripts to handle openvswitch
114
115 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
116 - rsyncnodelogs script, make it easy to bring up tun/tap devices
117
118 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
119 - support newer kernels
120
121 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
122 - Add executable tag to vif_up to let it run.
123
124 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
125 - Added execute attribute to vif_up, the absence of which prevented it from being used.
126
127 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
128 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
129 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
130
131 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
132 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
133 - and other minor changes.
134
135 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
136 - fix dotsshmount
137
138 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
139 - change dotsshmount's mount point
140
141 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
142 - Switch fd_tuntap to 2.6.27.
143
144 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
145 - Tweak to if_port_forward script.
146
147 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
148 - Added if_port_forward script to enable slices to forward ports for their
149 - allocated IP addresses.
150
151 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
152 - - hostname filter and updated documentation for ipfw scripts - Marta
153 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
154 - (if this is not needed anymore please remove and tag again)
155
156 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
157 - Tweak to Thom Haddow's script to let a slice see packets related to
158 - existing connections.
159
160 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
161 - ipfw frontend has a rules cleanup feature
162 - ongoing work around vif_up
163 - new script 'run_with_devices'
164
165 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
166 - improve usability of the ipfw backend
167
168 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
169 - * Load the tun module if it is not already loaded
170 - * Fixed a bug in fd_tuntap
171
172 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
173 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
174
175 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
176 - This update adds Thom Haddow's custom tun/tap-device scripts.
177
178 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
179 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
180
181 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
182 - minor changes in sliceip and ipfw, new reserve_udp_port
183
184 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
185 - Added reserve_tcp_port and Giovanni's slice_ip tool.
186
187 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
188 - tweak in ipfw-be for in-node emulation
189
190 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
191 - Added the ipfw backend script
192
193 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
194 - rsync authlogs to ~/
195
196 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
197 - Security update. umount had an issue that might have been exploited.
198
199 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
200 - Adding port reservation script (goodfences)
201 - Modifying umount to be more (or less, depending on your point of view) robust
202
203
204
205 %define module_current_branch 0.7