vsys for new lxc based planetlab code
[vsys-scripts.git] / root-context / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6
7 %define name vsys-scripts
8 %define version 0.95
9 %define taglevel 47
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab %{plrelease}
16 URL: %{SCMURL}
17
18 Summary: Vsys scripts scripts
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 Requires: vsys
26
27 Source0: vsys-scripts-%{version}.tar.gz
28
29 %description
30 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
31 to which users require privileged access.
32
33 %prep
34 %setup
35
36 %build
37 rm -rf $RPM_BUILD_ROOT
38 make -C root-context
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/vsys
42 cp root-context/exec/* $RPM_BUILD_ROOT/vsys
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 /vsys/*
49
50 %post
51
52 %postun
53
54 %changelog
55 * Tue Jun 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-47
56 - Giuseppe Lettieri's patch for ignoring glitches when tearing down iptables rules
57
58 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-46
59 - vif_up can set dropkern and mtu
60
61 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-45
62 - script 'promisc' can set a device in promiscuous mode
63
64 * Tue Sep 04 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-44
65 - new slice-oriented package vsys-wrapper (python wrapper)
66 - new layout of the module, spit between root-context and slice-context
67
68 * Fri Jul 27 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-43
69
70 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
71 - fix TUN devices creation (was always creating TAPs)
72
73 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
74
75 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
76
77 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
78 - prevent vserver from unsharing namespaces
79
80 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
81 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
82
83 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
84 - A new script that lets slices serve DNS by binding to UDP port 53.
85
86 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
87 - Disable namespaces for pl_netflow
88
89 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
90 - Added a script for users to create custom distributions within their slices. Use as follows:
91 - mkdir /rootfs;cd /rootfs
92 - wget <your distribution tarball>
93 - tar xvfz <tarball>
94 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
95 - cat /vsys/switcheroo.out &
96 - echo 1 > /vsys/switcheroo.in
97
98 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
99 - Added a new script from Jude.
100
101 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
102 - Build fd_netlink, a new script that lets slices stream packet headers
103
104 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
105 - New script for slices to stream the headers of all packets going out of a node.
106
107 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
108 - vif_up has support for GRE tunnels
109 - sliceip is known to cause kernel crashes with 2.6.32 at least
110
111 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
112 - New script: claimport.
113
114 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
115 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
116 - new vroute
117
118 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
119 - Bug fix for 2.6.27+ kernels
120
121 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
122 - first draft of new scripts to handle openvswitch
123
124 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
125 - rsyncnodelogs script, make it easy to bring up tun/tap devices
126
127 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
128 - support newer kernels
129
130 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
131 - Add executable tag to vif_up to let it run.
132
133 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
134 - Added execute attribute to vif_up, the absence of which prevented it from being used.
135
136 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
137 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
138 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
139
140 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
141 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
142 - and other minor changes.
143
144 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
145 - fix dotsshmount
146
147 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
148 - change dotsshmount's mount point
149
150 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
151 - Switch fd_tuntap to 2.6.27.
152
153 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
154 - Tweak to if_port_forward script.
155
156 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
157 - Added if_port_forward script to enable slices to forward ports for their
158 - allocated IP addresses.
159
160 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
161 - - hostname filter and updated documentation for ipfw scripts - Marta
162 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
163 - (if this is not needed anymore please remove and tag again)
164
165 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
166 - Tweak to Thom Haddow's script to let a slice see packets related to
167 - existing connections.
168
169 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
170 - ipfw frontend has a rules cleanup feature
171 - ongoing work around vif_up
172 - new script 'run_with_devices'
173
174 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
175 - improve usability of the ipfw backend
176
177 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
178 - * Load the tun module if it is not already loaded
179 - * Fixed a bug in fd_tuntap
180
181 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
182 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
183
184 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
185 - This update adds Thom Haddow's custom tun/tap-device scripts.
186
187 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
188 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
189
190 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
191 - minor changes in sliceip and ipfw, new reserve_udp_port
192
193 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
194 - Added reserve_tcp_port and Giovanni's slice_ip tool.
195
196 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
197 - tweak in ipfw-be for in-node emulation
198
199 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
200 - Added the ipfw backend script
201
202 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
203 - rsync authlogs to ~/
204
205 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
206 - Security update. umount had an issue that might have been exploited.
207
208 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
209 - Adding port reservation script (goodfences)
210 - Modifying umount to be more (or less, depending on your point of view) robust
211
212
213
214 %define module_current_branch 0.7