Setting tag vsys-scripts-0.95-48
[vsys-scripts.git] / root-context / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6
7 %define name vsys-scripts
8 %define version 0.95
9 %define taglevel 48
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab %{plrelease}
16 URL: %{SCMURL}
17
18 Summary: Vsys scripts scripts
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 Requires: vsys
26
27 Source0: vsys-scripts-%{version}.tar.gz
28
29 %description
30 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
31 to which users require privileged access.
32
33 %prep
34 %setup
35
36 %build
37 rm -rf $RPM_BUILD_ROOT
38 make -C root-context
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/vsys
42 install -D root-context/exec/* $RPM_BUILD_ROOT/vsys/
43 install -D root-context/init/sliceip.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sliceip
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 /vsys/
50 /etc/rc.d/init.d/
51
52 %post
53
54 %postun
55
56 %changelog
57 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-48
58 - sliceip has support for lxc and vs nodes (Thanks Giovanni)
59
60 * Tue Jun 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-47
61 - Giuseppe Lettieri's patch for ignoring glitches when tearing down iptables rules
62
63 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-46
64 - vif_up can set dropkern and mtu
65
66 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-45
67 - script 'promisc' can set a device in promiscuous mode
68
69 * Tue Sep 04 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-44
70 - new slice-oriented package vsys-wrapper (python wrapper)
71 - new layout of the module, spit between root-context and slice-context
72
73 * Fri Jul 27 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-43
74
75 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
76 - fix TUN devices creation (was always creating TAPs)
77
78 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
79
80 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
81
82 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
83 - prevent vserver from unsharing namespaces
84
85 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
86 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
87
88 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
89 - A new script that lets slices serve DNS by binding to UDP port 53.
90
91 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
92 - Disable namespaces for pl_netflow
93
94 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
95 - Added a script for users to create custom distributions within their slices. Use as follows:
96 - mkdir /rootfs;cd /rootfs
97 - wget <your distribution tarball>
98 - tar xvfz <tarball>
99 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
100 - cat /vsys/switcheroo.out &
101 - echo 1 > /vsys/switcheroo.in
102
103 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
104 - Added a new script from Jude.
105
106 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
107 - Build fd_netlink, a new script that lets slices stream packet headers
108
109 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
110 - New script for slices to stream the headers of all packets going out of a node.
111
112 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
113 - vif_up has support for GRE tunnels
114 - sliceip is known to cause kernel crashes with 2.6.32 at least
115
116 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
117 - New script: claimport.
118
119 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
120 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
121 - new vroute
122
123 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
124 - Bug fix for 2.6.27+ kernels
125
126 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
127 - first draft of new scripts to handle openvswitch
128
129 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
130 - rsyncnodelogs script, make it easy to bring up tun/tap devices
131
132 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
133 - support newer kernels
134
135 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
136 - Add executable tag to vif_up to let it run.
137
138 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
139 - Added execute attribute to vif_up, the absence of which prevented it from being used.
140
141 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
142 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
143 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
144
145 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
146 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
147 - and other minor changes.
148
149 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
150 - fix dotsshmount
151
152 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
153 - change dotsshmount's mount point
154
155 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
156 - Switch fd_tuntap to 2.6.27.
157
158 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
159 - Tweak to if_port_forward script.
160
161 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
162 - Added if_port_forward script to enable slices to forward ports for their
163 - allocated IP addresses.
164
165 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
166 - - hostname filter and updated documentation for ipfw scripts - Marta
167 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
168 - (if this is not needed anymore please remove and tag again)
169
170 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
171 - Tweak to Thom Haddow's script to let a slice see packets related to
172 - existing connections.
173
174 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
175 - ipfw frontend has a rules cleanup feature
176 - ongoing work around vif_up
177 - new script 'run_with_devices'
178
179 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
180 - improve usability of the ipfw backend
181
182 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
183 - * Load the tun module if it is not already loaded
184 - * Fixed a bug in fd_tuntap
185
186 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
187 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
188
189 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
190 - This update adds Thom Haddow's custom tun/tap-device scripts.
191
192 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
193 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
194
195 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
196 - minor changes in sliceip and ipfw, new reserve_udp_port
197
198 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
199 - Added reserve_tcp_port and Giovanni's slice_ip tool.
200
201 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
202 - tweak in ipfw-be for in-node emulation
203
204 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
205 - Added the ipfw backend script
206
207 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
208 - rsync authlogs to ~/
209
210 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
211 - Security update. umount had an issue that might have been exploited.
212
213 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
214 - Adding port reservation script (goodfences)
215 - Modifying umount to be more (or less, depending on your point of view) robust
216
217
218
219 %define module_current_branch 0.7