Setting tag vsys-scripts-0.95-50
[vsys-scripts.git] / root-context / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6
7 %define name vsys-scripts
8 %define version 0.95
9 %define taglevel 50
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab %{plrelease}
16 URL: %{SCMURL}
17
18 Summary: Vsys scripts scripts
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 Requires: vsys
26
27 Source0: vsys-scripts-%{version}.tar.gz
28
29 %description
30 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
31 to which users require privileged access.
32
33 %prep
34 %setup
35
36 %build
37 rm -rf $RPM_BUILD_ROOT
38 make -C root-context
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/vsys
42 install -D root-context/exec/* $RPM_BUILD_ROOT/vsys/
43 install -D root-context/init/sliceip.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sliceip
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 /vsys/
50 /etc/rc.d/init.d/
51
52 %post
53
54 %postun
55
56 %changelog
57 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-50
58 - a new vsys script for rebooting a vserver
59
60 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-49
61 - new privilege script pvtfs
62
63 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-48
64 - sliceip has support for lxc and vs nodes (Thanks Giovanni)
65
66 * Tue Jun 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-47
67 - Giuseppe Lettieri's patch for ignoring glitches when tearing down iptables rules
68
69 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-46
70 - vif_up can set dropkern and mtu
71
72 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-45
73 - script 'promisc' can set a device in promiscuous mode
74
75 * Tue Sep 04 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-44
76 - new slice-oriented package vsys-wrapper (python wrapper)
77 - new layout of the module, spit between root-context and slice-context
78
79 * Fri Jul 27 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-43
80
81 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
82 - fix TUN devices creation (was always creating TAPs)
83
84 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
85
86 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
87
88 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
89 - prevent vserver from unsharing namespaces
90
91 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
92 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
93
94 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
95 - A new script that lets slices serve DNS by binding to UDP port 53.
96
97 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
98 - Disable namespaces for pl_netflow
99
100 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
101 - Added a script for users to create custom distributions within their slices. Use as follows:
102 - mkdir /rootfs;cd /rootfs
103 - wget <your distribution tarball>
104 - tar xvfz <tarball>
105 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
106 - cat /vsys/switcheroo.out &
107 - echo 1 > /vsys/switcheroo.in
108
109 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
110 - Added a new script from Jude.
111
112 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
113 - Build fd_netlink, a new script that lets slices stream packet headers
114
115 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
116 - New script for slices to stream the headers of all packets going out of a node.
117
118 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
119 - vif_up has support for GRE tunnels
120 - sliceip is known to cause kernel crashes with 2.6.32 at least
121
122 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
123 - New script: claimport.
124
125 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
126 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
127 - new vroute
128
129 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
130 - Bug fix for 2.6.27+ kernels
131
132 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
133 - first draft of new scripts to handle openvswitch
134
135 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
136 - rsyncnodelogs script, make it easy to bring up tun/tap devices
137
138 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
139 - support newer kernels
140
141 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
142 - Add executable tag to vif_up to let it run.
143
144 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
145 - Added execute attribute to vif_up, the absence of which prevented it from being used.
146
147 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
148 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
149 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
150
151 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
152 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
153 - and other minor changes.
154
155 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
156 - fix dotsshmount
157
158 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
159 - change dotsshmount's mount point
160
161 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
162 - Switch fd_tuntap to 2.6.27.
163
164 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
165 - Tweak to if_port_forward script.
166
167 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
168 - Added if_port_forward script to enable slices to forward ports for their
169 - allocated IP addresses.
170
171 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
172 - - hostname filter and updated documentation for ipfw scripts - Marta
173 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
174 - (if this is not needed anymore please remove and tag again)
175
176 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
177 - Tweak to Thom Haddow's script to let a slice see packets related to
178 - existing connections.
179
180 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
181 - ipfw frontend has a rules cleanup feature
182 - ongoing work around vif_up
183 - new script 'run_with_devices'
184
185 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
186 - improve usability of the ipfw backend
187
188 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
189 - * Load the tun module if it is not already loaded
190 - * Fixed a bug in fd_tuntap
191
192 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
193 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
194
195 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
196 - This update adds Thom Haddow's custom tun/tap-device scripts.
197
198 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
199 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
200
201 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
202 - minor changes in sliceip and ipfw, new reserve_udp_port
203
204 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
205 - Added reserve_tcp_port and Giovanni's slice_ip tool.
206
207 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
208 - tweak in ipfw-be for in-node emulation
209
210 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
211 - Added the ipfw backend script
212
213 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
214 - rsync authlogs to ~/
215
216 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
217 - Security update. umount had an issue that might have been exploited.
218
219 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
220 - Adding port reservation script (goodfences)
221 - Modifying umount to be more (or less, depending on your point of view) robust
222
223
224
225 %define module_current_branch 0.7