all the python scripts are for python2, and fedora31 requires to be specific
[vsys-scripts.git] / root-context / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6
7 %define name vsys-scripts
8 %define version 0.95
9 %define taglevel 51
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab %{plrelease}
16 URL: %{SCMURL}
17
18 Summary: Vsys scripts scripts
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 Requires: vsys
26
27 Source0: vsys-scripts-%{version}.tar.gz
28
29 %description
30 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
31 to which users require privileged access.
32
33 %prep
34 %setup
35
36 %build
37 rm -rf $RPM_BUILD_ROOT
38 make -C root-context
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/vsys
42 install -D root-context/exec/* $RPM_BUILD_ROOT/vsys/
43 install -D root-context/init/sliceip.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sliceip
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 /vsys/
50 /etc/rc.d/init.d/
51
52 %post
53
54 %postun
55
56 %changelog
57 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-51
58 - builds on fedora>=21
59 - new script reversetraceroute
60
61 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-50
62 - a new vsys script for rebooting a vserver
63
64 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-49
65 - new privilege script pvtfs
66
67 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-48
68 - sliceip has support for lxc and vs nodes (Thanks Giovanni)
69
70 * Tue Jun 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-47
71 - Giuseppe Lettieri's patch for ignoring glitches when tearing down iptables rules
72
73 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-46
74 - vif_up can set dropkern and mtu
75
76 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-45
77 - script 'promisc' can set a device in promiscuous mode
78
79 * Tue Sep 04 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-44
80 - new slice-oriented package vsys-wrapper (python wrapper)
81 - new layout of the module, spit between root-context and slice-context
82
83 * Fri Jul 27 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-43
84
85 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
86 - fix TUN devices creation (was always creating TAPs)
87
88 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
89
90 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
91
92 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
93 - prevent vserver from unsharing namespaces
94
95 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
96 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
97
98 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
99 - A new script that lets slices serve DNS by binding to UDP port 53.
100
101 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
102 - Disable namespaces for pl_netflow
103
104 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
105 - Added a script for users to create custom distributions within their slices. Use as follows:
106 - mkdir /rootfs;cd /rootfs
107 - wget <your distribution tarball>
108 - tar xvfz <tarball>
109 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
110 - cat /vsys/switcheroo.out &
111 - echo 1 > /vsys/switcheroo.in
112
113 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
114 - Added a new script from Jude.
115
116 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
117 - Build fd_netlink, a new script that lets slices stream packet headers
118
119 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
120 - New script for slices to stream the headers of all packets going out of a node.
121
122 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
123 - vif_up has support for GRE tunnels
124 - sliceip is known to cause kernel crashes with 2.6.32 at least
125
126 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
127 - New script: claimport.
128
129 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
130 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
131 - new vroute
132
133 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
134 - Bug fix for 2.6.27+ kernels
135
136 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
137 - first draft of new scripts to handle openvswitch
138
139 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
140 - rsyncnodelogs script, make it easy to bring up tun/tap devices
141
142 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
143 - support newer kernels
144
145 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
146 - Add executable tag to vif_up to let it run.
147
148 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
149 - Added execute attribute to vif_up, the absence of which prevented it from being used.
150
151 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
152 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
153 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
154
155 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
156 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
157 - and other minor changes.
158
159 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
160 - fix dotsshmount
161
162 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
163 - change dotsshmount's mount point
164
165 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
166 - Switch fd_tuntap to 2.6.27.
167
168 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
169 - Tweak to if_port_forward script.
170
171 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
172 - Added if_port_forward script to enable slices to forward ports for their
173 - allocated IP addresses.
174
175 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
176 - - hostname filter and updated documentation for ipfw scripts - Marta
177 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
178 - (if this is not needed anymore please remove and tag again)
179
180 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
181 - Tweak to Thom Haddow's script to let a slice see packets related to
182 - existing connections.
183
184 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
185 - ipfw frontend has a rules cleanup feature
186 - ongoing work around vif_up
187 - new script 'run_with_devices'
188
189 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
190 - improve usability of the ipfw backend
191
192 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
193 - * Load the tun module if it is not already loaded
194 - * Fixed a bug in fd_tuntap
195
196 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
197 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
198
199 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
200 - This update adds Thom Haddow's custom tun/tap-device scripts.
201
202 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
203 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
204
205 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
206 - minor changes in sliceip and ipfw, new reserve_udp_port
207
208 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
209 - Added reserve_tcp_port and Giovanni's slice_ip tool.
210
211 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
212 - tweak in ipfw-be for in-node emulation
213
214 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
215 - Added the ipfw backend script
216
217 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
218 - rsync authlogs to ~/
219
220 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
221 - Security update. umount had an issue that might have been exploited.
222
223 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
224 - Adding port reservation script (goodfences)
225 - Modifying umount to be more (or less, depending on your point of view) robust
226
227
228
229 %define module_current_branch 0.7