install a 'sliceip' initscript that cleans up stuff at boot-time for the sake of...
[vsys-scripts.git] / root-context / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6
7 %define name vsys-scripts
8 %define version 0.95
9 %define taglevel 47
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab %{plrelease}
16 URL: %{SCMURL}
17
18 Summary: Vsys scripts scripts
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 Requires: vsys
26
27 Source0: vsys-scripts-%{version}.tar.gz
28
29 %description
30 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
31 to which users require privileged access.
32
33 %prep
34 %setup
35
36 %build
37 rm -rf $RPM_BUILD_ROOT
38 make -C root-context
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/vsys
42 install -D root-context/exec/* $RPM_BUILD_ROOT/vsys/
43 install -D root-context/init/sliceip.init ${prefix}/etc/rc.d/init.d/sliceip
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 /vsys/
50 /etc/rc.d/init.d/
51
52 %post
53
54 %postun
55
56 %changelog
57 * Tue Jun 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-47
58 - Giuseppe Lettieri's patch for ignoring glitches when tearing down iptables rules
59
60 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-46
61 - vif_up can set dropkern and mtu
62
63 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-45
64 - script 'promisc' can set a device in promiscuous mode
65
66 * Tue Sep 04 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-44
67 - new slice-oriented package vsys-wrapper (python wrapper)
68 - new layout of the module, spit between root-context and slice-context
69
70 * Fri Jul 27 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-43
71
72 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
73 - fix TUN devices creation (was always creating TAPs)
74
75 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
76
77 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
78
79 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
80 - prevent vserver from unsharing namespaces
81
82 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
83 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
84
85 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
86 - A new script that lets slices serve DNS by binding to UDP port 53.
87
88 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
89 - Disable namespaces for pl_netflow
90
91 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
92 - Added a script for users to create custom distributions within their slices. Use as follows:
93 - mkdir /rootfs;cd /rootfs
94 - wget <your distribution tarball>
95 - tar xvfz <tarball>
96 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
97 - cat /vsys/switcheroo.out &
98 - echo 1 > /vsys/switcheroo.in
99
100 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
101 - Added a new script from Jude.
102
103 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
104 - Build fd_netlink, a new script that lets slices stream packet headers
105
106 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
107 - New script for slices to stream the headers of all packets going out of a node.
108
109 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
110 - vif_up has support for GRE tunnels
111 - sliceip is known to cause kernel crashes with 2.6.32 at least
112
113 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
114 - New script: claimport.
115
116 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
117 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
118 - new vroute
119
120 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
121 - Bug fix for 2.6.27+ kernels
122
123 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
124 - first draft of new scripts to handle openvswitch
125
126 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
127 - rsyncnodelogs script, make it easy to bring up tun/tap devices
128
129 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
130 - support newer kernels
131
132 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
133 - Add executable tag to vif_up to let it run.
134
135 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
136 - Added execute attribute to vif_up, the absence of which prevented it from being used.
137
138 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
139 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
140 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
141
142 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
143 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
144 - and other minor changes.
145
146 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
147 - fix dotsshmount
148
149 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
150 - change dotsshmount's mount point
151
152 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
153 - Switch fd_tuntap to 2.6.27.
154
155 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
156 - Tweak to if_port_forward script.
157
158 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
159 - Added if_port_forward script to enable slices to forward ports for their
160 - allocated IP addresses.
161
162 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
163 - - hostname filter and updated documentation for ipfw scripts - Marta
164 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
165 - (if this is not needed anymore please remove and tag again)
166
167 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
168 - Tweak to Thom Haddow's script to let a slice see packets related to
169 - existing connections.
170
171 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
172 - ipfw frontend has a rules cleanup feature
173 - ongoing work around vif_up
174 - new script 'run_with_devices'
175
176 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
177 - improve usability of the ipfw backend
178
179 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
180 - * Load the tun module if it is not already loaded
181 - * Fixed a bug in fd_tuntap
182
183 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
184 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
185
186 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
187 - This update adds Thom Haddow's custom tun/tap-device scripts.
188
189 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
190 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
191
192 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
193 - minor changes in sliceip and ipfw, new reserve_udp_port
194
195 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
196 - Added reserve_tcp_port and Giovanni's slice_ip tool.
197
198 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
199 - tweak in ipfw-be for in-node emulation
200
201 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
202 - Added the ipfw backend script
203
204 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
205 - rsync authlogs to ~/
206
207 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
208 - Security update. umount had an issue that might have been exploited.
209
210 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
211 - Adding port reservation script (goodfences)
212 - Modifying umount to be more (or less, depending on your point of view) robust
213
214
215
216 %define module_current_branch 0.7