Setting tag vsys-scripts-0.95-49
[vsys-scripts.git] / root-context / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6
7 %define name vsys-scripts
8 %define version 0.95
9 %define taglevel 49
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab %{plrelease}
16 URL: %{SCMURL}
17
18 Summary: Vsys scripts scripts
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 Requires: vsys
26
27 Source0: vsys-scripts-%{version}.tar.gz
28
29 %description
30 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
31 to which users require privileged access.
32
33 %prep
34 %setup
35
36 %build
37 rm -rf $RPM_BUILD_ROOT
38 make -C root-context
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/vsys
42 install -D root-context/exec/* $RPM_BUILD_ROOT/vsys/
43 install -D root-context/init/sliceip.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sliceip
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 /vsys/
50 /etc/rc.d/init.d/
51
52 %post
53
54 %postun
55
56 %changelog
57 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-49
58 - new privilege script pvtfs
59
60 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-48
61 - sliceip has support for lxc and vs nodes (Thanks Giovanni)
62
63 * Tue Jun 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-47
64 - Giuseppe Lettieri's patch for ignoring glitches when tearing down iptables rules
65
66 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-46
67 - vif_up can set dropkern and mtu
68
69 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-45
70 - script 'promisc' can set a device in promiscuous mode
71
72 * Tue Sep 04 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-44
73 - new slice-oriented package vsys-wrapper (python wrapper)
74 - new layout of the module, spit between root-context and slice-context
75
76 * Fri Jul 27 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-43
77
78 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
79 - fix TUN devices creation (was always creating TAPs)
80
81 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
82
83 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
84
85 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
86 - prevent vserver from unsharing namespaces
87
88 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
89 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
90
91 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
92 - A new script that lets slices serve DNS by binding to UDP port 53.
93
94 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
95 - Disable namespaces for pl_netflow
96
97 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
98 - Added a script for users to create custom distributions within their slices. Use as follows:
99 - mkdir /rootfs;cd /rootfs
100 - wget <your distribution tarball>
101 - tar xvfz <tarball>
102 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
103 - cat /vsys/switcheroo.out &
104 - echo 1 > /vsys/switcheroo.in
105
106 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
107 - Added a new script from Jude.
108
109 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
110 - Build fd_netlink, a new script that lets slices stream packet headers
111
112 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
113 - New script for slices to stream the headers of all packets going out of a node.
114
115 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
116 - vif_up has support for GRE tunnels
117 - sliceip is known to cause kernel crashes with 2.6.32 at least
118
119 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
120 - New script: claimport.
121
122 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
123 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
124 - new vroute
125
126 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
127 - Bug fix for 2.6.27+ kernels
128
129 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
130 - first draft of new scripts to handle openvswitch
131
132 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
133 - rsyncnodelogs script, make it easy to bring up tun/tap devices
134
135 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
136 - support newer kernels
137
138 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
139 - Add executable tag to vif_up to let it run.
140
141 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
142 - Added execute attribute to vif_up, the absence of which prevented it from being used.
143
144 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
145 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
146 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
147
148 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
149 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
150 - and other minor changes.
151
152 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
153 - fix dotsshmount
154
155 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
156 - change dotsshmount's mount point
157
158 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
159 - Switch fd_tuntap to 2.6.27.
160
161 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
162 - Tweak to if_port_forward script.
163
164 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
165 - Added if_port_forward script to enable slices to forward ports for their
166 - allocated IP addresses.
167
168 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
169 - - hostname filter and updated documentation for ipfw scripts - Marta
170 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
171 - (if this is not needed anymore please remove and tag again)
172
173 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
174 - Tweak to Thom Haddow's script to let a slice see packets related to
175 - existing connections.
176
177 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
178 - ipfw frontend has a rules cleanup feature
179 - ongoing work around vif_up
180 - new script 'run_with_devices'
181
182 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
183 - improve usability of the ipfw backend
184
185 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
186 - * Load the tun module if it is not already loaded
187 - * Fixed a bug in fd_tuntap
188
189 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
190 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
191
192 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
193 - This update adds Thom Haddow's custom tun/tap-device scripts.
194
195 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
196 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
197
198 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
199 - minor changes in sliceip and ipfw, new reserve_udp_port
200
201 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
202 - Added reserve_tcp_port and Giovanni's slice_ip tool.
203
204 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
205 - tweak in ipfw-be for in-node emulation
206
207 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
208 - Added the ipfw backend script
209
210 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
211 - rsync authlogs to ~/
212
213 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
214 - Security update. umount had an issue that might have been exploited.
215
216 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
217 - Adding port reservation script (goodfences)
218 - Modifying umount to be more (or less, depending on your point of view) robust
219
220
221
222 %define module_current_branch 0.7