Dont use namespaces for pl_netflow slice
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 35
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
58 - Added a script for users to create custom distributions within their slices. Use as follows:
59 - mkdir /rootfs;cd /rootfs
60 - wget <your distribution tarball>
61 - tar xvfz <tarball>
62 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
63 - cat /vsys/switcheroo.out &
64 - echo 1 > /vsys/switcheroo.in
65
66 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
67 - Added a new script from Jude.
68
69 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
70 - Build fd_netlink, a new script that lets slices stream packet headers
71
72 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
73 - New script for slices to stream the headers of all packets going out of a node.
74
75 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
76 - vif_up has support for GRE tunnels
77 - sliceip is known to cause kernel crashes with 2.6.32 at least
78
79 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
80 - New script: claimport.
81
82 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
83 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
84 - new vroute
85
86 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
87 - Bug fix for 2.6.27+ kernels
88
89 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
90 - first draft of new scripts to handle openvswitch
91
92 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
93 - rsyncnodelogs script, make it easy to bring up tun/tap devices
94
95 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
96 - support newer kernels
97
98 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
99 - Add executable tag to vif_up to let it run.
100
101 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
102 - Added execute attribute to vif_up, the absence of which prevented it from being used.
103
104 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
105 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
106 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
107
108 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
109 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
110 - and other minor changes.
111
112 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
113 - fix dotsshmount
114
115 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
116 - change dotsshmount's mount point
117
118 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
119 - Switch fd_tuntap to 2.6.27.
120
121 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
122 - Tweak to if_port_forward script.
123
124 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
125 - Added if_port_forward script to enable slices to forward ports for their
126 - allocated IP addresses.
127
128 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
129 - - hostname filter and updated documentation for ipfw scripts - Marta
130 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
131 - (if this is not needed anymore please remove and tag again)
132
133 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
134 - Tweak to Thom Haddow's script to let a slice see packets related to
135 - existing connections.
136
137 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
138 - ipfw frontend has a rules cleanup feature
139 - ongoing work around vif_up
140 - new script 'run_with_devices'
141
142 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
143 - improve usability of the ipfw backend
144
145 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
146 - * Load the tun module if it is not already loaded
147 - * Fixed a bug in fd_tuntap
148
149 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
150 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
151
152 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
153 - This update adds Thom Haddow's custom tun/tap-device scripts.
154
155 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
156 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
157
158 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
159 - minor changes in sliceip and ipfw, new reserve_udp_port
160
161 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
162 - Added reserve_tcp_port and Giovanni's slice_ip tool.
163
164 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
165 - tweak in ipfw-be for in-node emulation
166
167 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
168 - Added the ipfw backend script
169
170 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
171 - rsync authlogs to ~/
172
173 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
174 - Security update. umount had an issue that might have been exploited.
175
176 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
177 - Adding port reservation script (goodfences)
178 - Modifying umount to be more (or less, depending on your point of view) robust
179
180
181
182 %define module_current_branch 0.7