pltun should create TUN not TAP interfaces
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 41
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
58
59 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
60
61 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
62 - prevent vserver from unsharing namespaces
63
64 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
65 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
66
67 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
68 - A new script that lets slices serve DNS by binding to UDP port 53.
69
70 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
71 - Disable namespaces for pl_netflow
72
73 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
74 - Added a script for users to create custom distributions within their slices. Use as follows:
75 - mkdir /rootfs;cd /rootfs
76 - wget <your distribution tarball>
77 - tar xvfz <tarball>
78 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
79 - cat /vsys/switcheroo.out &
80 - echo 1 > /vsys/switcheroo.in
81
82 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
83 - Added a new script from Jude.
84
85 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
86 - Build fd_netlink, a new script that lets slices stream packet headers
87
88 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
89 - New script for slices to stream the headers of all packets going out of a node.
90
91 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
92 - vif_up has support for GRE tunnels
93 - sliceip is known to cause kernel crashes with 2.6.32 at least
94
95 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
96 - New script: claimport.
97
98 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
99 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
100 - new vroute
101
102 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
103 - Bug fix for 2.6.27+ kernels
104
105 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
106 - first draft of new scripts to handle openvswitch
107
108 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
109 - rsyncnodelogs script, make it easy to bring up tun/tap devices
110
111 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
112 - support newer kernels
113
114 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
115 - Add executable tag to vif_up to let it run.
116
117 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
118 - Added execute attribute to vif_up, the absence of which prevented it from being used.
119
120 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
121 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
122 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
123
124 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
125 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
126 - and other minor changes.
127
128 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
129 - fix dotsshmount
130
131 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
132 - change dotsshmount's mount point
133
134 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
135 - Switch fd_tuntap to 2.6.27.
136
137 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
138 - Tweak to if_port_forward script.
139
140 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
141 - Added if_port_forward script to enable slices to forward ports for their
142 - allocated IP addresses.
143
144 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
145 - - hostname filter and updated documentation for ipfw scripts - Marta
146 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
147 - (if this is not needed anymore please remove and tag again)
148
149 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
150 - Tweak to Thom Haddow's script to let a slice see packets related to
151 - existing connections.
152
153 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
154 - ipfw frontend has a rules cleanup feature
155 - ongoing work around vif_up
156 - new script 'run_with_devices'
157
158 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
159 - improve usability of the ipfw backend
160
161 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
162 - * Load the tun module if it is not already loaded
163 - * Fixed a bug in fd_tuntap
164
165 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
166 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
167
168 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
169 - This update adds Thom Haddow's custom tun/tap-device scripts.
170
171 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
172 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
173
174 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
175 - minor changes in sliceip and ipfw, new reserve_udp_port
176
177 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
178 - Added reserve_tcp_port and Giovanni's slice_ip tool.
179
180 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
181 - tweak in ipfw-be for in-node emulation
182
183 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
184 - Added the ipfw backend script
185
186 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
187 - rsync authlogs to ~/
188
189 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
190 - Security update. umount had an issue that might have been exploited.
191
192 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
193 - Adding port reservation script (goodfences)
194 - Modifying umount to be more (or less, depending on your point of view) robust
195
196
197
198 %define module_current_branch 0.7