Setting tag vsys-scripts-0.95-34
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 34
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
58 - Added a new script from Jude.
59
60 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
61 - Build fd_netlink, a new script that lets slices stream packet headers
62
63 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
64 - New script for slices to stream the headers of all packets going out of a node.
65
66 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
67 - vif_up has support for GRE tunnels
68 - sliceip is known to cause kernel crashes with 2.6.32 at least
69
70 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
71 - New script: claimport.
72
73 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
74 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
75 - new vroute
76
77 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
78 - Bug fix for 2.6.27+ kernels
79
80 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
81 - first draft of new scripts to handle openvswitch
82
83 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
84 - rsyncnodelogs script, make it easy to bring up tun/tap devices
85
86 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
87 - support newer kernels
88
89 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
90 - Add executable tag to vif_up to let it run.
91
92 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
93 - Added execute attribute to vif_up, the absence of which prevented it from being used.
94
95 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
96 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
97 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
98
99 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
100 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
101 - and other minor changes.
102
103 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
104 - fix dotsshmount
105
106 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
107 - change dotsshmount's mount point
108
109 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
110 - Switch fd_tuntap to 2.6.27.
111
112 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
113 - Tweak to if_port_forward script.
114
115 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
116 - Added if_port_forward script to enable slices to forward ports for their
117 - allocated IP addresses.
118
119 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
120 - - hostname filter and updated documentation for ipfw scripts - Marta
121 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
122 - (if this is not needed anymore please remove and tag again)
123
124 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
125 - Tweak to Thom Haddow's script to let a slice see packets related to
126 - existing connections.
127
128 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
129 - ipfw frontend has a rules cleanup feature
130 - ongoing work around vif_up
131 - new script 'run_with_devices'
132
133 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
134 - improve usability of the ipfw backend
135
136 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
137 - * Load the tun module if it is not already loaded
138 - * Fixed a bug in fd_tuntap
139
140 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
141 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
142
143 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
144 - This update adds Thom Haddow's custom tun/tap-device scripts.
145
146 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
147 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
148
149 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
150 - minor changes in sliceip and ipfw, new reserve_udp_port
151
152 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
153 - Added reserve_tcp_port and Giovanni's slice_ip tool.
154
155 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
156 - tweak in ipfw-be for in-node emulation
157
158 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
159 - Added the ipfw backend script
160
161 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
162 - rsync authlogs to ~/
163
164 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
165 - Security update. umount had an issue that might have been exploited.
166
167 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
168 - Adding port reservation script (goodfences)
169 - Modifying umount to be more (or less, depending on your point of view) robust
170
171
172
173 %define module_current_branch 0.7