fix conflict
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 22
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
58 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
59 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
60
61 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
62 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
63 - and other minor changes.
64
65 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
66 - fix dotsshmount
67
68 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
69 - change dotsshmount's mount point
70
71 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
72 - Switch fd_tuntap to 2.6.27.
73
74 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
75 - Tweak to if_port_forward script.
76
77 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
78 - Added if_port_forward script to enable slices to forward ports for their
79 - allocated IP addresses.
80
81 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
82 - - hostname filter and updated documentation for ipfw scripts - Marta
83 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
84 - (if this is not needed anymore please remove and tag again)
85
86 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
87 - Tweak to Thom Haddow's script to let a slice see packets related to
88 - existing connections.
89
90 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
91 - ipfw frontend has a rules cleanup feature
92 - ongoing work around vif_up
93 - new script 'run_with_devices'
94
95 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
96 - improve usability of the ipfw backend
97
98 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
99 - * Load the tun module if it is not already loaded
100 - * Fixed a bug in fd_tuntap
101
102 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
103 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
104
105 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
106 - This update adds Thom Haddow's custom tun/tap-device scripts.
107
108 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
109 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
110
111 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
112 - minor changes in sliceip and ipfw, new reserve_udp_port
113
114 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
115 - Added reserve_tcp_port and Giovanni's slice_ip tool.
116
117 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
118 - tweak in ipfw-be for in-node emulation
119
120 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
121 - Added the ipfw backend script
122
123 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
124 - rsync authlogs to ~/
125
126 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
127 - Security update. umount had an issue that might have been exploited.
128
129 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
130 - Adding port reservation script (goodfences)
131 - Modifying umount to be more (or less, depending on your point of view) robust
132
133
134
135 %define module_current_branch 0.7