Build fd_netlink
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 32
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
58 - New script for slices to stream the headers of all packets going out of a node.
59
60 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
61 - vif_up has support for GRE tunnels
62 - sliceip is known to cause kernel crashes with 2.6.32 at least
63
64 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
65 - New script: claimport.
66
67 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
68 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
69 - new vroute
70
71 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
72 - Bug fix for 2.6.27+ kernels
73
74 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
75 - first draft of new scripts to handle openvswitch
76
77 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
78 - rsyncnodelogs script, make it easy to bring up tun/tap devices
79
80 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
81 - support newer kernels
82
83 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
84 - Add executable tag to vif_up to let it run.
85
86 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
87 - Added execute attribute to vif_up, the absence of which prevented it from being used.
88
89 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
90 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
91 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
92
93 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
94 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
95 - and other minor changes.
96
97 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
98 - fix dotsshmount
99
100 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
101 - change dotsshmount's mount point
102
103 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
104 - Switch fd_tuntap to 2.6.27.
105
106 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
107 - Tweak to if_port_forward script.
108
109 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
110 - Added if_port_forward script to enable slices to forward ports for their
111 - allocated IP addresses.
112
113 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
114 - - hostname filter and updated documentation for ipfw scripts - Marta
115 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
116 - (if this is not needed anymore please remove and tag again)
117
118 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
119 - Tweak to Thom Haddow's script to let a slice see packets related to
120 - existing connections.
121
122 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
123 - ipfw frontend has a rules cleanup feature
124 - ongoing work around vif_up
125 - new script 'run_with_devices'
126
127 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
128 - improve usability of the ipfw backend
129
130 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
131 - * Load the tun module if it is not already loaded
132 - * Fixed a bug in fd_tuntap
133
134 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
135 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
136
137 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
138 - This update adds Thom Haddow's custom tun/tap-device scripts.
139
140 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
141 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
142
143 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
144 - minor changes in sliceip and ipfw, new reserve_udp_port
145
146 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
147 - Added reserve_tcp_port and Giovanni's slice_ip tool.
148
149 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
150 - tweak in ipfw-be for in-node emulation
151
152 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
153 - Added the ipfw backend script
154
155 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
156 - rsync authlogs to ~/
157
158 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
159 - Security update. umount had an issue that might have been exploited.
160
161 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
162 - Adding port reservation script (goodfences)
163 - Modifying umount to be more (or less, depending on your point of view) robust
164
165
166
167 %define module_current_branch 0.7