Setting tag vsys-scripts-0.95-31
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 31
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
58 - vif_up has support for GRE tunnels
59 - sliceip is known to cause kernel crashes with 2.6.32 at least
60
61 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
62 - New script: claimport.
63
64 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
65 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
66 - new vroute
67
68 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
69 - Bug fix for 2.6.27+ kernels
70
71 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
72 - first draft of new scripts to handle openvswitch
73
74 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
75 - rsyncnodelogs script, make it easy to bring up tun/tap devices
76
77 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
78 - support newer kernels
79
80 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
81 - Add executable tag to vif_up to let it run.
82
83 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
84 - Added execute attribute to vif_up, the absence of which prevented it from being used.
85
86 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
87 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
88 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
89
90 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
91 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
92 - and other minor changes.
93
94 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
95 - fix dotsshmount
96
97 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
98 - change dotsshmount's mount point
99
100 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
101 - Switch fd_tuntap to 2.6.27.
102
103 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
104 - Tweak to if_port_forward script.
105
106 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
107 - Added if_port_forward script to enable slices to forward ports for their
108 - allocated IP addresses.
109
110 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
111 - - hostname filter and updated documentation for ipfw scripts - Marta
112 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
113 - (if this is not needed anymore please remove and tag again)
114
115 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
116 - Tweak to Thom Haddow's script to let a slice see packets related to
117 - existing connections.
118
119 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
120 - ipfw frontend has a rules cleanup feature
121 - ongoing work around vif_up
122 - new script 'run_with_devices'
123
124 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
125 - improve usability of the ipfw backend
126
127 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
128 - * Load the tun module if it is not already loaded
129 - * Fixed a bug in fd_tuntap
130
131 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
132 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
133
134 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
135 - This update adds Thom Haddow's custom tun/tap-device scripts.
136
137 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
138 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
139
140 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
141 - minor changes in sliceip and ipfw, new reserve_udp_port
142
143 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
144 - Added reserve_tcp_port and Giovanni's slice_ip tool.
145
146 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
147 - tweak in ipfw-be for in-node emulation
148
149 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
150 - Added the ipfw backend script
151
152 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
153 - rsync authlogs to ~/
154
155 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
156 - Security update. umount had an issue that might have been exploited.
157
158 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
159 - Adding port reservation script (goodfences)
160 - Modifying umount to be more (or less, depending on your point of view) robust
161
162
163
164 %define module_current_branch 0.7