Setting tag vsys-scripts-0.95-25
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 25
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
58 - support newer kernels
59
60 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
61 - Add executable tag to vif_up to let it run.
62
63 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
64 - Added execute attribute to vif_up, the absence of which prevented it from being used.
65
66 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
67 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
68 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
69
70 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
71 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
72 - and other minor changes.
73
74 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
75 - fix dotsshmount
76
77 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
78 - change dotsshmount's mount point
79
80 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
81 - Switch fd_tuntap to 2.6.27.
82
83 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
84 - Tweak to if_port_forward script.
85
86 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
87 - Added if_port_forward script to enable slices to forward ports for their
88 - allocated IP addresses.
89
90 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
91 - - hostname filter and updated documentation for ipfw scripts - Marta
92 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
93 - (if this is not needed anymore please remove and tag again)
94
95 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
96 - Tweak to Thom Haddow's script to let a slice see packets related to
97 - existing connections.
98
99 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
100 - ipfw frontend has a rules cleanup feature
101 - ongoing work around vif_up
102 - new script 'run_with_devices'
103
104 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
105 - improve usability of the ipfw backend
106
107 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
108 - * Load the tun module if it is not already loaded
109 - * Fixed a bug in fd_tuntap
110
111 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
112 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
113
114 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
115 - This update adds Thom Haddow's custom tun/tap-device scripts.
116
117 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
118 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
119
120 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
121 - minor changes in sliceip and ipfw, new reserve_udp_port
122
123 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
124 - Added reserve_tcp_port and Giovanni's slice_ip tool.
125
126 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
127 - tweak in ipfw-be for in-node emulation
128
129 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
130 - Added the ipfw backend script
131
132 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
133 - rsync authlogs to ~/
134
135 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
136 - Security update. umount had an issue that might have been exploited.
137
138 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
139 - Adding port reservation script (goodfences)
140 - Modifying umount to be more (or less, depending on your point of view) robust
141
142
143
144 %define module_current_branch 0.7