Setting tag vsys-scripts-0.95-42
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 42
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
58 - fix TUN devices creation (was always creating TAP's)
59
60 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
61
62 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
63
64 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
65 - prevent vserver from unsharing namespaces
66
67 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
68 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
69
70 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
71 - A new script that lets slices serve DNS by binding to UDP port 53.
72
73 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
74 - Disable namespaces for pl_netflow
75
76 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
77 - Added a script for users to create custom distributions within their slices. Use as follows:
78 - mkdir /rootfs;cd /rootfs
79 - wget <your distribution tarball>
80 - tar xvfz <tarball>
81 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
82 - cat /vsys/switcheroo.out &
83 - echo 1 > /vsys/switcheroo.in
84
85 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
86 - Added a new script from Jude.
87
88 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
89 - Build fd_netlink, a new script that lets slices stream packet headers
90
91 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
92 - New script for slices to stream the headers of all packets going out of a node.
93
94 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
95 - vif_up has support for GRE tunnels
96 - sliceip is known to cause kernel crashes with 2.6.32 at least
97
98 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
99 - New script: claimport.
100
101 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
102 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
103 - new vroute
104
105 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
106 - Bug fix for 2.6.27+ kernels
107
108 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
109 - first draft of new scripts to handle openvswitch
110
111 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
112 - rsyncnodelogs script, make it easy to bring up tun/tap devices
113
114 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
115 - support newer kernels
116
117 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
118 - Add executable tag to vif_up to let it run.
119
120 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
121 - Added execute attribute to vif_up, the absence of which prevented it from being used.
122
123 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
124 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
125 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
126
127 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
128 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
129 - and other minor changes.
130
131 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
132 - fix dotsshmount
133
134 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
135 - change dotsshmount's mount point
136
137 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
138 - Switch fd_tuntap to 2.6.27.
139
140 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
141 - Tweak to if_port_forward script.
142
143 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
144 - Added if_port_forward script to enable slices to forward ports for their
145 - allocated IP addresses.
146
147 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
148 - - hostname filter and updated documentation for ipfw scripts - Marta
149 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
150 - (if this is not needed anymore please remove and tag again)
151
152 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
153 - Tweak to Thom Haddow's script to let a slice see packets related to
154 - existing connections.
155
156 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
157 - ipfw frontend has a rules cleanup feature
158 - ongoing work around vif_up
159 - new script 'run_with_devices'
160
161 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
162 - improve usability of the ipfw backend
163
164 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
165 - * Load the tun module if it is not already loaded
166 - * Fixed a bug in fd_tuntap
167
168 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
169 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
170
171 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
172 - This update adds Thom Haddow's custom tun/tap-device scripts.
173
174 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
175 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
176
177 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
178 - minor changes in sliceip and ipfw, new reserve_udp_port
179
180 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
181 - Added reserve_tcp_port and Giovanni's slice_ip tool.
182
183 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
184 - tweak in ipfw-be for in-node emulation
185
186 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
187 - Added the ipfw backend script
188
189 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
190 - rsync authlogs to ~/
191
192 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
193 - Security update. umount had an issue that might have been exploited.
194
195 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
196 - Adding port reservation script (goodfences)
197 - Modifying umount to be more (or less, depending on your point of view) robust
198
199
200
201 %define module_current_branch 0.7