Setting tag vsys-scripts-0.95-33
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 33
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
58 - Build fd_netlink, a new script that lets slices stream packet headers
59
60 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
61 - New script for slices to stream the headers of all packets going out of a node.
62
63 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
64 - vif_up has support for GRE tunnels
65 - sliceip is known to cause kernel crashes with 2.6.32 at least
66
67 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
68 - New script: claimport.
69
70 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
71 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
72 - new vroute
73
74 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
75 - Bug fix for 2.6.27+ kernels
76
77 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
78 - first draft of new scripts to handle openvswitch
79
80 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
81 - rsyncnodelogs script, make it easy to bring up tun/tap devices
82
83 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
84 - support newer kernels
85
86 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
87 - Add executable tag to vif_up to let it run.
88
89 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
90 - Added execute attribute to vif_up, the absence of which prevented it from being used.
91
92 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
93 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
94 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
95
96 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
97 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
98 - and other minor changes.
99
100 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
101 - fix dotsshmount
102
103 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
104 - change dotsshmount's mount point
105
106 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
107 - Switch fd_tuntap to 2.6.27.
108
109 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
110 - Tweak to if_port_forward script.
111
112 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
113 - Added if_port_forward script to enable slices to forward ports for their
114 - allocated IP addresses.
115
116 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
117 - - hostname filter and updated documentation for ipfw scripts - Marta
118 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
119 - (if this is not needed anymore please remove and tag again)
120
121 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
122 - Tweak to Thom Haddow's script to let a slice see packets related to
123 - existing connections.
124
125 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
126 - ipfw frontend has a rules cleanup feature
127 - ongoing work around vif_up
128 - new script 'run_with_devices'
129
130 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
131 - improve usability of the ipfw backend
132
133 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
134 - * Load the tun module if it is not already loaded
135 - * Fixed a bug in fd_tuntap
136
137 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
138 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
139
140 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
141 - This update adds Thom Haddow's custom tun/tap-device scripts.
142
143 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
144 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
145
146 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
147 - minor changes in sliceip and ipfw, new reserve_udp_port
148
149 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
150 - Added reserve_tcp_port and Giovanni's slice_ip tool.
151
152 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
153 - tweak in ipfw-be for in-node emulation
154
155 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
156 - Added the ipfw backend script
157
158 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
159 - rsync authlogs to ~/
160
161 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
162 - Security update. umount had an issue that might have been exploited.
163
164 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
165 - Adding port reservation script (goodfences)
166 - Modifying umount to be more (or less, depending on your point of view) robust
167
168
169
170 %define module_current_branch 0.7