Make deletion optional in vif_down
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 36
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
58 - Disable namespaces for pl_netflow
59
60 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
61 - Added a script for users to create custom distributions within their slices. Use as follows:
62 - mkdir /rootfs;cd /rootfs
63 - wget <your distribution tarball>
64 - tar xvfz <tarball>
65 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
66 - cat /vsys/switcheroo.out &
67 - echo 1 > /vsys/switcheroo.in
68
69 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
70 - Added a new script from Jude.
71
72 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
73 - Build fd_netlink, a new script that lets slices stream packet headers
74
75 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
76 - New script for slices to stream the headers of all packets going out of a node.
77
78 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
79 - vif_up has support for GRE tunnels
80 - sliceip is known to cause kernel crashes with 2.6.32 at least
81
82 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
83 - New script: claimport.
84
85 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
86 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
87 - new vroute
88
89 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
90 - Bug fix for 2.6.27+ kernels
91
92 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
93 - first draft of new scripts to handle openvswitch
94
95 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
96 - rsyncnodelogs script, make it easy to bring up tun/tap devices
97
98 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
99 - support newer kernels
100
101 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
102 - Add executable tag to vif_up to let it run.
103
104 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
105 - Added execute attribute to vif_up, the absence of which prevented it from being used.
106
107 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
108 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
109 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
110
111 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
112 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
113 - and other minor changes.
114
115 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
116 - fix dotsshmount
117
118 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
119 - change dotsshmount's mount point
120
121 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
122 - Switch fd_tuntap to 2.6.27.
123
124 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
125 - Tweak to if_port_forward script.
126
127 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
128 - Added if_port_forward script to enable slices to forward ports for their
129 - allocated IP addresses.
130
131 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
132 - - hostname filter and updated documentation for ipfw scripts - Marta
133 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
134 - (if this is not needed anymore please remove and tag again)
135
136 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
137 - Tweak to Thom Haddow's script to let a slice see packets related to
138 - existing connections.
139
140 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
141 - ipfw frontend has a rules cleanup feature
142 - ongoing work around vif_up
143 - new script 'run_with_devices'
144
145 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
146 - improve usability of the ipfw backend
147
148 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
149 - * Load the tun module if it is not already loaded
150 - * Fixed a bug in fd_tuntap
151
152 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
153 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
154
155 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
156 - This update adds Thom Haddow's custom tun/tap-device scripts.
157
158 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
159 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
160
161 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
162 - minor changes in sliceip and ipfw, new reserve_udp_port
163
164 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
165 - Added reserve_tcp_port and Giovanni's slice_ip tool.
166
167 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
168 - tweak in ipfw-be for in-node emulation
169
170 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
171 - Added the ipfw backend script
172
173 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
174 - rsync authlogs to ~/
175
176 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
177 - Security update. umount had an issue that might have been exploited.
178
179 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
180 - Adding port reservation script (goodfences)
181 - Modifying umount to be more (or less, depending on your point of view) robust
182
183
184
185 %define module_current_branch 0.7