Merge remote-tracking branch 'origin/rhel6' into centos5
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 Summary: RPM installer/updater
4 Name: yum
5 Version: 3.2.22
6 Release: 33.el5.chroot1
7 License: GPLv2+
8 Group: System Environment/Base
9 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
10 Source1: yum.conf.fedora
11 Source2: yum-updatesd.conf.fedora
12
13 # Fedora patches we might as well carry
14 Patch0: installonlyn-enable.patch
15 Patch1: yum-mirror-priority.patch
16 Patch2: yum-manpage-files.patch
17 Patch3: yum-ia64-multilib.patch
18 # NOTE: We don't carry this as it'd change the policy mid cycle
19 # Patch3: yum-multilib-policy-best.patch
20
21 # Work around python-2.4.z's gettext ... maybe not needed post 5.3
22 Patch102: yum-hack-python-gettext-workaround.patch
23 # SSL, although it's still done in RHN-plugin
24 # Also fixes 462915: client and server x509 support for Yum
25 Patch103: yum-3.2.22-client+server-x509.patch
26
27 # Python-2.* is just too sucky to enable this
28 Patch104: yum-3.2.22-i18n-off.patch
29
30 # Post 3.2.22 release upstream changes
31 Patch110: yum-3.2.22-post-BIG.patch
32 Patch111: yum-3.2.22-txmbr-sort.patch
33 Patch112: yum-3.2.22-kernel-updates-minimize.patch
34 Patch113: yum-3.2.22-pylin-indent-fix.patch
35 Patch114: yum-3.2.22-i18n-gettext-typo-fix.patch
36 Patch115: yum-3.2.22-sort-providers.patch
37 Patch116: yum-3.2.22-local-pkgs.patch
38 Patch117: yum-3.2.22-rawhide-fixes.patch
39 Patch118: yum-3.2.22-regression.patch
40 Patch119: yum-3.2.22-reinstall-local.patch
41 Patch120: yum-3.2.23-rawhide-fixes.patch
42
43 # 5.5 patches...
44 Patch201: BZ-517286-instant-downloads.patch
45 Patch202: BZ-521008-regression-update-not-exist.patch
46 Patch203: BZ-526064-check-update-obs.patch
47 Patch204: BZ-528738-bugtracker.patch
48 Patch205: BZ-528746-reinstall-compat-rpm.patch
49 Patch206: BZ-529233-faster-compare_providers.patch
50 Patch207: BZ-529719-base_package_name-compare_providers.patch
51 Patch208: BZ-548582-excludes-source-repos-crash.patch
52 Patch209: BZ-523135-newest-obs-only.patch
53
54 # 5.6 patches...
55 Patch210: BZ-500721-sslverify-control-name-cert-mismatch.patch
56 Patch211: BZ-593349-install-obs-pkg-wrong-arch.patch
57 Patch212: BZ-628963-Handle-generated-.sqlite-files,-for-unique-.xml-MD.patch
58 Patch213: BZ-623955-traceback-no-proc-mounted.patch
59 Patch214: BZ-637146-document-ssl-options.patch
60 Patch215: BZ-634119-parse-enhanced-updateinfo-MD.patch
61
62 Patch1000: yum-3.2.22-chroot.patch
63
64 URL: http://yum.baseurl.org/
65 BuildArchitectures: noarch
66 BuildRequires: python
67 BuildRequires: gettext
68 BuildRequires: intltool
69 Conflicts: pirut < 1.1.4
70 Conflicts: yum-versionlock < 1.1.16-13.el5
71 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
72 Requires: python-iniparse
73 Requires: python-sqlite
74 Requires: urlgrabber >= 3.1.0
75 Requires: python-elementtree
76 # Make sure metadata code is updated too
77 Requires: yum-metadata-parser >= 1.1.0
78 Conflicts: yum-rhn-plugin < 0.5.3-30.el5
79 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
80 Obsoletes: yum-skip-broken
81 Conflicts: yum-skip-broken
82 Obsoletes: yum-basearchonly
83 Conflicts: yum-basearchonly
84 # yum-complete-transaction from 1.1.10-9.el5 has problems:
85 Conflicts: yum-utils < 1.1.16-11
86 # We don't require this in RHEL, although it'll use it if you have it
87 # suggests would be ok, if it worked and if pygpgme wasn't in EPEL :).
88 # Requires: pygpgme
89 Obsoletes: yum-allow-downgrade < 1.1.20-0
90 Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
91
92 %description
93 Yum is a utility that can check for and automatically download and
94 install updated RPM packages. Dependencies are obtained and downloaded 
95 automatically prompting the user as necessary.
96
97 %package updatesd
98 Summary: Update notification daemon
99 Group: Applications/System
100 Requires: yum = %{version}-%{release}
101 Requires: dbus-python
102 Requires: pygobject2
103 Requires(preun): /sbin/chkconfig
104 Requires(post): /sbin/chkconfig
105 Requires(preun): /sbin/service
106 Requires(post): /sbin/service
107
108 %description updatesd
109 yum-updatesd provides a daemon which checks for available updates and 
110 can notify you when they are available via email, syslog or dbus. 
111
112 %prep
113 %setup -q
114
115 %define _default_patch_fuzz 2
116
117 %patch0 -p1
118 %patch1 -p1
119 %patch2 -p1
120 %patch3 -p1
121
122 %patch102 -p1
123 %patch103 -p1
124
125 %patch104 -p1
126
127 %patch110 -p1
128 %patch111 -p1
129 %patch112 -p1
130 %patch113 -p1
131 %patch114 -p1
132 %patch115 -p1
133 %patch116 -p1
134 %patch117 -p1
135 %patch118 -p1
136 %patch119 -p1
137 %patch120 -p1
138
139 %patch201 -p1
140 %patch202 -p1
141 %patch203 -p1
142 %patch204 -p1
143 %patch205 -p1
144 %patch206 -p1
145 %patch207 -p1
146 %patch208 -p1
147 %patch209 -p1
148
149 %patch210 -p1
150 %patch211 -p1
151 %patch212 -p1
152 %patch213 -p1
153 %patch214 -p1
154 %patch215 -p1
155
156 %patch1000 -p1
157
158 %build
159 make
160
161 %install
162 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
163 make DESTDIR=$RPM_BUILD_ROOT install
164 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/yum.conf
165
166 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
167
168 # for now, move repodir/yum.conf back
169 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
170 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
171
172 # yum-updatesd has moved to the separate source version
173 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
174 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
175 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
176 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
177 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
178
179 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
180
181 %find_lang %name
182
183 %clean
184 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
185
186 %files -f %{name}.lang
187 %defattr(-, root, root, -)
188 %doc README AUTHORS COPYING TODO INSTALL ChangeLog PLUGINS
189 %config(noreplace) %{_sysconfdir}/yum.conf
190 %dir %{_sysconfdir}/yum
191 %dir %{_sysconfdir}/yum.repos.d
192 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
193 %dir %{_datadir}/yum-cli
194 %{_datadir}/yum-cli/*
195 %{_bindir}/yum
196 %{python_sitelib}/yum
197 %{python_sitelib}/rpmUtils
198 %dir /var/cache/yum
199 %dir /var/lib/yum
200 %{_mandir}/man*/yum.*
201 %{_mandir}/man*/yum-shell*
202 # plugin stuff
203 %dir %{_sysconfdir}/yum/pluginconf.d 
204 %dir /usr/lib/yum-plugins
205
206 %changelog
207 * Tue Nov  2 2010 James Antill <jantill@redhat.com> - 3.2.22-33
208 - Parse enhanced updateinfo MD.
209 - Resolves: rhbz#634119
210
211 * Tue Sep 28 2010 James Antill <jantill@redhat.com> - 3.2.22-32
212 - Document ssl options.
213 - Resolves: rhbz#637146
214
215 * Tue Sep 21 2010 James Antill <jantill@redhat.com> - 3.2.22-30
216 - Fix traceback when there is no proc mounted.
217 - Resolves: rhbz#623955
218
219 * Fri Sep 17 2010 James Antill <jantill@redhat.com> - 3.2.22-29
220 - Fix patch for, install of obsoleted pkg is wrong arch.
221 - Resolves: rhbz#593349
222
223 * Tue Sep 14 2010 James Antill <jantill@redhat.com> - 3.2.22-28
224 - Handle generated .sqlite files, for unique .xml MD.
225 - Resolves: rhbz#628963
226
227 * Wed Aug 11 2010 James Antill <jantill@redhat.com> - 3.2.22-27
228 - Make sslverify control name cert mismatch (requires newer m2crypto)
229 - Resolves: rhbz#500721
230 - Fix install of obsoleted pkg is wrong arch
231 - Resolves: rhbz#593349
232
233 * Tue Feb 23 2010 James Antill <jantill@redhat.com> - 3.2.22-26
234 - Only look at the newest packages for obsoletes, again.
235 - Resolves: rhbz#523135
236
237 * Tue Feb 16 2010 James Antill <jantill@redhat.com> - 3.2.22-25
238 - Fix weird excludes bug for source repos.
239 - Resolves: rhbz#548582
240
241 * Wed Jan 27 2010 James Antill <jantill@redhat.com> - 3.2.22-24
242 - Fix reinstall error handling, due to yumdb usage, bad backport of
243 - patch for 528746.
244 - Resolves: rhbz#559164
245
246 * Thu Dec 17 2009 James Antill <jantill@redhat.com> - 3.2.22-23
247 - Fix bugtracker URL
248 - Resolves: rhbz#528738
249 - Fix reinstall for rpm and general output fixup.
250 - Resolves: rhbz#528746
251 - Remove slow edge case from compare_providers
252 - Resolves: rhbz#529233
253 - Add base package name check to compare_providers()
254 - Resolves: rhbz#529719
255
256 * Wed Oct  7 2009 James Antill <jantill@redhat.com> - 3.2.22-21
257 - Fix instant downloads crash.
258 - Resolves: rhbz#517286
259 - Fix exit regression when updating packages which don't exist.
260 - Resolves: rhbz#521008
261 - Show obsoletes in check-update, if obsoletes flag is on.
262 - Resolves: rhbz#526064
263
264 * Tue Jul  7 2009 James Antill <jantill@redhat.com> - 3.2.22-20
265 - Resolve weird python unicode() vs. str() perf. problem
266 - Resolves: rhbz#509932
267 - Fixup documentation spelling errors.
268 - Resolves: 510012
269
270 * Fri Jun 26 2009 James Antill <jantill@redhat.com> - 3.2.22-18
271 - Allow API users to set repo directory attributes again.
272 - Resolves: rhbz#508055
273 - Re-Fix pkgSack init loop on empty pkgSacks to make anaconda happy.
274 - Resolves: rhbz#507885
275 - Resolves: rhbz#489256
276
277 * Wed Jun 24 2009 James Antill <jantill@redhat.com> - 3.2.22-16
278 - Fix pkgSack init loop on empty pkgSacks.
279 - Resolves: rhbz#507885
280 - Fix turning off color.
281 - Resolves: rhbz#507883
282 - Fix language testing to use LC_MESSAGES instead of LC_CTYPE.
283 - Resolves: rhbz#507357
284 - Fix to_str not being in misc
285 - Resolves: rhbz#508051
286 - Resolves: rhbz#489256
287
288 * Fri Jun 19 2009 James Antill <jantill@redhat.com> - 3.2.22-15
289 - Fix reinstall with local files.
290 - Resolves: rhbz#489256
291 - Resolves: rhbz#462915
292
293 * Thu May 14 2009 James Antill <jantill@redhat.com> - 3.2.22-14
294 - Fix a couple of regressions.
295 - Conflict with older rhn-plugin
296 - Resolves: rhbz#489256
297 - Resolves: rhbz#462915
298 - Resolves: 500697
299
300 * Tue Apr 28 2009 James Antill <jantill@redhat.com> - 3.2.22-10
301 - Rebase for lots of bug fixes, and some features/speedups.
302 - Resolves: rhbz#489256
303 - Resolves: rhbz#462915
304 - Only look at new obsoletes
305
306 * Tue Nov 25 2008 James Antill <jantill@redhat.com> - 3.2.19-18
307 - Fix utf8 in redhat-logos license
308 - Resolves: rhbz#472375
309
310 * Mon Nov 10 2008 James Antill <jantill@redhat.com> - 3.2.19-16
311 - Fix ia64 multilib for RHEL-5
312 - Resolves: rhbz#469271
313
314 * Tue Oct 28 2008 James Antill <jantill@redhat.com> - 3.2.19-14
315 - Fix yum shell when doing remove commands first.
316 - Resolves: rhbz#468754
317
318 * Thu Oct 23 2008 James Antill <jantill@redhat.com> - 3.2.19-13
319 - Add the timestamp_check option, so we can have repoids to random stuff
320 - Resolves: rhbz#466176
321 - Fix yum shell man page for repo command.
322 - Resolves: rhbz#467415
323 - Resolves: rhbz#454882
324
325 * Thu Oct 16 2008 James Antill <jantill@redhat.com> - 3.2.19-11
326 - Don't show rpm progress when in super quiet mode
327 - Resolves: rhbz#466911
328 - Resolves: rhbz#454882
329
330 * Mon Sep 29 2008 James Antill <jantill@redhat.com> - 3.2.19-10
331 - Fix/hide exceptions on rpm callbacks, to make rpm happier.
332 - Resolves: rhbz#463447
333 - Resolves: rhbz#454882
334
335 * Fri Sep 19 2008 James Antill <jantill@redhat.com> - 3.2.19-9
336 - Fix typo in checkSignals, we rpm has got a signal.
337 - Resolves: rhbz#462784
338 - Resolves: rhbz#454882
339
340 * Tue Sep 16 2008 James Antill <jantill@redhat.com> - 3.2.19-8
341 - Allow yum remove to work without downloading pkgSack MD.
342 - Only install a single package from a provider.
343 - Fix total download cb to use the logger.
344 - Add incomplete transactions warning.
345 - Speed fix for large patterns (notably large package name excludes).
346 - Speed fix for includepkgs.
347 - UI tweak for loaded plugins line.
348 - Dynamic columns support and list/groupinfo-v changes to use it.
349 - Add conflicts as well as obsoletes, so you can't reinstall skip-broken.
350 - Resolves: rhbz#462086
351 - Resolves: rhbz#454882
352
353 * Fri Aug 29 2008 James Antill <jantill@redhat.com> - 3.2.19-6
354 - Fix list searches for name.arch
355 - Resolves: rhbz#454882
356
357 * Thu Aug 28 2008 James Antill <jantill@redhat.com> - 3.2.19-5
358 - Fix minor API gitch in 3.2.19
359 - Obsolete yum-skip-broken, so it auto goes away on update
360 - Resolves: rhbz#454882
361
362 * Wed Aug 27 2008 James Antill <jantill@redhat.com> - 3.2.19-4
363 - Fix minor API gitch in 3.2.19
364 - Resolves: rhbz#454882
365
366 * Tue Aug 26 2008 James Antill <jantill@redhat.com> - 3.2.19-2
367 - Import next upstream 3.2.19.
368 - What will be in Fedora 9 soon.
369 - Resolves: rhbz#454882
370
371 * Wed Aug  6 2008 James Antill <jantill@redhat.com> - 3.2.17-0_beta_18_2
372 - Import next upstream 3.2.18 beta.
373 - What will be in Fedora 9 soon.
374 - Lots of bug fixes, changes for gpgcheck/repo_gpgcheck/update-minimal/etc.
375 - Resolves: rhbz#454882
376
377 * Mon Jul 21 2008 James Antill <jantill@redhat.com> - 3.2.17-0_beta_18_1
378 - Import upstream 3.2.18 beta.
379 - What will be in Fedora 9 soon.
380 - Resolves: rhbz#454882
381
382 * Mon Mar 24 2008 James Antill <jantill@redhat.com> - 3.2.8-10
383 - Allow URLs to work as arguments to -c (config. file)
384 - Resolves: rhbz#447271
385
386 * Mon Mar 24 2008 James Antill <jantill@redhat.com> - 3.2.8-9
387 - Minor man page fix
388 - Resolves: rhbz#438168
389 - Multilib arch problem fix
390 - Resolves: rhbz#437429
391
392 * Tue Mar 11 2008 James Antill <jantill@redhat.com> - 3.2.8-8
393 - Re-add the ssl-ca-cert patch
394 - Resolves: rhbz#436804
395 - Add unused patterns argument
396 - Resolves: rhbz#319491
397
398 * Thu Feb 21 2008 James Antill <jantill@redhat.com> - 3.2.8-7
399 - Hacky workaround for python split gettext bug.
400 - Resolves: rhbz#431073
401
402 * Sun Feb  3 2008 James Antill <jantill@redhat.com> - 3.2.8-6
403 - Tweak config. file for 3.2.8
404 - Resolves: rhbz#237773
405 - Set HTTP user-agent to specify this is yum, and which verison
406 - Resolves: rhbz#319461
407 - Create logdir if it doesn't exist.
408 - Resolves: rhbz#253960
409 - Add committer/comittime
410 - Relates: rhbz#319491
411
412
413 * Tue Jan 22 2008 James Antill <jantill@redhat.com> - 3.2.8-5
414 - Import some of the returnPackages() changes, to fix len() == -1 bug with
415 - some repos. And missing import sqlutils.
416 - Resolves: rhbz#429751
417
418 * Fri Jan 18 2008 James Antill <jantill@redhat.com> - 3.2.8-4
419 - Workaround the worst behaviour of yum install kernel.
420 - Import Fedora 8 yum base.
421 - Add lots of small bug fix patches from 3.2.9
422 - Resolves: rhbz#384691
423
424 * Wed Jan 10 2007 Jeremy Katz <katzj@redhat.com> - 3.0.1-5
425 - fix for 'yum localinstall' with multiarch (#220682)
426
427 * Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-4
428 - revert to older version of rpmsack to not repeatedly open the rpmdb to 
429   avoid problems (Related: #217285, #213963)
430
431 * Tue Nov 14 2006 Peter Jones <pjones@redhat.com> - 3.0.1-3
432 - don't consider arch when getting newest packages in a list (#212626)
433
434 * Fri Nov 10 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-2
435 - yum-updatesd fixes (#213622, #212494, #212507)
436 - sslcacert option (jbowes, #210977)
437
438 * Fri Nov  3 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-1
439 - update to 3.0.1
440
441 * Fri Oct 13 2006 Paul Nasrat <pnasrat@redhat.com> - 3.0-6
442 - fix package comparison for available packages
443
444 * Thu Oct 12 2006 Jeremy Katz <katzj@redhat.com> - 3.0-5
445 - fix traceback when syslog not available (#208773)
446 - fix package comparison not properly handling different arches (#210316)
447
448 * Tue Oct 10 2006 Jeremy Katz <katzj@redhat.com> - 3.0-4
449 - fix traceback on package download error (#210135, #210181, #210115)
450
451 * Thu Oct  5 2006 Jeremy Katz <katzj@redhat.com> - 3.0-3
452 - fix traceback referencing var (#209471)
453 - add dgregor's basepath patch
454
455 * Thu Oct  5 2006 Jeremy Katz <katzj@redhat.com> - 3.0-2
456 - fix traceback in yum-updatesd
457
458 * Wed Oct  4 2006 Jeremy Katz <katzj@redhat.com> - 3.0-1
459 - 3.0 
460
461 * Fri Sep 29 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-1
462 - update to 2.9.8 with the past two fixes as well as fixes for 
463   exclude/include lines in config files
464
465 * Thu Sep 28 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-4
466 - fix trying to reget existing files (#208460)
467
468 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-3
469 - and better fix for upstream (jbowes)
470
471 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-2
472 - backout patch that breaks anaconda
473
474 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-1
475 - update to 2.9.7
476
477 * Thu Sep 21 2006 James Bowes <jbowes@redhat.com> - 2.9.6-2
478 - Remove unused imports in installonlyn
479
480 * Wed Sep  6 2006 Jeremy Katz <katzj@redhat.com> - 2.9.6-1
481 - update to 2.9.6
482
483 * Tue Sep  5 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-5
484 - update to current CVS snap (20060906) in advance of the final 2.9.6 tarball
485 - bring back the installonlyn fixes 
486
487 * Thu Aug 31 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-4
488 - revert installonlyn changes; they require changes that will only be in 2.9.6
489
490 * Wed Aug 30 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-3
491 - fix deprecation warnings in installonlyn (Jack Neely)
492
493 * Thu Aug 24 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-2
494 - add patch to fix case of an empty rpmdb (eg, at install time #204005)
495
496 * Wed Aug 23 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-1
497 - update to 2.9.5
498
499 * Fri Aug 18 2006 Chris Lumens <clumens@redhat.com> 2.9.4-4
500 - Add patch to fix pattern matching (#202974).
501
502 * Fri Aug 18 2006 Karsten Hopp <karsten@redhat.com> - 2.9.4-3
503 - revert last change
504
505 * Thu Aug 17 2006 Karsten Hopp <karsten@redhat.com> - 2.9.4-2
506 - Requires: libxml2-python for updatesd subpackage
507
508 * Wed Aug  9 2006 Jeremy Katz <katzj@redhat.com> - 2.9.4-1
509 - update to 2.9.4 (including logging fixes, gpg checking fix, 
510   and fixes for #200901, #200346, #189483)
511
512 * Mon Jul 24 2006 Florian La Roche <laroche@redhat.com> - 2.9.3-2
513 - add patch to not require /dev/log (not present in chroots) #199558
514
515 * Wed Jul 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.3-1
516 - update to 2.9.3
517 - add fix for taking the yum lock more than once and a variable typo from CVS
518
519 * Wed Jul  5 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-3
520 - few other little api fixes (#197603, #197607)
521
522 * Mon Jul  3 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-2
523 - fix tyop (#197398)
524
525 * Wed Jun 28 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-1
526 - update to 2.9.2
527
528 * Tue Jun 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.1-2
529 - move yum-updatesd into a subpackage
530 - no longer ship the yum update cronjob, yum-updatesd can do this instead
531
532 * Tue Jun 20 2006 Jeremy Katz <katzj@redhat.com> - 2.9.1-1
533 - update to 2.9.1
534
535 * Mon Jun 19 2006 Paul Nasrat <pnasrat@redhat.com> - 2.9.0-8
536 - Fix resolvedeps
537
538 * Thu Jun 15 2006 Bill Nottingham <notting@redhat.com> 2.9.0-7
539 - require pygobject2 (for yum-updatesd)
540
541 * Thu Jun 15 2006 Chris Lumens <clumens@redhat.com> 2.9.0-6
542 - Fix compareEVR traceback.
543
544 * Wed Jun 14 2006 Paul Nasrat <pnasrat@redhat.com> - 2.9.0-5
545 - Various fixups (key grab and importing, composite exception handling)
546
547 * Tue Jun 13 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-4
548 - install yum-updatesd bits
549
550 * Tue Jun 13 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-3
551 - add patch to fix filelist crash installing/querying the filesystem package
552 - add patch to fix excludes
553
554 * Mon Jun 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-2
555 - add patch for mirror errors
556
557 * Mon Jun 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-1
558 - update to 2.9.0, require C-based metadata parser to speed things up
559
560 * Mon Jun  5 2006 Jeremy Katz <katzj@redhat.com> - 2.6.1-4
561 - handle PAE kernels in installonlyn (#194064)
562
563 * Thu May 25 2006 Paul Nasrat <pnasrat@redhat.com> - 2.6.1-3
564 - Rebuild with patch
565
566 * Wed May 24 2006 Paul Nasrat <pnasrat@redhat.com> - 2.6.1-2
567 - backport mirror failure callback 
568
569 * Wed Apr 26 2006 Jeremy Katz <katzj@redhat.com> - 2.6.1-1
570 - update to 2.6.1 with fixes for #181406, #185309, #161190, #185946
571
572 * Tue Apr 18 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-3
573 - more proxy fixing for non CLI use case (#185309)
574
575 * Mon Apr 10 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-2
576 - add fix for xen0/xenU kernels in installonlyn (#187894)
577 - add fix for proxies with the mirror list (#161190)
578
579 * Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-1
580 - update to 2.6.0 final containing fix for #176257
581
582 * Fri Mar 03 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-5
583 - Add support for patterns in YumBase.install()
584
585 * Thu Mar 02 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-4
586 - Cover pkg then group selection in conditional group support (#181858)
587
588 * Thu Mar 02 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-3
589 - Conditional group support (#181858)
590
591 * Fri Feb 24 2006 Jeremy Katz <katzj@redhat.com> - 2.5.3-2
592 - fix installyonlyn bug with tokeep > 2 (#176704)
593
594 * Wed Feb 22 2006 Jeremy Katz <katzj@redhat.com> - 2.5.3-1
595 - Update to 2.5.3 with fixes for lots of stuff (and all of our patches applied)
596   (#177528, #177737, #179512, others)
597
598 * Fri Feb 10 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-5
599 - Merge patches from head for group plugin support and conditionals
600
601 * Fri Feb 03 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-4
602 - Fix group unselect traceback (cf #177737)
603
604 * Tue Jan 31 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-3
605 - Merge upstream patches (sortabletransactiondata, grouplists)
606
607 * Sun Jan 15 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-2
608 - Fix group removal traceback (#177737)
609
610 * Sun Jan  8 2006 Jeremy Katz <katzj@redhat.com> - 2.5.1-1
611 - seth loves me and made a 2.5.1 release.  so no cvs snap for you! 
612
613 * Sun Jan  8 2006 Jeremy Katz <katzj@redhat.com> - 2.5.1-0.20060108
614 - update to CVS snap
615
616 * Wed Dec 21 2005 Paul Nasrat <pnasrat@redhat.com> - 2.5.0-5
617 - Make txmbr hashable (#175975)
618
619 * Fri Dec 16 2005 Paul Nasrat <pnasrat@redhat.com> - 2.5.0-4
620 - Fix for KeyError when no location['base']
621
622 * Wed Dec 14 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-3
623 - better mirrorlist fix
624
625 * Wed Dec 14 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-2
626 - revert installyonlyn change that wasn't supposed to get committed
627 - better fix for #175647 that doesn't cause tracebacks when deps 
628   need updating too
629 - fix mirrorlist corruption (#175436)
630
631 * Tue Dec 13 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-1
632 - update to 2.5.0
633 - add patch for traceback in #175647
634
635 * Sat Dec 10 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-0.20051210
636 - update to newer CVS
637
638 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
639 - rebuilt
640
641 * Wed Dec  7 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-0.20051207
642 - update to cvs snap for new group code and lots of other stuff
643
644 * Tue Dec  6 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-3
645 - ... and actually apply the patch
646
647 * Mon Dec  5 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-2
648 - add Panu's patch for cachecookie cleaning (#174715)
649 - change default cache time to 30 minutes to match new upstream
650
651 * Wed Nov 30 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-1
652 - update to 2.4.1
653 - add PLUGINS to the docs
654 - fix another installonlyn bug (#174001)
655
656 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-14
657 - really fix kernel-smp-devel
658
659 * Fri Nov 11 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-13
660 - handle installonlypkgs in provides too to handle, eg, 
661   kernel-smp-devel (#172981)
662
663 * Thu Nov 10 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-12
664 - fix problem with custom kernel names in installonlyn (#172855)
665 - make it more obvious how to add more tokeep with installonlyn
666
667 * Wed Nov 09 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-11
668 - Expose location base from metadata
669
670 * Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-10
671 - fix problem in installonlyn that caillon hit where removing kernels 
672   would trigger instead of only happening on update/install of kernels
673 - make plugin config files noreplace
674
675 * Mon Nov  7 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-9
676 - enable plugins by default
677 - add installyonlyn plugin so that we only keep two kernels around by default
678
679 * Mon Oct 24 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-8
680 - drop macro patch
681 - more fixes for returnByName* stuff -- need to leave best arch selection
682   to the caller
683
684 * Sun Oct 23 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-7
685 - Drop anaconda flag patch
686 - Fix ppc64pseries/iseries basearch substitution
687
688 * Thu Oct 06 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-6
689 - Backport transaction constants
690 - Allow setting anaconda flag
691
692 * Tue Oct  4 2005 Jeremy Katz <katzj@redhat.com>
693 - add dirs for plugins
694
695 * Tue Sep 27 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-5
696 - add yum-cli dir (#169334)
697
698 * Wed Sep 21 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-4
699 - make returnByName* be consistent in what it returns (#168712)
700
701 * Fri Sep 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-3
702 - add two patches for anaconda that have been committed upstream
703   * allow removal of packages from transaction
704   * support search by name with sqlite
705
706 * Thu Sep 01 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-2
707 - Initial version of macro support patch
708
709 * Tue Aug 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-1
710 - update to 2.4.0
711
712 * Fri Jul  8 2005 Jeremy Katz <katzj@redhat.com> - 2.3.4-1
713 - update to 2.3.4
714 - use %%{python_sitelib} in the file list
715
716 * Wed Jun 15 2005 Jeremy Katz <katzj@redhat.com> - 2.3.3-1
717 - update to 2.3.3
718
719 * Wed May 25 2005 Paul Nasrat <pnasrat@redhat.com> - 2.3.2-7
720 - Drop erase reversal patch 
721
722 * Tue May 24 2005 Paul Nasrat <pnasrat@redhat.com> - 2.3.2-6
723 - Erase/remove reversing for yum cli (#158577)
724
725 * Tue May 24 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-5
726 - allow multiple packages _providing_ kernel-devel (or any installonlypkgs) 
727   to be installed (#155988)
728
729 * Mon May 23 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-4
730 - fix traceback on out of disk space error
731
732 * Fri May 20 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-3
733 - add fixes from Seth for the shell to run depsolve and to clean up 
734   output somewhat (#158267)
735
736 * Thu May  5 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-2
737 - handle ppc64/sparc64 "correctly"
738
739 * Mon Apr  4 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-1
740 - update to 2.3.2, now requires python-elementtree for xml parsing
741
742 * Tue Mar 15 2005 Jeremy Katz <katzj@redhat.com> - 2.3.1-3
743 - add patch from gijs for sqlite changes
744
745 * Mon Mar 14 2005 Florian La Roche <laroche@redhat.com>
746 - python-sqlite3 -> python-sqlite
747
748 * Mon Mar  7 2005 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
749 - update to 2.3.1
750 - urlgrabber is split out into its own package now
751 - require python-sqlite3
752
753 * Tue Feb 22 2005 Jeremy Katz <katzj@redhat.com> - 2.3.0-2
754 - fix the duplicate repos with the same id bug
755
756 * Mon Feb 21 2005 Jeremy Katz <katzj@redhat.com> - 2.3.0-1
757 - update to 2.3.0
758
759 * Tue Jan 25 2005 Jeremy Katz <katzj@redhat.com> - 2.1.13-1
760 - update to 2.1.13
761
762 * Sat Jan 22 2005 Jeremy Katz <katzj@redhat.com> - 2.1.12-2
763 - allow multiple kernel-devel packages to be installed
764
765 * Wed Jan 12 2005 Florian La Roche <laroche@redhat.com>
766 - add small patch to fix dep reporting
767
768 * Mon Nov 29 2004 Jeremy Katz <katzj@redhat.com> - 2.1.12-1
769 - update to 2.1.12
770 - add hack from jbj to workaround python 2.4 urllib breakage (#138535)
771
772 * Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-4
773 - rebuild for python 2.4
774
775 * Sun Oct 31 2004 Bill Nottingham <notting@redhat.com> - 2.1.11-3
776 - fix multilib update patch to allow installing noarch (#135396, continued)
777
778 * Fri Oct 29 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-2
779 - add patch to fix multilib updates on ia32e (#135396)
780
781 * Thu Oct 28 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-1
782 - update to 2.1.11
783   - fix config file error handling
784   - better handling of empty lines/comments in mirror lists
785   - improve some error messages
786
787 * Sun Oct 24 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-3.1
788 - make the cron job executable (#136764)
789
790 * Thu Oct 21 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-3
791 - actually remove the repositories
792
793 * Wed Oct 20 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-2
794 - remove repositories from being explicitly listed in yum.conf, 
795   .repo files will be included in the fedora-release package
796
797 * Tue Oct 19 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-1
798 - update to 2.1.10
799   * updated man pages
800   * make more resilient to broken groups file
801   * fix urlgrabber failure callback (#136178)
802
803 * Mon Oct 18 2004 Jeremy Katz <katzj@redhat.com> - 2.1.9-1
804 - 2.1.9 includes the path fix
805
806 * Mon Oct 18 2004 Jeremy Katz <katzj@redhat.com> - 2.1.8-2
807 - fix path in /usr/bin/yum
808 - turn on gpgchecking by default
809
810 * Mon Oct 18 2004 Bill Nottingham <notting@redhat.com> - 2.1.8-1
811 - 2.1.8, fixes #135735, #135998, #135775
812
813 * Wed Oct 13 2004 Jeremy Katz <katzj@redhat.com> - 2.1.7-2
814 - add yum-arch
815
816 * Wed Oct 13 2004 Jeremy Katz <katzj@redhat.com> - 2.1.7-1
817 - 2.1.7
818 - use mirror list by default
819
820 * Wed Oct  6 2004 Bill Nottingham <notting@redhat.com> - 2.1.6-1
821 - 2.1.6
822
823 * Mon Oct  4 2004 Jeremy Katz <katzj@redhat.com> - 2.1.5-1
824 - 2.1.5
825 - turn on obsoletes=1 by default in yum.conf
826
827 * Wed Sep 29 2004 Bill Nottingham <notting@redhat.com> - 2.1.4-1
828 - 2.1.4
829
830 * Fri Sep  3 2004 Bill Nottingham <notting@redhat.com> - 2.1.3-1
831 - 2.1.3
832
833 * Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.1.2-1
834 - 2.1.2
835
836 * Wed Sep  1 2004 Jeremy Katz <katzj@redhat.com> - 2.1.1-1
837 - 2.1.1
838
839 * Tue Aug 31 2004 Jeremy Katz <katzj@redhat.com> - 2.1.0-1
840 - update to 2.1.0
841
842 * Wed Jul 7 2004  Elliot Lee <sopwith@redhat.com> 2.0.7-3
843 - Back to rawhide
844
845 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
846 - rebuilt
847
848 * Tue May 11 2004 Elliot Lee <sopwith@redhat.com> 2.0.7-1.1
849 - Update config again
850
851 * Fri May  7 2004 Jeremy Katz <katzj@redhat.com> 2.0.7-1
852 - update to 2.0.7
853 - change config to point to final FC2 locations
854
855 * Fri Apr 16 2004 Jeremy Katz <katzj@redhat.com> - 2.0.7-0.20040416
856 - new snap 
857
858 * Sat Apr  3 2004 Jeremy Katz <katzj@redhat.com> 2.0.7-0.20040403
859 - new snap, should fix yum -e name.arch
860
861 * Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.0.6-1
862 - update to 2.0.6
863
864 * Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> 2.0.5.20040310-1
865 - update to today's snap
866
867 * Wed Mar  3 2004 Jeremy Katz <katzj@redhat.com> 2.0.5.20040303-1
868 - today's snap
869
870 * Tue Mar  2 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040229-1
871 - update again per seth's request
872
873 * Thu Feb 26 2004 Florian La Roche <Florian.LaRoche@redhat.de>
874 - mv /etc/init.d -> /etc/rc.d/init.d
875
876 * Tue Feb 24 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040224-1
877 - newer
878
879 * Mon Feb 23 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040223-1
880 - update to current snapshot per skvidal's request
881 - add retries=20 to yum.conf
882
883 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
884 - rebuilt
885
886 * Fri Jan 23 2004 Bill Nottingham <notting@redhat.com> 2.0.4.20040103-1
887 - update to current snapshot
888 - fix config for FC2 test 1
889
890 * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 2.0.4-5
891 - build yum daily snapshot for amd64 fix.
892
893 * Wed Nov 12 2003 Bill Nottingham <notting@redhat.com> 2.0.4-4
894 - patch for excluding dirs in yum-arch from CVS
895
896 * Thu Nov  6 2003 Jeremy Katz <katzj@redhat.com> 2.0.4-3
897 - patch to work with python 2.3 from Seth
898
899 * Wed Oct 29 2003 Elliot Lee <sopwith@redhat.com> 2.0.4-2
900 - Stick in a new yum.conf for FC1.
901
902 * Mon Oct 20 2003 Florian La Roche <Florian.LaRoche@redhat.de>
903 - new upstream release 2.0.4
904
905 * Tue Sep 16 2003 Jeff Johnson <jbj@redhat.com> 2.0.3-1
906 - update to 2.0.3
907 - drop yum-init patch, merged into 2.0.3.
908 - change rpm version requirement to 4.1.1.
909
910 * Thu Jul 24 2003 Florian La Roche <Florian.LaRoche@redhat.de>
911 - change init script to more current RHL style
912
913 * Wed Jul 23 2003 Nalin Dahyabhai <nalin@redhat.com>
914 - require libxml2-python, because yum does
915
916 * Thu Jul 17 2003 Jeff Johnson <jbj@redhat.com> 2.0-1
917 - update to 2.0.
918
919 * Thu May 22 2003 Jeff Johnson <jbj@redhat.com> 1.98-0.20030522
920 - update to snapshot.
921
922 * Mon May 12 2003 Jeff Johnson <jbj@redhat.com> 1.98-0.20030512
923 - create.