add latest centos5 yum (corresponds to the centos 5.6)
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 Summary: RPM installer/updater
4 Name: yum
5 Version: 3.2.22
6 Release: 26%{?dist}.chroot1
7 License: GPLv2+
8 Group: System Environment/Base
9 Source0: http://linux.duke.edu/projects/yum/download/3.2/%{name}-%{version}.tar.gz
10 Source1: yum.conf.fedora
11 Source2: yum-updatesd.conf.fedora
12
13 #  See: http://people.redhat.com/jantill/gits/yum branch el-5.3-master
14 # and the el5.3* branches for the individual patches.
15
16 # Fedora patches we might as well carry
17 Patch0: installonlyn-enable.patch
18 Patch1: yum-mirror-priority.patch
19 Patch2: yum-manpage-files.patch
20 Patch3: yum-ia64-multilib.patch
21 # NOTE: We don't carry this as it'd change the policy mid cycle
22 # Patch3: yum-multilib-policy-best.patch
23
24 # Work around python-2.4.z's gettext ... maybe not needed post 5.3
25 Patch102: yum-hack-python-gettext-workaround.patch
26 # SSL, although it's still done in RHN-plugin
27 # Also fixes 462915: client and server x509 support for Yum
28 Patch103: yum-3.2.22-client+server-x509.patch
29
30 # Python-2.* is just too sucky to enable this
31 Patch104: yum-3.2.22-i18n-off.patch
32
33 # Post 3.2.22 release upstream changes
34 Patch110: yum-3.2.22-post-BIG.patch
35 Patch111: yum-3.2.22-txmbr-sort.patch
36 Patch112: yum-3.2.22-kernel-updates-minimize.patch
37 Patch113: yum-3.2.22-pylin-indent-fix.patch
38 Patch114: yum-3.2.22-i18n-gettext-typo-fix.patch
39 Patch115: yum-3.2.22-sort-providers.patch
40 Patch116: yum-3.2.22-local-pkgs.patch
41 Patch117: yum-3.2.22-rawhide-fixes.patch
42 Patch118: yum-3.2.22-regression.patch
43 Patch119: yum-3.2.22-reinstall-local.patch
44 Patch120: yum-3.2.23-rawhide-fixes.patch
45
46 # 5.5 patches...
47 Patch201: BZ-517286-instant-downloads.patch
48 Patch202: BZ-521008-regression-update-not-exist.patch
49 Patch203: BZ-526064-check-update-obs.patch
50 Patch204: BZ-528738-bugtracker.patch
51 Patch205: BZ-528746-reinstall-compat-rpm.patch
52 Patch206: BZ-529233-faster-compare_providers.patch
53 Patch207: BZ-529719-base_package_name-compare_providers.patch
54 Patch208: BZ-548582-excludes-source-repos-crash.patch
55 Patch209: BZ-523135-newest-obs-only.patch
56
57 Patch1000: yum-3.2.22-chroot.patch
58
59 URL: http://linux.duke.edu/yum/
60 BuildArchitectures: noarch
61 BuildRequires: python
62 BuildRequires: gettext
63 BuildRequires: intltool
64 Conflicts: pirut < 1.1.4
65 Conflicts: yum-versionlock < 1.1.16-13.el5
66 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
67 Requires: python-iniparse
68 Requires: python-sqlite
69 Requires: urlgrabber >= 3.1.0
70 Requires: python-elementtree
71 # Make sure metadata code is updated too
72 Requires: yum-metadata-parser >= 1.1.0
73 Requires: yum-fastestmirror
74 Conflicts: yum-rhn-plugin < 0.5.3-30.el5
75 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
76 Obsoletes: yum-skip-broken
77 Conflicts: yum-skip-broken
78 Obsoletes: yum-basearchonly
79 Conflicts: yum-basearchonly
80 # yum-complete-transaction from 1.1.10-9.el5 has problems:
81 Conflicts: yum-utils < 1.1.16-11
82 # We don't require this in RHEL, although it'll use it if you have it
83 # suggests would be ok, if it worked and if pygpgme wasn't in EPEL :).
84 # Requires: pygpgme
85 Obsoletes: yum-allow-downgrade < 1.1.20-0
86 Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
87 Obsoletes: yum-repolist
88
89 %description
90 Yum is a utility that can check for and automatically download and
91 install updated RPM packages. Dependencies are obtained and downloaded 
92 automatically prompting the user as necessary.
93
94 %package updatesd
95 Summary: Update notification daemon
96 Group: Applications/System
97 Requires: yum = %{version}-%{release}
98 Requires: dbus-python
99 Requires: pygobject2
100 Requires(preun): /sbin/chkconfig
101 Requires(post): /sbin/chkconfig
102 Requires(preun): /sbin/service
103 Requires(post): /sbin/service
104
105 %description updatesd
106 yum-updatesd provides a daemon which checks for available updates and 
107 can notify you when they are available via email, syslog or dbus. 
108
109 %prep
110 %setup -q
111
112 %define _default_patch_fuzz 2
113
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p1
117 %patch3 -p1
118
119 %patch102 -p1
120 %patch103 -p1
121
122 %patch104 -p1
123
124 %patch110 -p1
125 %patch111 -p1
126 %patch112 -p1
127 %patch113 -p1
128 %patch114 -p1
129 %patch115 -p1
130 %patch116 -p1
131 %patch117 -p1
132 %patch118 -p1
133 %patch119 -p1
134 %patch120 -p1
135
136 %patch201 -p1
137 %patch202 -p1
138 %patch203 -p1
139 %patch204 -p1
140 %patch205 -p1
141 %patch206 -p1
142 %patch207 -p1
143 %patch208 -p1
144 %patch209 -p1
145
146 %patch1000 -p1
147
148 %build
149 make
150
151 %install
152 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
153 make DESTDIR=$RPM_BUILD_ROOT install
154 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/yum.conf
155
156 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
157
158 # for now, move repodir/yum.conf back
159 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
160 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
161
162 # yum-updatesd has moved to the separate source version
163 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
164 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
165 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
166 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
167 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
168
169 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
170
171 %find_lang %name
172
173 %clean
174 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
175
176 %files -f %{name}.lang
177 %defattr(-, root, root, -)
178 %doc README AUTHORS COPYING TODO INSTALL ChangeLog PLUGINS
179 %config(noreplace) %{_sysconfdir}/yum.conf
180 %dir %{_sysconfdir}/yum
181 %dir %{_sysconfdir}/yum.repos.d
182 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
183 %dir %{_datadir}/yum-cli
184 %{_datadir}/yum-cli/*
185 %{_bindir}/yum
186 %{python_sitelib}/yum
187 %{python_sitelib}/rpmUtils
188 %dir /var/cache/yum
189 %dir /var/lib/yum
190 %{_mandir}/man*/yum.*
191 %{_mandir}/man*/yum-shell*
192 # plugin stuff
193 %dir %{_sysconfdir}/yum/pluginconf.d 
194 %dir /usr/lib/yum-plugins
195
196 %changelog
197 * Sun Apr 04 2010 Karanbir Singh <kbsingh@centos.org> - 3.2.22-26.el5.centos
198 - Make installonly be 5
199 - Require fastest mirror plugin
200 - Obsolete yum-repolist
201
202 * Tue Feb 23 2010 James Antill <jantill@redhat.com> - 3.2.22-26
203 - Only look at the newest packages for obsoletes, again.
204 - Resolves: rhbz#523135
205
206 * Tue Feb 16 2010 James Antill <jantill@redhat.com> - 3.2.22-25
207 - Fix weird excludes bug for source repos.
208 - Resolves: rhbz#548582
209
210 * Wed Jan 27 2010 James Antill <jantill@redhat.com> - 3.2.22-24
211 - Fix reinstall error handling, due to yumdb usage, bad backport of
212 - patch for 528746.
213 - Resolves: rhbz#559164
214
215 * Thu Dec 17 2009 James Antill <jantill@redhat.com> - 3.2.22-23
216 - Fix bugtracker URL
217 - Resolves: rhbz#528738
218 - Fix reinstall for rpm and general output fixup.
219 - Resolves: rhbz#528746
220 - Remove slow edge case from compare_providers
221 - Resolves: rhbz#529233
222 - Add base package name check to compare_providers()
223 - Resolves: rhbz#529719
224
225 * Wed Oct  7 2009 James Antill <jantill@redhat.com> - 3.2.22-21
226 - Fix instant downloads crash.
227 - Resolves: rhbz#517286
228 - Fix exit regression when updating packages which don't exist.
229 - Resolves: rhbz#521008
230 - Show obsoletes in check-update, if obsoletes flag is on.
231 - Resolves: rhbz#526064
232
233 * Tue Jul  7 2009 James Antill <jantill@redhat.com> - 3.2.22-20
234 - Resolve weird python unicode() vs. str() perf. problem
235 - Resolves: rhbz#509932
236 - Fixup documentation spelling errors.
237 - Resolves: 510012
238
239 * Fri Jun 26 2009 James Antill <jantill@redhat.com> - 3.2.22-18
240 - Allow API users to set repo directory attributes again.
241 - Resolves: rhbz#508055
242 - Re-Fix pkgSack init loop on empty pkgSacks to make anaconda happy.
243 - Resolves: rhbz#507885
244 - Resolves: rhbz#489256
245
246 * Wed Jun 24 2009 James Antill <jantill@redhat.com> - 3.2.22-16
247 - Fix pkgSack init loop on empty pkgSacks.
248 - Resolves: rhbz#507885
249 - Fix turning off color.
250 - Resolves: rhbz#507883
251 - Fix language testing to use LC_MESSAGES instead of LC_CTYPE.
252 - Resolves: rhbz#507357
253 - Fix to_str not being in misc
254 - Resolves: rhbz#508051
255 - Resolves: rhbz#489256
256
257 * Fri Jun 19 2009 James Antill <jantill@redhat.com> - 3.2.22-15
258 - Fix reinstall with local files.
259 - Resolves: rhbz#489256
260 - Resolves: rhbz#462915
261
262 * Thu May 14 2009 James Antill <jantill@redhat.com> - 3.2.22-14
263 - Fix a couple of regressions.
264 - Conflict with older rhn-plugin
265 - Resolves: rhbz#489256
266 - Resolves: rhbz#462915
267 - Resolves: 500697
268
269 * Tue Apr 28 2009 James Antill <jantill@redhat.com> - 3.2.22-10
270 - Rebase for lots of bug fixes, and some features/speedups.
271 - Resolves: rhbz#489256
272 - Resolves: rhbz#462915
273 - Only look at new obsoletes
274
275 * Tue Nov 25 2008 James Antill <jantill@redhat.com> - 3.2.19-18
276 - Fix utf8 in redhat-logos license
277 - Resolves: rhbz#472375
278
279 * Mon Nov 10 2008 James Antill <jantill@redhat.com> - 3.2.19-16
280 - Fix ia64 multilib for RHEL-5
281 - Resolves: rhbz#469271
282
283 * Tue Oct 28 2008 James Antill <jantill@redhat.com> - 3.2.19-14
284 - Fix yum shell when doing remove commands first.
285 - Resolves: rhbz#468754
286
287 * Thu Oct 23 2008 James Antill <jantill@redhat.com> - 3.2.19-13
288 - Add the timestamp_check option, so we can have repoids to random stuff
289 - Resolves: rhbz#466176
290 - Fix yum shell man page for repo command.
291 - Resolves: rhbz#467415
292 - Resolves: rhbz#454882
293
294 * Thu Oct 16 2008 James Antill <jantill@redhat.com> - 3.2.19-11
295 - Don't show rpm progress when in super quiet mode
296 - Resolves: rhbz#466911
297 - Resolves: rhbz#454882
298
299 * Mon Sep 29 2008 James Antill <jantill@redhat.com> - 3.2.19-10
300 - Fix/hide exceptions on rpm callbacks, to make rpm happier.
301 - Resolves: rhbz#463447
302 - Resolves: rhbz#454882
303
304 * Fri Sep 19 2008 James Antill <jantill@redhat.com> - 3.2.19-9
305 - Fix typo in checkSignals, we rpm has got a signal.
306 - Resolves: rhbz#462784
307 - Resolves: rhbz#454882
308
309 * Tue Sep 16 2008 James Antill <jantill@redhat.com> - 3.2.19-8
310 - Allow yum remove to work without downloading pkgSack MD.
311 - Only install a single package from a provider.
312 - Fix total download cb to use the logger.
313 - Add incomplete transactions warning.
314 - Speed fix for large patterns (notably large package name excludes).
315 - Speed fix for includepkgs.
316 - UI tweak for loaded plugins line.
317 - Dynamic columns support and list/groupinfo-v changes to use it.
318 - Add conflicts as well as obsoletes, so you can't reinstall skip-broken.
319 - Resolves: rhbz#462086
320 - Resolves: rhbz#454882
321
322 * Fri Aug 29 2008 James Antill <jantill@redhat.com> - 3.2.19-6
323 - Fix list searches for name.arch
324 - Resolves: rhbz#454882
325
326 * Thu Aug 28 2008 James Antill <jantill@redhat.com> - 3.2.19-5
327 - Fix minor API gitch in 3.2.19
328 - Obsolete yum-skip-broken, so it auto goes away on update
329 - Resolves: rhbz#454882
330
331 * Wed Aug 27 2008 James Antill <jantill@redhat.com> - 3.2.19-4
332 - Fix minor API gitch in 3.2.19
333 - Resolves: rhbz#454882
334
335 * Tue Aug 26 2008 James Antill <jantill@redhat.com> - 3.2.19-2
336 - Import next upstream 3.2.19.
337 - What will be in Fedora 9 soon.
338 - Resolves: rhbz#454882
339
340 * Wed Aug  6 2008 James Antill <jantill@redhat.com> - 3.2.17-0_beta_18_2
341 - Import next upstream 3.2.18 beta.
342 - What will be in Fedora 9 soon.
343 - Lots of bug fixes, changes for gpgcheck/repo_gpgcheck/update-minimal/etc.
344 - Resolves: rhbz#454882
345
346 * Mon Jul 21 2008 James Antill <jantill@redhat.com> - 3.2.17-0_beta_18_1
347 - Import upstream 3.2.18 beta.
348 - What will be in Fedora 9 soon.
349 - Resolves: rhbz#454882
350
351 * Mon Mar 24 2008 James Antill <jantill@redhat.com> - 3.2.8-10
352 - Allow URLs to work as arguments to -c (config. file)
353 - Resolves: rhbz#447271
354
355 * Mon Mar 24 2008 James Antill <jantill@redhat.com> - 3.2.8-9
356 - Minor man page fix
357 - Resolves: rhbz#438168
358 - Multilib arch problem fix
359 - Resolves: rhbz#437429
360
361 * Tue Mar 11 2008 James Antill <jantill@redhat.com> - 3.2.8-8
362 - Re-add the ssl-ca-cert patch
363 - Resolves: rhbz#436804
364 - Add unused patterns argument
365 - Resolves: rhbz#319491
366
367 * Thu Feb 21 2008 James Antill <jantill@redhat.com> - 3.2.8-7
368 - Hacky workaround for python split gettext bug.
369 - Resolves: rhbz#431073
370
371 * Sun Feb  3 2008 James Antill <jantill@redhat.com> - 3.2.8-6
372 - Tweak config. file for 3.2.8
373 - Resolves: rhbz#237773
374 - Set HTTP user-agent to specify this is yum, and which verison
375 - Resolves: rhbz#319461
376 - Create logdir if it doesn't exist.
377 - Resolves: rhbz#253960
378 - Add committer/comittime
379 - Relates: rhbz#319491
380
381
382 * Tue Jan 22 2008 James Antill <jantill@redhat.com> - 3.2.8-5
383 - Import some of the returnPackages() changes, to fix len() == -1 bug with
384 - some repos. And missing import sqlutils.
385 - Resolves: rhbz#429751
386
387 * Fri Jan 18 2008 James Antill <jantill@redhat.com> - 3.2.8-4
388 - Workaround the worst behaviour of yum install kernel.
389 - Import Fedora 8 yum base.
390 - Add lots of small bug fix patches from 3.2.9
391 - Resolves: rhbz#384691
392
393 * Wed Jan 10 2007 Jeremy Katz <katzj@redhat.com> - 3.0.1-5
394 - fix for 'yum localinstall' with multiarch (#220682)
395
396 * Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-4
397 - revert to older version of rpmsack to not repeatedly open the rpmdb to 
398   avoid problems (Related: #217285, #213963)
399
400 * Tue Nov 14 2006 Peter Jones <pjones@redhat.com> - 3.0.1-3
401 - don't consider arch when getting newest packages in a list (#212626)
402
403 * Fri Nov 10 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-2
404 - yum-updatesd fixes (#213622, #212494, #212507)
405 - sslcacert option (jbowes, #210977)
406
407 * Fri Nov  3 2006 Jeremy Katz <katzj@redhat.com> - 3.0.1-1
408 - update to 3.0.1
409
410 * Fri Oct 13 2006 Paul Nasrat <pnasrat@redhat.com> - 3.0-6
411 - fix package comparison for available packages
412
413 * Thu Oct 12 2006 Jeremy Katz <katzj@redhat.com> - 3.0-5
414 - fix traceback when syslog not available (#208773)
415 - fix package comparison not properly handling different arches (#210316)
416
417 * Tue Oct 10 2006 Jeremy Katz <katzj@redhat.com> - 3.0-4
418 - fix traceback on package download error (#210135, #210181, #210115)
419
420 * Thu Oct  5 2006 Jeremy Katz <katzj@redhat.com> - 3.0-3
421 - fix traceback referencing var (#209471)
422 - add dgregor's basepath patch
423
424 * Thu Oct  5 2006 Jeremy Katz <katzj@redhat.com> - 3.0-2
425 - fix traceback in yum-updatesd
426
427 * Wed Oct  4 2006 Jeremy Katz <katzj@redhat.com> - 3.0-1
428 - 3.0 
429
430 * Fri Sep 29 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-1
431 - update to 2.9.8 with the past two fixes as well as fixes for 
432   exclude/include lines in config files
433
434 * Thu Sep 28 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-4
435 - fix trying to reget existing files (#208460)
436
437 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-3
438 - and better fix for upstream (jbowes)
439
440 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-2
441 - backout patch that breaks anaconda
442
443 * Wed Sep 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.7-1
444 - update to 2.9.7
445
446 * Thu Sep 21 2006 James Bowes <jbowes@redhat.com> - 2.9.6-2
447 - Remove unused imports in installonlyn
448
449 * Wed Sep  6 2006 Jeremy Katz <katzj@redhat.com> - 2.9.6-1
450 - update to 2.9.6
451
452 * Tue Sep  5 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-5
453 - update to current CVS snap (20060906) in advance of the final 2.9.6 tarball
454 - bring back the installonlyn fixes 
455
456 * Thu Aug 31 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-4
457 - revert installonlyn changes; they require changes that will only be in 2.9.6
458
459 * Wed Aug 30 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-3
460 - fix deprecation warnings in installonlyn (Jack Neely)
461
462 * Thu Aug 24 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-2
463 - add patch to fix case of an empty rpmdb (eg, at install time #204005)
464
465 * Wed Aug 23 2006 Jeremy Katz <katzj@redhat.com> - 2.9.5-1
466 - update to 2.9.5
467
468 * Fri Aug 18 2006 Chris Lumens <clumens@redhat.com> 2.9.4-4
469 - Add patch to fix pattern matching (#202974).
470
471 * Fri Aug 18 2006 Karsten Hopp <karsten@redhat.com> - 2.9.4-3
472 - revert last change
473
474 * Thu Aug 17 2006 Karsten Hopp <karsten@redhat.com> - 2.9.4-2
475 - Requires: libxml2-python for updatesd subpackage
476
477 * Wed Aug  9 2006 Jeremy Katz <katzj@redhat.com> - 2.9.4-1
478 - update to 2.9.4 (including logging fixes, gpg checking fix, 
479   and fixes for #200901, #200346, #189483)
480
481 * Mon Jul 24 2006 Florian La Roche <laroche@redhat.com> - 2.9.3-2
482 - add patch to not require /dev/log (not present in chroots) #199558
483
484 * Wed Jul 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.3-1
485 - update to 2.9.3
486 - add fix for taking the yum lock more than once and a variable typo from CVS
487
488 * Wed Jul  5 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-3
489 - few other little api fixes (#197603, #197607)
490
491 * Mon Jul  3 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-2
492 - fix tyop (#197398)
493
494 * Wed Jun 28 2006 Jeremy Katz <katzj@redhat.com> - 2.9.2-1
495 - update to 2.9.2
496
497 * Tue Jun 27 2006 Jeremy Katz <katzj@redhat.com> - 2.9.1-2
498 - move yum-updatesd into a subpackage
499 - no longer ship the yum update cronjob, yum-updatesd can do this instead
500
501 * Tue Jun 20 2006 Jeremy Katz <katzj@redhat.com> - 2.9.1-1
502 - update to 2.9.1
503
504 * Mon Jun 19 2006 Paul Nasrat <pnasrat@redhat.com> - 2.9.0-8
505 - Fix resolvedeps
506
507 * Thu Jun 15 2006 Bill Nottingham <notting@redhat.com> 2.9.0-7
508 - require pygobject2 (for yum-updatesd)
509
510 * Thu Jun 15 2006 Chris Lumens <clumens@redhat.com> 2.9.0-6
511 - Fix compareEVR traceback.
512
513 * Wed Jun 14 2006 Paul Nasrat <pnasrat@redhat.com> - 2.9.0-5
514 - Various fixups (key grab and importing, composite exception handling)
515
516 * Tue Jun 13 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-4
517 - install yum-updatesd bits
518
519 * Tue Jun 13 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-3
520 - add patch to fix filelist crash installing/querying the filesystem package
521 - add patch to fix excludes
522
523 * Mon Jun 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-2
524 - add patch for mirror errors
525
526 * Mon Jun 12 2006 Jeremy Katz <katzj@redhat.com> - 2.9.0-1
527 - update to 2.9.0, require C-based metadata parser to speed things up
528
529 * Mon Jun  5 2006 Jeremy Katz <katzj@redhat.com> - 2.6.1-4
530 - handle PAE kernels in installonlyn (#194064)
531
532 * Thu May 25 2006 Paul Nasrat <pnasrat@redhat.com> - 2.6.1-3
533 - Rebuild with patch
534
535 * Wed May 24 2006 Paul Nasrat <pnasrat@redhat.com> - 2.6.1-2
536 - backport mirror failure callback 
537
538 * Wed Apr 26 2006 Jeremy Katz <katzj@redhat.com> - 2.6.1-1
539 - update to 2.6.1 with fixes for #181406, #185309, #161190, #185946
540
541 * Tue Apr 18 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-3
542 - more proxy fixing for non CLI use case (#185309)
543
544 * Mon Apr 10 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-2
545 - add fix for xen0/xenU kernels in installonlyn (#187894)
546 - add fix for proxies with the mirror list (#161190)
547
548 * Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 2.6.0-1
549 - update to 2.6.0 final containing fix for #176257
550
551 * Fri Mar 03 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-5
552 - Add support for patterns in YumBase.install()
553
554 * Thu Mar 02 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-4
555 - Cover pkg then group selection in conditional group support (#181858)
556
557 * Thu Mar 02 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.3-3
558 - Conditional group support (#181858)
559
560 * Fri Feb 24 2006 Jeremy Katz <katzj@redhat.com> - 2.5.3-2
561 - fix installyonlyn bug with tokeep > 2 (#176704)
562
563 * Wed Feb 22 2006 Jeremy Katz <katzj@redhat.com> - 2.5.3-1
564 - Update to 2.5.3 with fixes for lots of stuff (and all of our patches applied)
565   (#177528, #177737, #179512, others)
566
567 * Fri Feb 10 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-5
568 - Merge patches from head for group plugin support and conditionals
569
570 * Fri Feb 03 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-4
571 - Fix group unselect traceback (cf #177737)
572
573 * Tue Jan 31 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-3
574 - Merge upstream patches (sortabletransactiondata, grouplists)
575
576 * Sun Jan 15 2006 Paul Nasrat <pnasrat@redhat.com> - 2.5.1-2
577 - Fix group removal traceback (#177737)
578
579 * Sun Jan  8 2006 Jeremy Katz <katzj@redhat.com> - 2.5.1-1
580 - seth loves me and made a 2.5.1 release.  so no cvs snap for you! 
581
582 * Sun Jan  8 2006 Jeremy Katz <katzj@redhat.com> - 2.5.1-0.20060108
583 - update to CVS snap
584
585 * Wed Dec 21 2005 Paul Nasrat <pnasrat@redhat.com> - 2.5.0-5
586 - Make txmbr hashable (#175975)
587
588 * Fri Dec 16 2005 Paul Nasrat <pnasrat@redhat.com> - 2.5.0-4
589 - Fix for KeyError when no location['base']
590
591 * Wed Dec 14 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-3
592 - better mirrorlist fix
593
594 * Wed Dec 14 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-2
595 - revert installyonlyn change that wasn't supposed to get committed
596 - better fix for #175647 that doesn't cause tracebacks when deps 
597   need updating too
598 - fix mirrorlist corruption (#175436)
599
600 * Tue Dec 13 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-1
601 - update to 2.5.0
602 - add patch for traceback in #175647
603
604 * Sat Dec 10 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-0.20051210
605 - update to newer CVS
606
607 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
608 - rebuilt
609
610 * Wed Dec  7 2005 Jeremy Katz <katzj@redhat.com> - 2.5.0-0.20051207
611 - update to cvs snap for new group code and lots of other stuff
612
613 * Tue Dec  6 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-3
614 - ... and actually apply the patch
615
616 * Mon Dec  5 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-2
617 - add Panu's patch for cachecookie cleaning (#174715)
618 - change default cache time to 30 minutes to match new upstream
619
620 * Wed Nov 30 2005 Jeremy Katz <katzj@redhat.com> - 2.4.1-1
621 - update to 2.4.1
622 - add PLUGINS to the docs
623 - fix another installonlyn bug (#174001)
624
625 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-14
626 - really fix kernel-smp-devel
627
628 * Fri Nov 11 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-13
629 - handle installonlypkgs in provides too to handle, eg, 
630   kernel-smp-devel (#172981)
631
632 * Thu Nov 10 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-12
633 - fix problem with custom kernel names in installonlyn (#172855)
634 - make it more obvious how to add more tokeep with installonlyn
635
636 * Wed Nov 09 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-11
637 - Expose location base from metadata
638
639 * Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-10
640 - fix problem in installonlyn that caillon hit where removing kernels 
641   would trigger instead of only happening on update/install of kernels
642 - make plugin config files noreplace
643
644 * Mon Nov  7 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-9
645 - enable plugins by default
646 - add installyonlyn plugin so that we only keep two kernels around by default
647
648 * Mon Oct 24 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-8
649 - drop macro patch
650 - more fixes for returnByName* stuff -- need to leave best arch selection
651   to the caller
652
653 * Sun Oct 23 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-7
654 - Drop anaconda flag patch
655 - Fix ppc64pseries/iseries basearch substitution
656
657 * Thu Oct 06 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-6
658 - Backport transaction constants
659 - Allow setting anaconda flag
660
661 * Tue Oct  4 2005 Jeremy Katz <katzj@redhat.com>
662 - add dirs for plugins
663
664 * Tue Sep 27 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-5
665 - add yum-cli dir (#169334)
666
667 * Wed Sep 21 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-4
668 - make returnByName* be consistent in what it returns (#168712)
669
670 * Fri Sep 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-3
671 - add two patches for anaconda that have been committed upstream
672   * allow removal of packages from transaction
673   * support search by name with sqlite
674
675 * Thu Sep 01 2005 Paul Nasrat <pnasrat@redhat.com> - 2.4.0-2
676 - Initial version of macro support patch
677
678 * Tue Aug 16 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0-1
679 - update to 2.4.0
680
681 * Fri Jul  8 2005 Jeremy Katz <katzj@redhat.com> - 2.3.4-1
682 - update to 2.3.4
683 - use %%{python_sitelib} in the file list
684
685 * Wed Jun 15 2005 Jeremy Katz <katzj@redhat.com> - 2.3.3-1
686 - update to 2.3.3
687
688 * Wed May 25 2005 Paul Nasrat <pnasrat@redhat.com> - 2.3.2-7
689 - Drop erase reversal patch 
690
691 * Tue May 24 2005 Paul Nasrat <pnasrat@redhat.com> - 2.3.2-6
692 - Erase/remove reversing for yum cli (#158577)
693
694 * Tue May 24 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-5
695 - allow multiple packages _providing_ kernel-devel (or any installonlypkgs) 
696   to be installed (#155988)
697
698 * Mon May 23 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-4
699 - fix traceback on out of disk space error
700
701 * Fri May 20 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-3
702 - add fixes from Seth for the shell to run depsolve and to clean up 
703   output somewhat (#158267)
704
705 * Thu May  5 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-2
706 - handle ppc64/sparc64 "correctly"
707
708 * Mon Apr  4 2005 Jeremy Katz <katzj@redhat.com> - 2.3.2-1
709 - update to 2.3.2, now requires python-elementtree for xml parsing
710
711 * Tue Mar 15 2005 Jeremy Katz <katzj@redhat.com> - 2.3.1-3
712 - add patch from gijs for sqlite changes
713
714 * Mon Mar 14 2005 Florian La Roche <laroche@redhat.com>
715 - python-sqlite3 -> python-sqlite
716
717 * Mon Mar  7 2005 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
718 - update to 2.3.1
719 - urlgrabber is split out into its own package now
720 - require python-sqlite3
721
722 * Tue Feb 22 2005 Jeremy Katz <katzj@redhat.com> - 2.3.0-2
723 - fix the duplicate repos with the same id bug
724
725 * Mon Feb 21 2005 Jeremy Katz <katzj@redhat.com> - 2.3.0-1
726 - update to 2.3.0
727
728 * Tue Jan 25 2005 Jeremy Katz <katzj@redhat.com> - 2.1.13-1
729 - update to 2.1.13
730
731 * Sat Jan 22 2005 Jeremy Katz <katzj@redhat.com> - 2.1.12-2
732 - allow multiple kernel-devel packages to be installed
733
734 * Wed Jan 12 2005 Florian La Roche <laroche@redhat.com>
735 - add small patch to fix dep reporting
736
737 * Mon Nov 29 2004 Jeremy Katz <katzj@redhat.com> - 2.1.12-1
738 - update to 2.1.12
739 - add hack from jbj to workaround python 2.4 urllib breakage (#138535)
740
741 * Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-4
742 - rebuild for python 2.4
743
744 * Sun Oct 31 2004 Bill Nottingham <notting@redhat.com> - 2.1.11-3
745 - fix multilib update patch to allow installing noarch (#135396, continued)
746
747 * Fri Oct 29 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-2
748 - add patch to fix multilib updates on ia32e (#135396)
749
750 * Thu Oct 28 2004 Jeremy Katz <katzj@redhat.com> - 2.1.11-1
751 - update to 2.1.11
752   - fix config file error handling
753   - better handling of empty lines/comments in mirror lists
754   - improve some error messages
755
756 * Sun Oct 24 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-3.1
757 - make the cron job executable (#136764)
758
759 * Thu Oct 21 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-3
760 - actually remove the repositories
761
762 * Wed Oct 20 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-2
763 - remove repositories from being explicitly listed in yum.conf, 
764   .repo files will be included in the fedora-release package
765
766 * Tue Oct 19 2004 Jeremy Katz <katzj@redhat.com> - 2.1.10-1
767 - update to 2.1.10
768   * updated man pages
769   * make more resilient to broken groups file
770   * fix urlgrabber failure callback (#136178)
771
772 * Mon Oct 18 2004 Jeremy Katz <katzj@redhat.com> - 2.1.9-1
773 - 2.1.9 includes the path fix
774
775 * Mon Oct 18 2004 Jeremy Katz <katzj@redhat.com> - 2.1.8-2
776 - fix path in /usr/bin/yum
777 - turn on gpgchecking by default
778
779 * Mon Oct 18 2004 Bill Nottingham <notting@redhat.com> - 2.1.8-1
780 - 2.1.8, fixes #135735, #135998, #135775
781
782 * Wed Oct 13 2004 Jeremy Katz <katzj@redhat.com> - 2.1.7-2
783 - add yum-arch
784
785 * Wed Oct 13 2004 Jeremy Katz <katzj@redhat.com> - 2.1.7-1
786 - 2.1.7
787 - use mirror list by default
788
789 * Wed Oct  6 2004 Bill Nottingham <notting@redhat.com> - 2.1.6-1
790 - 2.1.6
791
792 * Mon Oct  4 2004 Jeremy Katz <katzj@redhat.com> - 2.1.5-1
793 - 2.1.5
794 - turn on obsoletes=1 by default in yum.conf
795
796 * Wed Sep 29 2004 Bill Nottingham <notting@redhat.com> - 2.1.4-1
797 - 2.1.4
798
799 * Fri Sep  3 2004 Bill Nottingham <notting@redhat.com> - 2.1.3-1
800 - 2.1.3
801
802 * Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.1.2-1
803 - 2.1.2
804
805 * Wed Sep  1 2004 Jeremy Katz <katzj@redhat.com> - 2.1.1-1
806 - 2.1.1
807
808 * Tue Aug 31 2004 Jeremy Katz <katzj@redhat.com> - 2.1.0-1
809 - update to 2.1.0
810
811 * Wed Jul 7 2004  Elliot Lee <sopwith@redhat.com> 2.0.7-3
812 - Back to rawhide
813
814 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
815 - rebuilt
816
817 * Tue May 11 2004 Elliot Lee <sopwith@redhat.com> 2.0.7-1.1
818 - Update config again
819
820 * Fri May  7 2004 Jeremy Katz <katzj@redhat.com> 2.0.7-1
821 - update to 2.0.7
822 - change config to point to final FC2 locations
823
824 * Fri Apr 16 2004 Jeremy Katz <katzj@redhat.com> - 2.0.7-0.20040416
825 - new snap 
826
827 * Sat Apr  3 2004 Jeremy Katz <katzj@redhat.com> 2.0.7-0.20040403
828 - new snap, should fix yum -e name.arch
829
830 * Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.0.6-1
831 - update to 2.0.6
832
833 * Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> 2.0.5.20040310-1
834 - update to today's snap
835
836 * Wed Mar  3 2004 Jeremy Katz <katzj@redhat.com> 2.0.5.20040303-1
837 - today's snap
838
839 * Tue Mar  2 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040229-1
840 - update again per seth's request
841
842 * Thu Feb 26 2004 Florian La Roche <Florian.LaRoche@redhat.de>
843 - mv /etc/init.d -> /etc/rc.d/init.d
844
845 * Tue Feb 24 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040224-1
846 - newer
847
848 * Mon Feb 23 2004 Jeremy Katz <katzj@redhat.com> - 2.0.5.20040223-1
849 - update to current snapshot per skvidal's request
850 - add retries=20 to yum.conf
851
852 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
853 - rebuilt
854
855 * Fri Jan 23 2004 Bill Nottingham <notting@redhat.com> 2.0.4.20040103-1
856 - update to current snapshot
857 - fix config for FC2 test 1
858
859 * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 2.0.4-5
860 - build yum daily snapshot for amd64 fix.
861
862 * Wed Nov 12 2003 Bill Nottingham <notting@redhat.com> 2.0.4-4
863 - patch for excluding dirs in yum-arch from CVS
864
865 * Thu Nov  6 2003 Jeremy Katz <katzj@redhat.com> 2.0.4-3
866 - patch to work with python 2.3 from Seth
867
868 * Wed Oct 29 2003 Elliot Lee <sopwith@redhat.com> 2.0.4-2
869 - Stick in a new yum.conf for FC1.
870
871 * Mon Oct 20 2003 Florian La Roche <Florian.LaRoche@redhat.de>
872 - new upstream release 2.0.4
873
874 * Tue Sep 16 2003 Jeff Johnson <jbj@redhat.com> 2.0.3-1
875 - update to 2.0.3
876 - drop yum-init patch, merged into 2.0.3.
877 - change rpm version requirement to 4.1.1.
878
879 * Thu Jul 24 2003 Florian La Roche <Florian.LaRoche@redhat.de>
880 - change init script to more current RHL style
881
882 * Wed Jul 23 2003 Nalin Dahyabhai <nalin@redhat.com>
883 - require libxml2-python, because yum does
884
885 * Thu Jul 17 2003 Jeff Johnson <jbj@redhat.com> 2.0-1
886 - update to 2.0.
887
888 * Thu May 22 2003 Jeff Johnson <jbj@redhat.com> 1.98-0.20030522
889 - update to snapshot.
890
891 * Mon May 12 2003 Jeff Johnson <jbj@redhat.com> 1.98-0.20030512
892 - create.