Setting tag iproute2-2.6.37-2
[iproute2.git] / iproute.spec
1 %define name iproute
2 %define version 2.6.37
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 %define cbq_version v0.7.3
8
9 Vendor: PlanetLab
10 Packager: PlanetLab Central <support@planet-lab.org>
11 Distribution: PlanetLab %{plrelease}
12 URL: %{SCMURL}
13
14 Summary: Advanced IP routing and network device configuration tools.
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Group: Applications/System
19 #Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
20 #URL:    http://developer.osdl.org/dev/iproute2/
21 Source: iproute2-%{version}.tar.bz2
22 Patch1: gre.patch
23 Patch2: compile.patch
24 License: GNU GPL
25 BuildRoot: %{_tmppath}/%{name}-%{version}-root
26 BuildRequires: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
27
28 %description
29 The iproute package contains networking utilities (ip and rtmon, for
30 example) which are designed to use the advanced networking
31 capabilities of the Linux 2.4.x and 2.6.x kernel.
32
33 %prep
34 %setup -q -n iproute2-%{version}
35 %patch1 -p1
36 %patch2 -p1
37
38 %build
39 make
40 #make -C doc
41
42 %install
43 #rm -rf $RPM_BUILD_ROOT
44 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
45
46 mkdir -p $RPM_BUILD_ROOT/sbin \
47          $RPM_BUILD_ROOT%{_sbindir} \
48          $RPM_BUILD_ROOT%{_mandir}/man8 \
49          $RPM_BUILD_ROOT/etc/iproute2 \
50          $RPM_BUILD_ROOT%{_datadir}/tc \
51
52 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
53 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
54 install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
55 install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
56 rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
57 iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
58 install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
59 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
60
61 cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
62 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
63
64 %clean
65 #rm -rf $RPM_BUILD_ROOT
66 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(-,root,root)
70 %dir /etc/iproute2
71 %doc README.decnet README.iproute2+tc RELNOTES
72 #%doc doc/*.ps
73 %doc examples
74 /sbin/*
75 %{_mandir}/man8/*
76 %attr(644,root,root) %config(noreplace) /etc/iproute2/*
77 %{_sbindir}/*
78 %dir %{_datadir}/tc
79 %{_datadir}/tc/*
80
81 %changelog
82 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iproute2-2.6.37-2
83 - only a cleaner specfile
84
85 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iproute2-2.6.37-1
86 - dont rebuild doc
87
88 * Fri Apr 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iproute2-2.6.33-2
89 - Fix taglevel
90
91 * Thu Jun 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iproute2-2.6.16-2
92 - Should fix build error caused by new version of kernel headers.:
93
94 * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
95 - update to iproute-2.6.11
96
97 * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
98 - gcc4 rebuilt
99
100 * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
101 - update to iproute-2.6.10
102
103 * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
104 - added arpd into sbin
105
106 * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
107 - debug info removed from makefile and from spec (#140891)
108
109 * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
110 - source file updated from snapshot version
111 - endian patch adding <endian.h> 
112
113 * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
114 - added installation of netem module for tc
115
116 * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
117 - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
118
119 * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
120 - updated to iproute-2.6.9, spec file change, patches cleared
121
122 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
123 - rebuilt
124
125 * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
126 - Took tons of manpages from debian, much more complete (#123952).
127
128 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
129 - rebuilt
130
131 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
132 - Built security errata version for FC1.
133
134 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
135 - Fixed -f option for ss (#118355).
136 - Small description fix (#110997).
137 - Added initialization of some vars (#74961). 
138 - Added patch to initialize "default" rule as well (#60693).
139
140 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
141 - rebuilt
142
143 * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
144 - Security errata for netlink (CAN-2003-0856).
145
146 * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
147 - Updated to latest version. Used by other distros, so seems stable. ;-)
148 - Quite a few patches needed updating in that turn.
149 - Added ss (#107363) and several other new nifty tools.
150
151 * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
152 - rebuilt
153
154 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
155 - rebuilt
156
157 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
158 - rebuilt
159
160 * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
161 - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
162
163 * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
164 - remove flags patch at author's request
165
166 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
167 - automated rebuild
168
169 * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
170 - Don't forcibly strip binaries
171
172 * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
173 - Fixed missing diffserv and atm support in config (#57278).
174 - Fixed inconsistent numeric base problem for command line (#65473).
175
176 * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
177 - Added patch to fix crosscompiling by Adrian Linkins.
178
179 * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
180 - Update to latest stable release 2.4.7-now-ss010824.
181 - Added simple man page for ip.
182
183 * Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
184 - allow setting of allmulti & promisc flags (#48669)
185
186 * Mon Jul 02 2001 Than Ngo <than@redhat.com>
187 - fix build problem in beehive if kernel-sources is not installed
188
189 * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
190 - updated to iproute2-2.2.4-now-ss001007.tar.gz 
191 - bzip2 source tar file
192 - "License" replaces "Copyright"
193 - added "BuildPrereq: tetex-latex tetex-dvips psutils"
194 - rebuilt for 7.2
195
196 * Tue May  1 2001 Bill Nottingham <notting@redhat.com>
197 - use the system headers - the included ones are broken
198 - ETH_P_ECHO went away
199
200 * Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
201 - test for specific KERNEL_INCLUDE directories.
202
203 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
204 - rebuild for 7.1
205
206 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
207 - add default configuration files for iproute (Bug #10549, #18887)
208
209 * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
210 - fix include-glibc/ to cope with glibc 2.2 new resolver headers
211
212 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
213 - automatic rebuild
214
215 * Sun Jun 18 2000 Than Ngo <than@redhat.de>
216 - rebuilt in the new build environment
217 - use RPM macros
218 - handle RPM_OPT_FLAGS
219
220 * Sat Jun 03 2000 Than Ngo <than@redhat.de>
221 - fix iproute to build with new glibc
222
223 * Fri May 26 2000 Ngo Than <than@redhat.de>
224 - update to 2.2.4-now-ss000305
225 - add configuration files
226
227 * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
228 - strip binaries
229
230 * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
231 - first build