change taglevel
[iproute2.git] / iproute.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iproute
7 %define version 2.6.33
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define cbq_version v0.7.3
13
14 Vendor: PlanetLab
15 Packager: PlanetLab Central <support@planet-lab.org>
16 Distribution: PlanetLab %{plrelease}
17 URL: %(echo %{url} | cut -d ' ' -f 2)
18
19 Summary: Advanced IP routing and network device configuration tools.
20 Name: %{name}
21 Version: %{version}
22 Release: %{release}
23 Group: Applications/System
24 #Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
25 #URL:    http://developer.osdl.org/dev/iproute2/
26 Source: iproute2-%{version}.tar.bz2
27 Patch1: gre.patch
28 License: GNU GPL
29 BuildRoot: %{_tmppath}/%{name}-%{version}-root
30 BuildPrereq: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
31
32 %description
33 The iproute package contains networking utilities (ip and rtmon, for
34 example) which are designed to use the advanced networking
35 capabilities of the Linux 2.4.x and 2.6.x kernel.
36
37 %prep
38 %setup -q -n iproute2-%{version}
39 %patch1 -p1
40
41 %build
42 make
43 make -C doc
44
45 %install
46 #rm -rf $RPM_BUILD_ROOT
47 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
48
49 mkdir -p $RPM_BUILD_ROOT/sbin \
50          $RPM_BUILD_ROOT%{_sbindir} \
51          $RPM_BUILD_ROOT%{_mandir}/man8 \
52          $RPM_BUILD_ROOT/etc/iproute2 \
53          $RPM_BUILD_ROOT%{_datadir}/tc \
54
55 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
56 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
57 install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
58 install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
59 rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
60 iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
61 install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
62 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
63
64 cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
65 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
66
67 %clean
68 #rm -rf $RPM_BUILD_ROOT
69 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(-,root,root)
73 %dir /etc/iproute2
74 %doc README.decnet README.iproute2+tc RELNOTES
75 %doc doc/*.ps examples
76 /sbin/*
77 %{_mandir}/man8/*
78 %attr(644,root,root) %config(noreplace) /etc/iproute2/*
79 %{_sbindir}/*
80 %dir %{_datadir}/tc
81 %{_datadir}/tc/*
82
83 %changelog
84 * Thu Jun 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iproute2-2.6.16-2
85 - Should fix build error caused by new version of kernel headers.:
86
87 * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
88 - update to iproute-2.6.11
89
90 * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
91 - gcc4 rebuilt
92
93 * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
94 - update to iproute-2.6.10
95
96 * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
97 - added arpd into sbin
98
99 * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
100 - debug info removed from makefile and from spec (#140891)
101
102 * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
103 - source file updated from snapshot version
104 - endian patch adding <endian.h> 
105
106 * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
107 - added installation of netem module for tc
108
109 * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
110 - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
111
112 * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
113 - updated to iproute-2.6.9, spec file change, patches cleared
114
115 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
116 - rebuilt
117
118 * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
119 - Took tons of manpages from debian, much more complete (#123952).
120
121 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
122 - rebuilt
123
124 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
125 - Built security errata version for FC1.
126
127 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
128 - Fixed -f option for ss (#118355).
129 - Small description fix (#110997).
130 - Added initialization of some vars (#74961). 
131 - Added patch to initialize "default" rule as well (#60693).
132
133 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
134 - rebuilt
135
136 * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
137 - Security errata for netlink (CAN-2003-0856).
138
139 * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
140 - Updated to latest version. Used by other distros, so seems stable. ;-)
141 - Quite a few patches needed updating in that turn.
142 - Added ss (#107363) and several other new nifty tools.
143
144 * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
145 - rebuilt
146
147 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
148 - rebuilt
149
150 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
151 - rebuilt
152
153 * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
154 - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
155
156 * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
157 - remove flags patch at author's request
158
159 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
160 - automated rebuild
161
162 * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
163 - Don't forcibly strip binaries
164
165 * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
166 - Fixed missing diffserv and atm support in config (#57278).
167 - Fixed inconsistent numeric base problem for command line (#65473).
168
169 * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
170 - Added patch to fix crosscompiling by Adrian Linkins.
171
172 * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
173 - Update to latest stable release 2.4.7-now-ss010824.
174 - Added simple man page for ip.
175
176 * Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
177 - allow setting of allmulti & promisc flags (#48669)
178
179 * Mon Jul 02 2001 Than Ngo <than@redhat.com>
180 - fix build problem in beehive if kernel-sources is not installed
181
182 * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
183 - updated to iproute2-2.2.4-now-ss001007.tar.gz 
184 - bzip2 source tar file
185 - "License" replaces "Copyright"
186 - added "BuildPrereq: tetex-latex tetex-dvips psutils"
187 - rebuilt for 7.2
188
189 * Tue May  1 2001 Bill Nottingham <notting@redhat.com>
190 - use the system headers - the included ones are broken
191 - ETH_P_ECHO went away
192
193 * Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
194 - test for specific KERNEL_INCLUDE directories.
195
196 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
197 - rebuild for 7.1
198
199 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
200 - add default configuration files for iproute (Bug #10549, #18887)
201
202 * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
203 - fix include-glibc/ to cope with glibc 2.2 new resolver headers
204
205 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
206 - automatic rebuild
207
208 * Sun Jun 18 2000 Than Ngo <than@redhat.de>
209 - rebuilt in the new build environment
210 - use RPM macros
211 - handle RPM_OPT_FLAGS
212
213 * Sat Jun 03 2000 Than Ngo <than@redhat.de>
214 - fix iproute to build with new glibc
215
216 * Fri May 26 2000 Ngo Than <than@redhat.de>
217 - update to 2.2.4-now-ss000305
218 - add configuration files
219
220 * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
221 - strip binaries
222
223 * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
224 - first build