bump to 2.6.34
[iproute2.git] / iproute.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iproute
7 %define version 2.6.34
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define cbq_version v0.7.3
13
14 Vendor: PlanetLab
15 Packager: PlanetLab Central <support@planet-lab.org>
16 Distribution: PlanetLab %{plrelease}
17 URL: %(echo %{url} | cut -d ' ' -f 2)
18
19 Summary: Advanced IP routing and network device configuration tools.
20 Name: %{name}
21 Version: %{version}
22 Release: %{release}
23 Group: Applications/System
24 #Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
25 #URL:    http://developer.osdl.org/dev/iproute2/
26 Source: iproute2-%{version}.tar.bz2
27 Patch1: gre.patch
28 License: GNU GPL
29 BuildRoot: %{_tmppath}/%{name}-%{version}-root
30 BuildPrereq: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
31
32 %description
33 The iproute package contains networking utilities (ip and rtmon, for
34 example) which are designed to use the advanced networking
35 capabilities of the Linux 2.4.x and 2.6.x kernel.
36
37 %prep
38 %setup -q -n iproute2-%{version}
39 %patch1 -p1
40
41 %build
42 make
43 make -C doc
44
45 %install
46 #rm -rf $RPM_BUILD_ROOT
47 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
48
49 mkdir -p $RPM_BUILD_ROOT/sbin \
50          $RPM_BUILD_ROOT%{_sbindir} \
51          $RPM_BUILD_ROOT%{_mandir}/man8 \
52          $RPM_BUILD_ROOT/etc/iproute2 \
53          $RPM_BUILD_ROOT%{_datadir}/tc \
54
55 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
56 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
57 install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
58 install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
59 rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
60 iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
61 install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
62 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
63
64 cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
65 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
66
67 %clean
68 #rm -rf $RPM_BUILD_ROOT
69 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(-,root,root)
73 %dir /etc/iproute2
74 %doc README.decnet README.iproute2+tc RELNOTES
75 %doc doc/*.ps examples
76 /sbin/*
77 %{_mandir}/man8/*
78 %attr(644,root,root) %config(noreplace) /etc/iproute2/*
79 %{_sbindir}/*
80 %dir %{_datadir}/tc
81 %{_datadir}/tc/*
82
83 %changelog
84 * Fri Apr 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iproute2-2.6.33-2
85 - Fix taglevel
86
87 * Thu Jun 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iproute2-2.6.16-2
88 - Should fix build error caused by new version of kernel headers.:
89
90 * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
91 - update to iproute-2.6.11
92
93 * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
94 - gcc4 rebuilt
95
96 * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
97 - update to iproute-2.6.10
98
99 * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
100 - added arpd into sbin
101
102 * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
103 - debug info removed from makefile and from spec (#140891)
104
105 * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
106 - source file updated from snapshot version
107 - endian patch adding <endian.h> 
108
109 * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
110 - added installation of netem module for tc
111
112 * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
113 - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
114
115 * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
116 - updated to iproute-2.6.9, spec file change, patches cleared
117
118 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
119 - rebuilt
120
121 * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
122 - Took tons of manpages from debian, much more complete (#123952).
123
124 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
125 - rebuilt
126
127 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
128 - Built security errata version for FC1.
129
130 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
131 - Fixed -f option for ss (#118355).
132 - Small description fix (#110997).
133 - Added initialization of some vars (#74961). 
134 - Added patch to initialize "default" rule as well (#60693).
135
136 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
137 - rebuilt
138
139 * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
140 - Security errata for netlink (CAN-2003-0856).
141
142 * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
143 - Updated to latest version. Used by other distros, so seems stable. ;-)
144 - Quite a few patches needed updating in that turn.
145 - Added ss (#107363) and several other new nifty tools.
146
147 * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
148 - rebuilt
149
150 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
151 - rebuilt
152
153 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
154 - rebuilt
155
156 * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
157 - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
158
159 * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
160 - remove flags patch at author's request
161
162 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
163 - automated rebuild
164
165 * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
166 - Don't forcibly strip binaries
167
168 * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
169 - Fixed missing diffserv and atm support in config (#57278).
170 - Fixed inconsistent numeric base problem for command line (#65473).
171
172 * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
173 - Added patch to fix crosscompiling by Adrian Linkins.
174
175 * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
176 - Update to latest stable release 2.4.7-now-ss010824.
177 - Added simple man page for ip.
178
179 * Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
180 - allow setting of allmulti & promisc flags (#48669)
181
182 * Mon Jul 02 2001 Than Ngo <than@redhat.com>
183 - fix build problem in beehive if kernel-sources is not installed
184
185 * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
186 - updated to iproute2-2.2.4-now-ss001007.tar.gz 
187 - bzip2 source tar file
188 - "License" replaces "Copyright"
189 - added "BuildPrereq: tetex-latex tetex-dvips psutils"
190 - rebuilt for 7.2
191
192 * Tue May  1 2001 Bill Nottingham <notting@redhat.com>
193 - use the system headers - the included ones are broken
194 - ETH_P_ECHO went away
195
196 * Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
197 - test for specific KERNEL_INCLUDE directories.
198
199 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
200 - rebuild for 7.1
201
202 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
203 - add default configuration files for iproute (Bug #10549, #18887)
204
205 * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
206 - fix include-glibc/ to cope with glibc 2.2 new resolver headers
207
208 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
209 - automatic rebuild
210
211 * Sun Jun 18 2000 Than Ngo <than@redhat.de>
212 - rebuilt in the new build environment
213 - use RPM macros
214 - handle RPM_OPT_FLAGS
215
216 * Sat Jun 03 2000 Than Ngo <than@redhat.de>
217 - fix iproute to build with new glibc
218
219 * Fri May 26 2000 Ngo Than <than@redhat.de>
220 - update to 2.2.4-now-ss000305
221 - add configuration files
222
223 * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
224 - strip binaries
225
226 * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
227 - first build