arranged for the module-tagging script
[iproute2.git] / iproute.spec
1 #
2 # $Id: myplc.spec 7268 2007-12-01 00:09:11Z dhozac $
3 #
4 %define url $URL$
5
6 %define name iproute
7 %define version 2.6.16
8 %define subversion 1
9
10 %define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: Advanced IP routing and network device configuration tools.
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Group: Applications/System
22 #Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
23 #URL:    http://developer.osdl.org/dev/iproute2/
24 Source: %{name}-%{version}.tar.gz
25 %define SOURCE1 ip.8
26 %define SOURCE2 tc.8
27 %define SOURCE3 tc-cbq.8
28 %define SOURCE4 tc-cbq-details.8
29 %define SOURCE5 tc-htb.8
30 %define SOURCE6 tc-pbfifo.8
31 %define SOURCE7 tc-pfifo_fast.8
32 %define SOURCE8 tc-prio.8
33 %define SOURCE9 tc-red.8
34 %define SOURCE10 tc-sfq.8
35 %define SOURCE11 tc-tbf.8
36 License: GNU GPL
37 BuildRoot: %{_tmppath}/%{name}-%{version}-root
38 BuildPrereq: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
39
40 %description
41 The iproute package contains networking utilities (ip and rtmon, for
42 example) which are designed to use the advanced networking
43 capabilities of the Linux 2.4.x and 2.6.x kernel.
44
45 %prep
46 %setup -q
47
48 %build
49 make
50 make -C doc
51
52 %install
53 #rm -rf $RPM_BUILD_ROOT
54 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
55
56 mkdir -p $RPM_BUILD_ROOT/sbin \
57          $RPM_BUILD_ROOT%{_sbindir} \
58          $RPM_BUILD_ROOT%{_mandir}/man8 \
59          $RPM_BUILD_ROOT/etc/iproute2 \
60          $RPM_BUILD_ROOT%{_libdir}/tc
61
62 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
63 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
64 install -m 755 tc/q_netem.so $RPM_BUILD_ROOT%{_libdir}/tc
65 install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_libdir}/tc
66 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_mandir}/man8
67 install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_mandir}/man8
68 install -m 644 %{SOURCE3} $RPM_BUILD_ROOT/%{_mandir}/man8
69 install -m 644 %{SOURCE4} $RPM_BUILD_ROOT/%{_mandir}/man8
70 install -m 644 %{SOURCE5} $RPM_BUILD_ROOT/%{_mandir}/man8
71 install -m 644 %{SOURCE6} $RPM_BUILD_ROOT/%{_mandir}/man8
72 install -m 644 %{SOURCE7} $RPM_BUILD_ROOT/%{_mandir}/man8
73 install -m 644 %{SOURCE8} $RPM_BUILD_ROOT/%{_mandir}/man8
74 install -m 644 %{SOURCE9} $RPM_BUILD_ROOT/%{_mandir}/man8
75 install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/%{_mandir}/man8
76 install -m 644 %{SOURCE11} $RPM_BUILD_ROOT/%{_mandir}/man8
77
78 cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
79 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
80
81 %clean
82 #rm -rf $RPM_BUILD_ROOT
83 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root)
87 %dir /etc/iproute2
88 %doc README.decnet README.iproute2+tc RELNOTES
89 %doc doc/*.ps examples
90 /sbin/*
91 %{_mandir}/man8/*
92 %attr(644,root,root) %config(noreplace) /etc/iproute2/*
93 %{_sbindir}/*
94 %{_libdir}/tc/*
95
96 %changelog
97 * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
98 - update to iproute-2.6.11
99
100 * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
101 - gcc4 rebuilt
102
103 * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
104 - update to iproute-2.6.10
105
106 * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
107 - added arpd into sbin
108
109 * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
110 - debug info removed from makefile and from spec (#140891)
111
112 * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
113 - source file updated from snapshot version
114 - endian patch adding <endian.h> 
115
116 * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
117 - added installation of netem module for tc
118
119 * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
120 - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
121
122 * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
123 - updated to iproute-2.6.9, spec file change, patches cleared
124
125 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
126 - rebuilt
127
128 * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
129 - Took tons of manpages from debian, much more complete (#123952).
130
131 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
132 - rebuilt
133
134 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
135 - Built security errata version for FC1.
136
137 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
138 - Fixed -f option for ss (#118355).
139 - Small description fix (#110997).
140 - Added initialization of some vars (#74961). 
141 - Added patch to initialize "default" rule as well (#60693).
142
143 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
144 - rebuilt
145
146 * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
147 - Security errata for netlink (CAN-2003-0856).
148
149 * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
150 - Updated to latest version. Used by other distros, so seems stable. ;-)
151 - Quite a few patches needed updating in that turn.
152 - Added ss (#107363) and several other new nifty tools.
153
154 * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
155 - rebuilt
156
157 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
158 - rebuilt
159
160 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
161 - rebuilt
162
163 * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
164 - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
165
166 * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
167 - remove flags patch at author's request
168
169 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
170 - automated rebuild
171
172 * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
173 - Don't forcibly strip binaries
174
175 * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
176 - Fixed missing diffserv and atm support in config (#57278).
177 - Fixed inconsistent numeric base problem for command line (#65473).
178
179 * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
180 - Added patch to fix crosscompiling by Adrian Linkins.
181
182 * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
183 - Update to latest stable release 2.4.7-now-ss010824.
184 - Added simple man page for ip.
185
186 * Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
187 - allow setting of allmulti & promisc flags (#48669)
188
189 * Mon Jul 02 2001 Than Ngo <than@redhat.com>
190 - fix build problem in beehive if kernel-sources is not installed
191
192 * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
193 - updated to iproute2-2.2.4-now-ss001007.tar.gz 
194 - bzip2 source tar file
195 - "License" replaces "Copyright"
196 - added "BuildPrereq: tetex-latex tetex-dvips psutils"
197 - rebuilt for 7.2
198
199 * Tue May  1 2001 Bill Nottingham <notting@redhat.com>
200 - use the system headers - the included ones are broken
201 - ETH_P_ECHO went away
202
203 * Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
204 - test for specific KERNEL_INCLUDE directories.
205
206 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
207 - rebuild for 7.1
208
209 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
210 - add default configuration files for iproute (Bug #10549, #18887)
211
212 * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
213 - fix include-glibc/ to cope with glibc 2.2 new resolver headers
214
215 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
216 - automatic rebuild
217
218 * Sun Jun 18 2000 Than Ngo <than@redhat.de>
219 - rebuilt in the new build environment
220 - use RPM macros
221 - handle RPM_OPT_FLAGS
222
223 * Sat Jun 03 2000 Than Ngo <than@redhat.de>
224 - fix iproute to build with new glibc
225
226 * Fri May 26 2000 Ngo Than <than@redhat.de>
227 - update to 2.2.4-now-ss000305
228 - add configuration files
229
230 * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
231 - strip binaries
232
233 * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
234 - first build