bump to 2.6.37
[iproute2.git] / iproute.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iproute
7 %define version 2.6.37
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define cbq_version v0.7.3
13
14 Vendor: PlanetLab
15 Packager: PlanetLab Central <support@planet-lab.org>
16 Distribution: PlanetLab %{plrelease}
17 URL: %(echo %{url} | cut -d ' ' -f 2)
18
19 Summary: Advanced IP routing and network device configuration tools.
20 Name: %{name}
21 Version: %{version}
22 Release: %{release}
23 Group: Applications/System
24 #Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
25 #URL:    http://developer.osdl.org/dev/iproute2/
26 Source: iproute2-%{version}.tar.bz2
27 Patch1: gre.patch
28 Patch2: compile.patch
29 License: GNU GPL
30 BuildRoot: %{_tmppath}/%{name}-%{version}-root
31 BuildPrereq: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
32
33 %description
34 The iproute package contains networking utilities (ip and rtmon, for
35 example) which are designed to use the advanced networking
36 capabilities of the Linux 2.4.x and 2.6.x kernel.
37
38 %prep
39 %setup -q -n iproute2-%{version}
40 %patch1 -p1
41 %patch2 -p1
42
43 %build
44 make
45 make -C doc
46
47 %install
48 #rm -rf $RPM_BUILD_ROOT
49 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
50
51 mkdir -p $RPM_BUILD_ROOT/sbin \
52          $RPM_BUILD_ROOT%{_sbindir} \
53          $RPM_BUILD_ROOT%{_mandir}/man8 \
54          $RPM_BUILD_ROOT/etc/iproute2 \
55          $RPM_BUILD_ROOT%{_datadir}/tc \
56
57 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
58 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
59 install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
60 install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
61 rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
62 iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
63 install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
64 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
65
66 cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
67 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
68
69 %clean
70 #rm -rf $RPM_BUILD_ROOT
71 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(-,root,root)
75 %dir /etc/iproute2
76 %doc README.decnet README.iproute2+tc RELNOTES
77 %doc doc/*.ps examples
78 /sbin/*
79 %{_mandir}/man8/*
80 %attr(644,root,root) %config(noreplace) /etc/iproute2/*
81 %{_sbindir}/*
82 %dir %{_datadir}/tc
83 %{_datadir}/tc/*
84
85 %changelog
86 * Fri Apr 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iproute2-2.6.33-2
87 - Fix taglevel
88
89 * Thu Jun 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iproute2-2.6.16-2
90 - Should fix build error caused by new version of kernel headers.:
91
92 * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
93 - update to iproute-2.6.11
94
95 * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
96 - gcc4 rebuilt
97
98 * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
99 - update to iproute-2.6.10
100
101 * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
102 - added arpd into sbin
103
104 * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
105 - debug info removed from makefile and from spec (#140891)
106
107 * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
108 - source file updated from snapshot version
109 - endian patch adding <endian.h> 
110
111 * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
112 - added installation of netem module for tc
113
114 * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
115 - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
116
117 * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
118 - updated to iproute-2.6.9, spec file change, patches cleared
119
120 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
121 - rebuilt
122
123 * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
124 - Took tons of manpages from debian, much more complete (#123952).
125
126 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
127 - rebuilt
128
129 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
130 - Built security errata version for FC1.
131
132 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
133 - Fixed -f option for ss (#118355).
134 - Small description fix (#110997).
135 - Added initialization of some vars (#74961). 
136 - Added patch to initialize "default" rule as well (#60693).
137
138 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
139 - rebuilt
140
141 * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
142 - Security errata for netlink (CAN-2003-0856).
143
144 * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
145 - Updated to latest version. Used by other distros, so seems stable. ;-)
146 - Quite a few patches needed updating in that turn.
147 - Added ss (#107363) and several other new nifty tools.
148
149 * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
150 - rebuilt
151
152 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
153 - rebuilt
154
155 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
156 - rebuilt
157
158 * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
159 - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
160
161 * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
162 - remove flags patch at author's request
163
164 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
165 - automated rebuild
166
167 * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
168 - Don't forcibly strip binaries
169
170 * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
171 - Fixed missing diffserv and atm support in config (#57278).
172 - Fixed inconsistent numeric base problem for command line (#65473).
173
174 * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
175 - Added patch to fix crosscompiling by Adrian Linkins.
176
177 * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
178 - Update to latest stable release 2.4.7-now-ss010824.
179 - Added simple man page for ip.
180
181 * Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
182 - allow setting of allmulti & promisc flags (#48669)
183
184 * Mon Jul 02 2001 Than Ngo <than@redhat.com>
185 - fix build problem in beehive if kernel-sources is not installed
186
187 * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
188 - updated to iproute2-2.2.4-now-ss001007.tar.gz 
189 - bzip2 source tar file
190 - "License" replaces "Copyright"
191 - added "BuildPrereq: tetex-latex tetex-dvips psutils"
192 - rebuilt for 7.2
193
194 * Tue May  1 2001 Bill Nottingham <notting@redhat.com>
195 - use the system headers - the included ones are broken
196 - ETH_P_ECHO went away
197
198 * Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
199 - test for specific KERNEL_INCLUDE directories.
200
201 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
202 - rebuild for 7.1
203
204 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
205 - add default configuration files for iproute (Bug #10549, #18887)
206
207 * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
208 - fix include-glibc/ to cope with glibc 2.2 new resolver headers
209
210 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
211 - automatic rebuild
212
213 * Sun Jun 18 2000 Than Ngo <than@redhat.de>
214 - rebuilt in the new build environment
215 - use RPM macros
216 - handle RPM_OPT_FLAGS
217
218 * Sat Jun 03 2000 Than Ngo <than@redhat.de>
219 - fix iproute to build with new glibc
220
221 * Fri May 26 2000 Ngo Than <than@redhat.de>
222 - update to 2.2.4-now-ss000305
223 - add configuration files
224
225 * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
226 - strip binaries
227
228 * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
229 - first build