bump to latest stable and change repository layout
[iproute2.git] / iproute.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iproute
7 %define version 2.6.33
8 %define taglevel 2
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define cbq_version v0.7.3
13
14 Vendor: PlanetLab
15 Packager: PlanetLab Central <support@planet-lab.org>
16 Distribution: PlanetLab %{plrelease}
17 URL: %(echo %{url} | cut -d ' ' -f 2)
18
19 Summary: Advanced IP routing and network device configuration tools.
20 Name: %{name}
21 Version: %{version}
22 Release: %{release}
23 Group: Applications/System
24 #Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
25 #URL:    http://developer.osdl.org/dev/iproute2/
26 Source: iproute2-%{version}.tar.bz2
27 License: GNU GPL
28 BuildRoot: %{_tmppath}/%{name}-%{version}-root
29 BuildPrereq: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
30
31 %description
32 The iproute package contains networking utilities (ip and rtmon, for
33 example) which are designed to use the advanced networking
34 capabilities of the Linux 2.4.x and 2.6.x kernel.
35
36 %prep
37 %setup -q -n iproute2-%{version}
38
39 %build
40 make
41 make -C doc
42
43 %install
44 #rm -rf $RPM_BUILD_ROOT
45 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
46
47 mkdir -p $RPM_BUILD_ROOT/sbin \
48          $RPM_BUILD_ROOT%{_sbindir} \
49          $RPM_BUILD_ROOT%{_mandir}/man8 \
50          $RPM_BUILD_ROOT/etc/iproute2 \
51          $RPM_BUILD_ROOT%{_datadir}/tc \
52
53 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
54 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
55 install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
56 install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
57 rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
58 iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
59 install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
60 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
61
62 cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
63 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
64
65 %clean
66 #rm -rf $RPM_BUILD_ROOT
67 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(-,root,root)
71 %dir /etc/iproute2
72 %doc README.decnet README.iproute2+tc RELNOTES
73 %doc doc/*.ps examples
74 /sbin/*
75 %{_mandir}/man8/*
76 %attr(644,root,root) %config(noreplace) /etc/iproute2/*
77 %{_sbindir}/*
78 %dir %{_datadir}/tc
79 %{_datadir}/tc/*
80
81 %changelog
82 * Thu Jun 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iproute2-2.6.16-2
83 - Should fix build error caused by new version of kernel headers.:
84
85 * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
86 - update to iproute-2.6.11
87
88 * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
89 - gcc4 rebuilt
90
91 * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
92 - update to iproute-2.6.10
93
94 * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
95 - added arpd into sbin
96
97 * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
98 - debug info removed from makefile and from spec (#140891)
99
100 * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
101 - source file updated from snapshot version
102 - endian patch adding <endian.h> 
103
104 * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
105 - added installation of netem module for tc
106
107 * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
108 - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
109
110 * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
111 - updated to iproute-2.6.9, spec file change, patches cleared
112
113 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
114 - rebuilt
115
116 * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
117 - Took tons of manpages from debian, much more complete (#123952).
118
119 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
120 - rebuilt
121
122 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
123 - Built security errata version for FC1.
124
125 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
126 - Fixed -f option for ss (#118355).
127 - Small description fix (#110997).
128 - Added initialization of some vars (#74961). 
129 - Added patch to initialize "default" rule as well (#60693).
130
131 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
132 - rebuilt
133
134 * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
135 - Security errata for netlink (CAN-2003-0856).
136
137 * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
138 - Updated to latest version. Used by other distros, so seems stable. ;-)
139 - Quite a few patches needed updating in that turn.
140 - Added ss (#107363) and several other new nifty tools.
141
142 * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
143 - rebuilt
144
145 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
146 - rebuilt
147
148 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
149 - rebuilt
150
151 * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
152 - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
153
154 * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
155 - remove flags patch at author's request
156
157 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
158 - automated rebuild
159
160 * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
161 - Don't forcibly strip binaries
162
163 * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
164 - Fixed missing diffserv and atm support in config (#57278).
165 - Fixed inconsistent numeric base problem for command line (#65473).
166
167 * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
168 - Added patch to fix crosscompiling by Adrian Linkins.
169
170 * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
171 - Update to latest stable release 2.4.7-now-ss010824.
172 - Added simple man page for ip.
173
174 * Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
175 - allow setting of allmulti & promisc flags (#48669)
176
177 * Mon Jul 02 2001 Than Ngo <than@redhat.com>
178 - fix build problem in beehive if kernel-sources is not installed
179
180 * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
181 - updated to iproute2-2.2.4-now-ss001007.tar.gz 
182 - bzip2 source tar file
183 - "License" replaces "Copyright"
184 - added "BuildPrereq: tetex-latex tetex-dvips psutils"
185 - rebuilt for 7.2
186
187 * Tue May  1 2001 Bill Nottingham <notting@redhat.com>
188 - use the system headers - the included ones are broken
189 - ETH_P_ECHO went away
190
191 * Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
192 - test for specific KERNEL_INCLUDE directories.
193
194 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
195 - rebuild for 7.1
196
197 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
198 - add default configuration files for iproute (Bug #10549, #18887)
199
200 * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
201 - fix include-glibc/ to cope with glibc 2.2 new resolver headers
202
203 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
204 - automatic rebuild
205
206 * Sun Jun 18 2000 Than Ngo <than@redhat.de>
207 - rebuilt in the new build environment
208 - use RPM macros
209 - handle RPM_OPT_FLAGS
210
211 * Sat Jun 03 2000 Than Ngo <than@redhat.de>
212 - fix iproute to build with new glibc
213
214 * Fri May 26 2000 Ngo Than <than@redhat.de>
215 - update to 2.2.4-now-ss000305
216 - add configuration files
217
218 * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
219 - strip binaries
220
221 * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
222 - first build